Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

ОбработкаВыбора и владелец формы. Хелп

ОбработкаВыбора и владелец формы. Хелп
Я
   Плот
 
22.01.13 - 09:02
Ребята привет! Из формы документа вызываю форму выбора и передаю в нее Владельца
Процедура ОснованиеНачалоВыбора(Элемент, СтандартнаяОбработка)    
    СтандартнаяОбработка = Ложь;    
    ФормаВыбора = Справочники.Субконто.ПолучитьФормуВыбора("ФормаВыбора");
    ФормаВыбора.СправочникСписок.Отбор.Владелец.Установить(ПланыВидовХарактеристик.ВидыСубконтоБюджет.НайтиПоНаименованию("Виды целевых средств"));
    ФормаВыбора.Открыть();
КонецПроцедуры

Процедура ОснованиеОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    СтандартнаяОбработка = ложь;
    Основание = ВыбранноеЗначение;    
КонецПроцедуры
Но никакие значение не проставляется. И вообще в процедуру ОснованиеОбработкаВыбора() не заходит. Помогите пжл.
 
 
   k1us181b
 
1 - 22.01.13 - 09:05
а без строки "ФормаВыбора.СправочникСписок.Отбор.Владелец.Установить.."?
   DrShad
 
2 - 22.01.13 - 09:07
параметры ПолучитьФормуВыбора читай
   Плот
 
3 - 22.01.13 - 09:23
Процедура ОснованиеНачалоВыбора(Элемент, СтандартнаяОбработка)    
    СтандартнаяОбработка = Ложь;    
    ФормаВыбора = Справочники.Субконто.ПолучитьФормуВыбора("ФормаВыбора",Элемент);
    ФормаВыбора.Отбор.Владелец.Установить(ПланыВидовХарактеристик.ВидыСубконтоБюджет.НайтиПоНаименованию("Виды целевых средств"));
    ФормаВыбора.Открыть();
КонецПроцедуры

(1) Упс. Сенкс.
(2) Точняк. Затупил чет.
Спасибо всем!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует