Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Как быть? часть на 8 УТП, часть на 7 Комплексная.

Как быть? часть на 8 УТП, часть на 7 Комплексная.
Я
   zladenuw
 
22.01.13 - 02:31
часть фирм переехала на 8. документы набивает 1 человек. остальные врятли за месяц, два перейдут.
обмен по кд ?
Набивают тупо в 8 и все загружается в 7 ?
 
 
   zladenuw
 
1 - 22.01.13 - 02:33
как показала практика КОМ тормоз :(. файлы и то быстрее
   zladenuw
 
2 - 22.01.13 - 02:37
После загрузки в приемник  пишется файл подтверждения, с номером объекта. как часто читать такие файлы?
Сейчас ловлю блокировку объекта.
   zladenuw
 
3 - 22.01.13 - 02:38
(2)
вот так
Процедура ПолучитьПодтверждения() Экспорт

     Запрос = Новый ЗАпрос("ВЫБРАТЬ
                             |    Пользователи.ПользовательСОМ
                             |ИЗ
                             |    Справочник.Пользователи КАК Пользователи
                             |ГДЕ
                             |    Пользователи.ПользовательСОМ <> """"");
      Выборка = Запрос.Выполнить().Выбрать();
      Пока Выборка.Следующий() Цикл
         Пользователь = Выборка.ПользовательСОМ;    
    
       ПутьПодтверждений = "\\1CSQL2\storage\1С\Total\ОбменсУТП\Обмен\Подтверждения\"+Пользователь;
       Текст = Новый ЧтениеТекста;
       МЗПодтверждения = РегистрыСведений.Подтверждения.СоздатьМенеджерЗаписи();
      //Получим список документов не подтвержденных
 
       Запрос = Новый ЗАпрос("ВЫБРАТЬ
                             |    Подтверждения.Объект,
                             |    Подтверждения.УникИнд
                             |ИЗ
                             |    РегистрСведений.Подтверждения КАК Подтверждения
                             |ГДЕ
                             |    НЕ Подтверждения.Синхронизирован");
       ВыборкаЗапроса = Запрос.Выполнить().Выбрать();
       Пока ВыборкаЗапроса.Следующий() Цикл
            
           Попытка
               Текст.Открыть(ПутьПодтверждений+"\"+ВыборкаЗапроса.УникИнд+".txt",КодировкаТекста.ANSI);          
           Исключение
               Продолжить;
           КонецПопытки;
           
             Стр = Текст.ПрочитатьСтроку();
             Пока Стр <> Неопределено Цикл// строки читаются до символа перевода строки
 
                 НомерДокумента = Стр;
                 Объект = ВыборкаЗапроса.Объект.ПолучитьОбъект();
                 Если ТипЗнч(Объект.ссылка) = Тип("ДокументСсылка.ЗаявкаТО") Тогда
                     Объект.НомерАкта = НомерДокумента;
                 Иначе    
                     Объект.НомерБух  = НомерДокумента;
                 КонецЕсли; 
                 Объект.Записать();
                 
                 МЗПодтверждения.УникИнд = ВыборкаЗапроса.УникИнд;
                 МЗПодтверждения.Объект = Объект.Ссылка;
                 МЗПодтверждения.Прочитать();
                 Если МЗПодтверждения.Выбран() Тогда
                    // Сообщить("Для документа -"+Объект.Ссылка+", получен бухгалтерский код - "+ НомерДокумента);
 
                 КонецЕсли; 
                 МЗПодтверждения.УникИнд = ВыборкаЗапроса.УникИнд;
                 МЗПодтверждения.Объект = Объект.Ссылка;
                 МЗПодтверждения.Синхронизирован = Истина;
                 МЗПодтверждения.Записать();
                 Стр = Текст.ПрочитатьСтроку();
                 Сообщить("Для документа -"+Объект.Ссылка+", получен бухгалтерский код - "+ НомерДокумента);
             КонецЦикла;     
       КонецЦикла; 

          
          
      
      КонецЦикла; 
               
       
         


КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
Закон Брукера: Даже маленькая практика стоит большой теории.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует