Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

1C Розница - РМК

1C Розница - РМК
Я
   ТоненькийКлиент
 
21.01.13 - 19:11
Пытаюсь изменить количество кнопок "быстрых товаров" - не могу найти , где вообще редактируется интерфейс РМК (((
Подскажите, плиз!
 
 
   Wobland
 
1 - 21.01.13 - 19:12
в 1.0 это вроде б была форма чека
   ТоненькийКлиент
 
2 - 21.01.13 - 19:13
(1) спасибо!
   ТоненькийКлиент
 
3 - 21.01.13 - 19:35
Еще вопрос.
Добавил дополнительный ряд кнопок в интерфейс РМК.Быстрые товары.
При переходе в РМК выдает ошибку
{Документ.ЧекККМ.Форма.ФормаРегистрацииПродаж.Форма(4641)}: Поле объекта не обнаружено (Товар22)

Ошибка ведет в процедуру

ЭлементыФормы.КоманднаяПанельБыстрыеТовары.Кнопки[СтрокаКнопки.ИмяКнопки].Доступность = ЗначениеЗаполнено(СтрокаКнопки.Номенклатура);



Процедура УстановитьВидКнопокБыстрыеТовары()
    
    Если Не мИспользоватьНастройкуРМК Тогда
        ЭлементыФормы.ПанельПодборБыстрыеТовары.Доступность = Ложь;
        Возврат;
    КонецЕсли;
    
    Для Каждого СтрокаКнопки Из мНастройкаРМК.БыстрыеТовары Цикл
        
        ЭлементыФормы[СтрокаКнопки.ИмяКнопки].Доступность = ЗначениеЗаполнено(СтрокаКнопки.Номенклатура);
        
        ЭлементыФормы.КоманднаяПанельБыстрыеТовары.Кнопки[СтрокаКнопки.ИмяКнопки].Доступность = ЗначениеЗаполнено(СтрокаКнопки.Номенклатура);
        
        Если ЗначениеЗаполнено(СтрокаКнопки.Картинка) Тогда
            ЭлементыФормы[СтрокаКнопки.ИмяКнопки].Картинка = СтрокаКнопки.Картинка.Хранилище.Получить();
        Иначе
            ЭлементыФормы[СтрокаКнопки.ИмяКнопки].Заголовок = СтрокаКнопки.Название;
        КонецЕсли;
        
    КонецЦикла;
    
КонецПроцедуры

Где определяются значения этих типовых 21 кнопки? и почему на новые кнопки такая реакция?
Спасибо!
   mTema32
 
4 - 21.01.13 - 21:48
Все в модуле этой формы. Поставь точку останова в процедуре "При открытии" и пройдись отладчиком. Тогда поймешь как там формируются кнопки и почему на новые такая реакция)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует