Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Консоль отчетов

Консоль отчетов
Я
   zak555
 
21.01.13 - 15:54
Доброго времени суток !

В конструкторе СКД на закладке Настройки создал несколько Вариантов отчётов. Как в самом консоле выбрать разные варианты ?
 
 
   zak555
 
1 - 21.01.13 - 15:59
ещё называется Произвольные отчеты
   zak555
 
2 - 21.01.13 - 16:05
никто не использует консоль ?
   vmv
 
3 - 21.01.13 - 16:08
я нет - она от лукавого
   zak555
 
4 - 21.01.13 - 16:10
(3) почему нет ?
достаточно универсальное решение
   zak555
 
5 - 21.01.13 - 16:45
Если ТекущаяСтрока <> Неопределено И ТекущаяСтрока.СхемаКомпоновкиДанных <> Неопределено Тогда 
        
        НастройкиВКнопке[Строка(НомерНастройки)] = "";   
        ИмяКнопки = "К" + Строка(НомерНастройки);
        Действие = Новый Действие("ЗагрузитьНастройкиОтчета");
        НоваяКнопка = Кнопки.Добавить(ИмяКнопки, ТипКнопкиКоманднойПанели.Действие, НСтр("ru='Настройки по умолчанию'"), Действие);
        
    КонецЕсли;
    
    Если ТекущаяСтрока <> Неопределено И ТипЗнч(ТекущаяСтрока.Настройки) = Тип("ТаблицаЗначений") Тогда
        
        Для Каждого ТН Из ТекущаяСтрока.Настройки Цикл
            
            НомерНастройки = НомерНастройки + 1;
            НастройкиВКнопке[Строка(НомерНастройки)] = ТН.Имя;
            ИмяКнопки = "К" + Строка(НомерНастройки);
            Действие = Новый Действие("ЗагрузитьНастройкиОтчета");
            НоваяКнопка = Кнопки.Добавить(ИмяКнопки, ТипКнопкиКоманднойПанели.Действие, ТН.Имя, Действие);
            
            Если ПоследняяОткрытаяНастройка = ТН.Имя Тогда
                
                НоваяКнопка.Пометка = Истина;
                
            КонецЕсли;
            
        КонецЦикла;


во второе если не заходит
   pessok
 
6 - 21.01.13 - 17:03
типовая консоль отчетов? я отсюда пошел
   zak555
 
7 - 21.01.13 - 17:14
(6) да
какую предлагаешь ?
   zak555
 
8 - 21.01.13 - 18:41
!ап
   Sensodin
 
9 - 21.01.13 - 18:52
   zak555
 
10 - 21.01.13 - 19:01
(9) так нужна консоль отчётов
 
 Рекламное место пустует
   zak555
 
11 - 21.01.13 - 20:25
ап!
   WASSUP_NIGGA
 
12 - 22.01.13 - 03:27
Ненавижу типовую консоль отчетов... скачайте лучше консоль запросов которая есть как для обычного так и для упр. приложения. Лучше с ИТС диска взять.
   WASSUP_NIGGA
 
13 - 22.01.13 - 03:34
По теме: в СКД вы можете сохранить ваш новый вариант в файл, в самой консоле загрузить вариант из файла, помоему тока так
   zak555
 
14 - 22.01.13 - 07:10
(12) чем не нравится типовая консоль ?
   zak555
 
15 - 22.01.13 - 07:11
(13) но это бред какой-то, хочу который создан конструкторе СКД
   WASSUP_NIGGA
 
16 - 22.01.13 - 07:38
Я не понимаю в чем проблема вообще?

Первый вариант: Открываете консоль отчетов, новый отчет и открываете СКД, настроили как надо и на закладке "Настройки" сохраняете в файл.
При каждом открытии консоли отчетов, над второй колонкой жмёте загрузить настройки.


Второй вариант:
Открываете консоль отчетов, в СКД делаете все делат, потом в самом отчете, настраиваете в самой консоле во второй и третьей колонке всё как надо и жмёте вверху консоли (перед знаком вопроса) "Сохранить настройки (для текущего пользователя)" и всё.
Потом при октрытии консоли, грузите настройки для текущего пользователя (можно много вариантов сохранить)
   WASSUP_NIGGA
 
17 - 22.01.13 - 07:41
Третий вариант, в первой колонке создавать отчеты и настривать каждый как надо через СКД.

Потом сохраняете всё отчеты в 1 файл, при каждом открытии консоли грузите файл и у вас будет сразу хоть 10 вариантов отчета
   WASSUP_NIGGA
 
18 - 22.01.13 - 07:42
если вы имели ввиду "Почему в СКД я настроил отчет, группировки и т.д, закрыл окно а консоль выдаёт пустой вариант", так работает эта обработка, после СКД во второй колонке отчета добавьте группировки
   zak555
 
19 - 22.01.13 - 07:57
(16) тупость в том, что есть и так один файл .dcf, в котором описаны и так все варианты
зачем ещё плодить к каждому варианту файд *.xxl ?
   zak555
 
20 - 22.01.13 - 07:57
*xml
   WASSUP_NIGGA
 
21 - 22.01.13 - 08:03
щас всё сделал заново.

Открыл консоль отчетов, в первой колонке добавил два отчета.
Выбрал первый отчет настроил вторую колонку, группировки и т.д. потом когда закончил настройки жму вверху консоли (где знако вопроса) сохраняю настройки (поставьте обязательно галочку возле настройки), потом так же со вторым вариантом, потом сохраняю отчеты в файл dcf.

Итог: При открытии обработки "Консоль отчетов" автоматом грузится мой файл dcf в котором два рабочих отчета (два варианта) запускаются при нажатии.
   zak555
 
22 - 22.01.13 - 08:07
(21) так в одном dcf находится один отчёт с двумя настройками
вот какие эти настройки вызывать

если зайти в режим редактирования СКД и поставить нужный пользовательский вариант первым в списке, то при загрузки настроек по умолчанию он загрузить то, что нужно
   zak555
 
23 - 22.01.13 - 08:40
думаю, что возможность выбора варианта СКД надо добавить в контекстное меню

как сделать разный набор выбора для разных отчётов ?

http://savepic.org/2564729.jpg
   WASSUP_NIGGA
 
24 - 22.01.13 - 09:07
Стока страданий и ради чего?
Вы могли с самого начала в первой таблице консолди, создать два отчета и изменить каждый по своему, сохранить настройки (где знакор вопроса) и сохранить в файл, всё.

Ну ок сделаю скрин
   zak555
 
25 - 22.01.13 - 09:13
(24) боюсь, что пользователь запутается
   WASSUP_NIGGA
 
26 - 22.01.13 - 09:20
Вот пример:
http://img339.imageshack.us/img339/2111/21512268.png

Сделал минимальный вариант отчета.
Всё что нужно будет пользователю:
1) Открыть обработку "Консоль отчетов"
2) Выбрать из первой таблицы любой из отчетов(вариантов)

Сохраняется в файл и грузится он автоматом.
   zak555
 
27 - 22.01.13 - 10:14
а как тогда пользовательские поля организовать для все вариантов одинаковый ?


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует