Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

УФ. Ругается на ошибку при обращении к общему модулю.

УФ. Ругается на ошибку при обращении к общему модулю.
Я
   espanol
 
21.01.13 - 14:33
В команде объекта:

&НаСервере
Функция ПечатнаяФорма(ПараметрКоманды)
    ТабличныйДокумент                     = Новый ТабличныйДокумент;
    ТабличныйДокумент.ОтображатьСетку     = Ложь;
    ТабличныйДокумент.Защита              = Ложь;
    ТабличныйДокумент.ТолькоПросмотр      = Ложь;
    ТабличныйДокумент.ОтображатьЗаголовки = Ложь;
    ТабличныйДокумент.АвтоМасштаб         = Истина;
    ТабличныйДокумент.ОриентацияСтраницы  = ОриентацияСтраницы.Портрет;
    Сформирован                           = Ложь;
    
    Документ = ПараметрКоманды.ПолучитьОбъект();
    Если НЕ Документ.Проведен Тогда
        Сообщение            = Новый СообщениеПользователю();
        Сообщение.Текст      = "Документ не проведен: " + Строка(Документ);
        Сообщение.КлючДанных = ПараметрКоманды;
        Сообщение.Сообщить();
    КонецЕсли;
    Документ.ПечатьДоговорАктФиз(ТабличныйДокумент);
    Сформирован = Истина;
    
    Если Сформирован Тогда
        Возврат ТабличныйДокумент;
    Иначе
        Возврат Неопределено;
    КонецЕсли;
КонецФункции

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    ТабличныйДокумент = ПечатнаяФорма(ПараметрКоманды);
    Если ТабличныйДокумент <> Неопределено Тогда
        ТабличныйДокумент.Показать();
    КонецЕсли;
КонецПроцедуры


В модуле документа:

Функция ПечатьДоговорАктФиз(ТабДокумент) Экспорт

ОбластьМакетаШапки.Параметры.ПодписантФИО     = МодульПечатиАвтосалона.Падеж(ФИО, 2);


Ошибка:

{Документ.ЗаказНаАвтомобиль.МодульОбъекта(2869,51)}: Переменная не определена (МодульПечатиАвтосалона)
        ОбластьМакетаШапки.Параметры.ПодписантФИО     = <<?>>МодульПечатиАвтосалона.Падеж(ФИО, 2);
 
 
   Wobland
 
1 - 21.01.13 - 14:34
ага, буду знать, спасибо
   vmv
 
2 - 21.01.13 - 14:35
контекст исполнения МодульПечатиАвтосалона сатри и беги отсюда с такими познаниями
   espanol
 
3 - 21.01.13 - 14:35
Почему ошибка то? Как правильно обратится?
   Wobland
 
4 - 21.01.13 - 14:37
(3) уважаемый модуль, видимый на сервере...
   Надсмотрщик
 
5 - 21.01.13 - 14:38
(3) "Ваша Честь"!
   espanol
 
6 - 21.01.13 - 14:40
Блин, галочка у общего модуля снята была
   vmv
 
7 - 21.01.13 - 14:41
(6) видимо не зря, убиваешь конфу с головы - такова задача?)
   espanol
 
8 - 21.01.13 - 14:42
И почему тут сидят 99% де%илы, вместо помощи издеваются сидят, горите в аду пи%орасы )))
   espanol
 
9 - 21.01.13 - 14:42
(7) счего бы вдруг то?
   Wobland
 
10 - 21.01.13 - 14:42
эх, опять я без спасибы...
 
 Рекламное место пустует
   vmv
 
11 - 21.01.13 - 14:42
когда мы говорим ПЕЧАТЬ, то сразу подразумаваем КЛИЕНТ - все остальные ассоциации ущербны в зародыше
   vmv
 
12 - 21.01.13 - 14:44
(8) смачная истеричка мдя, в Гелендык в этом году не съездил и вот результат - нервы растрепаны)
   Wobland
 
13 - 21.01.13 - 14:44
(11) а я вот на сервере регламентно формировал печатные формы и слал по почте...
   espanol
 
14 - 21.01.13 - 14:44
(11) ты не угадал, модель содержит другие данные
   vmv
 
15 - 21.01.13 - 14:46
(11) тогда эту модель созвали специалисты с характеристками из (8), ты не их идеолог часом?
   espanol
 
16 - 21.01.13 - 14:47
(15) хватит выеживаться чувак, ты не самый умный и не телепат, коли не знаешь задачи, то не пукай в лужу, выглядеть будешь хотя бы умным.
   vmv
 
17 - 21.01.13 - 14:47
(13) это рассылка(отправка) отчетов во вне - допустима такая стратегия в этом случае
   vmv
 
18 - 21.01.13 - 14:48
(16) я первым дал правильный ответ, так что я практически гений 1С эээ 2-й в истории, а вот кто ты уже понятно)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует