Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Документы поиск по номеру

Документы поиск по номеру
Я
   ReZеt
 
21.01.13 - 09:34
Здравствуйте. Не могу обратиться к документы написал следующий код
     &НаКлиенте
Процедура СоздатьНовыйДокумент(Команда)
   
       // Вставить содержимое обработчика.
 
        Если СоздатьНовыйДокументНаСервере() = 0 Тогда
                Сообщить("Не удалось создать новый документ");
        КонецЕсли;

    КонецПроцедуры
    &НаСервере
    Функция   СоздатьНовыйДокументНаСервере()
        Перем НоваяПлПор;
        Перем СтрокаТЧ;
        НоваяПлПор=Документы.ПлатежноеПоручение.НайтиПоНомеру("00000007619");
        НоваяПлПор.ПолучитьФорму();
        Сообщить(НоваяПлПор.Дата);
КонецФункции
После чего он мне дату выдает 01.01.0001 0:00:00
А должен 10.01.2012 10:57:20
Подскажите что не так
 
 
   DrShad
 
1 - 21.01.13 - 09:35
потому что он тебе пустую ссылку находит
   DrShad
 
2 - 21.01.13 - 09:35
и с таким кодом никто тебе ничего не должен
   ReZеt
 
3 - 21.01.13 - 09:37
Пустую? Такс но документ существует все реквизиты забиты и проведен он
   organizm
 
4 - 21.01.13 - 09:37
сделай лучше запрос и никого не мучай
   ReZеt
 
5 - 21.01.13 - 09:37
Да мне тут вообще ни кто не должен
   ReZеt
 
6 - 21.01.13 - 09:38
А чем код не нравиться? (2)
   DrShad
 
7 - 21.01.13 - 09:40
(6) слишком много лишнего и нет понятия о том что делаешь
   SerF_2011
 
8 - 21.01.13 - 09:45
(0) <Дата интервала> (необязательный)
Тип: Дата. Дата из интервала, в котором проводится поиск по номеру. Сам интервал определяется как период уникальности номеров документа, в который входит указанная дата. Например, если номера документов уникальны в пределах месяца и задана дата 10 декабря 2001 года, то поиск будет проводиться в интервале с 01 по 31 декабря 2001 года.
   ReZеt
 
9 - 21.01.13 - 09:47
(7) Ну да второе точно а вот первое не знаю лишнее или нет ))
   Godofsin
 
10 - 21.01.13 - 09:49
правильный ответ в (8)
 
 Рекламное место пустует
   ReZеt
 
11 - 21.01.13 - 09:52
Ну то есть мне нужно написать что 
НоваяПлПор=Документы.ПлатежноеПоручение.НайтиПоНомеру("00000007619","01.01.2012");
   ReZеt
 
12 - 21.01.13 - 09:53
Получилось)))))))
   Aleksey
 
13 - 21.01.13 - 09:53
(11) да
   ReZеt
 
14 - 21.01.13 - 09:53
Спасибо
   Defender aka LINN
 
15 - 21.01.13 - 09:54
(11) Дата должна быть датой, как ни парадоксально.
   ReZеt
 
16 - 21.01.13 - 09:55
(15) Все я все понял )
   SerF_2011
 
17 - 21.01.13 - 09:56
(11) Как говорится, во тебе и новый год пришел некстати.
   ReZеt
 
18 - 21.01.13 - 09:57
НоваяПлПор=Документы.ПлатежноеПоручение.НайтиПоНомеру("00000007618","01.01.2012 0:00:00");
   ReZеt
 
19 - 21.01.13 - 09:59
Скажите а как сделать перебор всех документов ну вот к примеру платежное поручение
   Reset
 
20 - 21.01.13 - 09:59
А зачем его вообще искать, если требуется СоздатьНовыйДокументНаСервере?
   ReZеt
 
21 - 21.01.13 - 10:00
Да не требуется просто интересно все разбираюсь сижу вот и спрашиваю до чего не догоняю
   Reset
 
22 - 21.01.13 - 10:01
А зачем назвал Создать, если этого не требуется? :)
   ReZеt
 
23 - 21.01.13 - 10:03
Ну почему почему потому что код черновой, я его скопипастил и сижу курю потихоньку (22)
   SerF_2011
 
24 - 21.01.13 - 10:07
(19) а зачем тебе перебор прям всех документов?
   Reset
 
25 - 21.01.13 - 10:08
Тебе сначала надо исправлять вот это "нет понятия о том что делаешь"
Для это формировать для себя четкую цель и искать средства ее выполнить. А не наоборот, делать хоть что-то, хз зачем.
   ReZеt
 
26 - 21.01.13 - 10:10
Ну все все равно спасибо Всем понятливым и не очень


Список тем форума
Рекламное место пустует  Рекламное место пустует
Чтобы обнаруживать ошибки, программист должен иметь ум, которому доставляет удовольствие находить изъяны там, где, казалось, царят красота и совершенство.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует