Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Как то что отметил через список значений записать в справочник

Как то что отметил через список значений записать в справочник
Я
   sr_deadman
 
20.01.13 - 16:15
Мне надо записать в справочник данные которые я отметил через список значений
Выборка = Справочники.ВариантыОбедов.Выбрать();
СписокЗначений = Новый СписокЗначений;
Пока Выборка.Следующий() Цикл
     Если Не Выборка.ПометкаУдаления Тогда
         СписокЗначений.Добавить(Выборка.Ссылка);
     КонецЕсли;
 КонецЦикла;
СписокЗначений.ОтметитьЭлементы("Выберите обед");
надо записать в справочник
 
 
   Нуф-Нуф
 
1 - 20.01.13 - 16:21
подразумеваю у тебя какой-то вопрос?
   sr_deadman
 
2 - 20.01.13 - 16:22
да СписокЗначений есть функция ОтметитьЭлементы возвращает ложь если не отметил и истина если отметил надо мне то что я отметил записать в справочник
   DrShad
 
3 - 20.01.13 - 16:23
используй процедуру ЗаписатьВРандомныйСправочникТоЧтоЯОтметилВСпискеЗначений()
   sr_deadman
 
4 - 20.01.13 - 16:24
это че за функция
   DrShad
 
5 - 20.01.13 - 16:25
это не функция, а процедура!
   sr_deadman
 
6 - 20.01.13 - 16:26
а как мне ее использовать
   DrShad
 
7 - 20.01.13 - 16:27
вызывай
   sr_deadman
 
8 - 20.01.13 - 16:29
такой процедуры нет хватит прикалываться
   DrShad
 
9 - 20.01.13 - 16:31
какой вопрос - такой ответ
   sr_deadman
 
10 - 20.01.13 - 16:32
ну это серьезно у меня горит мне надо эту задачу решить
 
 Рекламное место пустует
   wertyu
 
11 - 20.01.13 - 16:33
типичная ошибка, когда что-то горит, надо не на мисту писать, а звонить пожарным!
   DrShad
 
12 - 20.01.13 - 16:34
мы тебе мешаем?
   Dен
 
13 - 20.01.13 - 16:34
(0) А что в справочник записывать?
Ты же все читаешь из справочника, значит там все есть.
   sr_deadman
 
14 - 20.01.13 - 16:35
ну которые я в отметке выбрал надо записать в справочник

задача вот
Результат выбора пользователя записывайте в справочник
«ОбедыПользователей». При выборе нескольких вариантов выполняйте запись
нескольких элементов справочника;
   wertyu
 
15 - 20.01.13 - 16:37
Объект = Справочники.ОбедыПользователей.СоздатьЭлемент();
Объект.Записать();
   Dен
 
16 - 20.01.13 - 16:38
(14) И что неполучается?
   wertyu
 
17 - 20.01.13 - 16:39
всё это внутри цикла:
Для Каждого э Из СписокЗначений Цикл
Если э.Пометка Тогда
Объект = Справочники.ОбедыПользователей.СоздатьЭлемент(); 
Объект.Записать();
КонецЕсли;
КонецЦикла;
   sr_deadman
 
18 - 20.01.13 - 16:39
Да записать надо не просто справочник а элементы которые я выбрал
   wertyu
 
19 - 20.01.13 - 16:43
так запиши не просто справочник:

Для Каждого э Из СписокЗначений Цикл 
Если э.Пометка Тогда
Объект = Справочники.ОбедыПользователей.СоздатьЭлемент();
Объект.Наименование = "это не просто запись, я это выбрал!" 
Объект.Записать();
КонецЕсли;
КонецЦикла;
   sr_deadman
 
20 - 20.01.13 - 16:57
это не поможет Пометка возвращает Истина и Ложь это булево а надо значение
   Ткачев
 
21 - 20.01.13 - 17:04
...
Объект.Наименование = Э.Значение;
...
   sr_deadman
 
22 - 20.01.13 - 17:06
а надо значение которое пометил
   wertyu
 
23 - 20.01.13 - 17:31
нельзя, это значение станет незначительным, а нужно только значительные
   skillhoster
 
24 - 20.01.13 - 21:48
У вас есть справочник, ВариантыОбедов, вы загоняете его в СписокЗначений и предоставляете пользователю отметить некоторые элементы списка, затем, исходя из отметок пользователя вы делаете что? Перезаписываете ВариантыОбедов сами в себя, или выбранные значения вам нужно записать в какой-то другой справочник?
В общем в любом случае, СписокЗначений - это коллекция, и у каждого элемента этой коллекции есть свойство Пометка, есть свойство Значение. В свойстве Значение будет содержаться ссылка на ваш исходный справочник. Можете делать с ней что хотите.

Ну или просто нужно почистить кэш.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует