Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Макеты

Макеты
Я
   andrew31575
 
19.01.13 - 15:22
У меня есть печатная форма кредитного документа..мне надо чтобы одна область "ПОДВАЛ" выводилась только в конце страницы.а у меня она выводится сразу после предыдушей области..помоги оформить это дело
 
 
   Рэйв
 
1 - 19.01.13 - 15:27
Убери вывод подвала из цикла вывода строк
   andrew31575
 
2 - 19.01.13 - 15:31
а он не в цикле
   Prikum
 
3 - 19.01.13 - 15:42
(2) Код покажи!
   andrew31575
 
4 - 19.01.13 - 15:52
Процедура Печать(ТабДок, Ссылка) Экспорт
   //{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
 
    Макет = Документы.КупляПродажа1.ПолучитьМакет("Печать");
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    КупляПродажа1.Дата,
    |    КупляПродажа1.Номер,
    |    КупляПродажа1.Организация,
    |    КупляПродажа1.Покупатель,
    |    КупляПродажа1.СуммаКвартирыСПроцентами,
    |    КупляПродажа1.ТабКредит.(
    |        НомерСтроки,
    |        ДатаОплаты,
    |        СуммаОплаты,
    |        ОстатокДолга
    |    )
    |ИЗ
    |    Документ.КупляПродажа1 КАК КупляПродажа1
    |ГДЕ
    |    КупляПродажа1.Ссылка В (&Ссылка)";
    Запрос.Параметры.Вставить("Ссылка", Ссылка);
    Выборка = Запрос.Выполнить().Выбрать();

    ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
    Шапка = Макет.ПолучитьОбласть("Шапка");
    ОбластьТабКредитШапка = Макет.ПолучитьОбласть("ТабКредитШапка");
    ОбластьТабКредит = Макет.ПолучитьОбласть("ТабКредит");
    ТабДок.Очистить();

    ВставлятьРазделительСтраниц = Ложь;
    Пока Выборка.Следующий() Цикл
        Если ВставлятьРазделительСтраниц Тогда
            ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
        КонецЕсли;

        ТабДок.Вывести(ОбластьЗаголовок);

        Шапка.Параметры.Заполнить(Выборка);
        ТабДок.Вывести(Шапка, Выборка.Уровень());

        ТабДок.Вывести(ОбластьТабКредитШапка);
        ВыборкаТабКредит = Выборка.ТабКредит.Выбрать();
        Пока ВыборкаТабКредит.Следующий() Цикл
            ОбластьТабКредит.Параметры.Заполнить(ВыборкаТабКредит);
            ТабДок.Вывести(ОбластьТабКредит, ВыборкаТабКредит.Уровень());
        КонецЦикла;

        ВставлятьРазделительСтраниц = Истина;
    КонецЦикла;
   //}}
 
    ОблПодвал = Макет.ПолучитьОбласть("Подвал");
    ТабДок.Вывести(ОблПодвал);
   КонецПроцедуры
   Рэйв
 
5 - 19.01.13 - 15:56
не может у тебя при таком коде подвал несколько раз выводится.
Если ты конечн функцию несколько раз не вызываешь
   mikecool
 
6 - 19.01.13 - 15:57
после вывода таблицы выводи пустые строки до тех пор, пока не останется место только для подвала - вот тут его и выводи
   andrew31575
 
7 - 19.01.13 - 15:59
не помежете непосредственно кодом?хотя бы наведите..я новичок просто

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует