Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Как узнать текущий объект....

v7: Как узнать текущий объект....
Я
   tmpnikl
 
17.01.13 - 12:32
Разбираю код
    Спр=СоздатьОбъект("Справочник.x");
    Род = СоздатьОбъект("Справочник.x");
    Род.ВыбратьЭлементы();
    Пока Род.ПолучитьЭлемент() > 0 Цикл
        Если (Род.ЭтоГруппа() = 1 )  Тогда
            Прервать;
        КонецЕсли;
    КонецЦикла;

       ВыбратьСтроки(); 
    Пока ПолучитьСтроку()=1 Цикл
    КонецЦикла;
К какому объекту применяется команда ВыбратьСтроки() к объекту Спр или к объекту Род, по аналогии есть такое понятие в бд. если алиас не укзан(x.table), то команды применяется к текущей таблице, следовательно как можно здесь узнать текущий объект?
PS: Просьба кто тут собрался посмеяться, не отвечать...
 
 
   ДенисЧ
 
1 - 17.01.13 - 12:33
а где этот код находится?
ВыбратьСтроки() применяется к контексту
   Азат
 
2 - 17.01.13 - 12:34
а у тебя синтакс-помощника нет в 1С-е?
ВыбратьСтроки - к табличной части дока или к ТЗ
   Mikeware
 
3 - 17.01.13 - 12:34
(2) а то ты не видишь, кто первый ему ответил....
   Dolly_EV
 
4 - 17.01.13 - 12:34
(2) в таком виде - только к ТЧ дока
   Азат
 
5 - 17.01.13 - 12:35
(3) инет медленный, с опозданием увидел...
   Dolly_EV
 
6 - 17.01.13 - 12:35
(0) Этот код - из формы документа? вот к нему (документу) это и относится
   tmpnikl
 
7 - 17.01.13 - 12:37
Да понял, относится к документу..., спасибо...
   ДенисЧ
 
8 - 17.01.13 - 12:37
А вот теперь можно и посмеяться :-)

Продам СП, дорого.
   Надсмотрщик
 
9 - 17.01.13 - 12:44
(8) Без отката мне СП не продашь!
   Mikeware
 
10 - 17.01.13 - 12:45
(5) дык продавец СП и ответил. вывод - он знал...
 
 Рекламное место пустует
   Privalov
 
11 - 17.01.13 - 12:48
мля..

Список тем форума
Рекламное место пустует  Рекламное место пустует
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует