Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Как происходит сортировка таблицы значений

v7: Как происходит сортировка таблицы значений
Я
   Масянька
 
16.01.13 - 16:00
И снова - здравствуйте!

Если кто знает - просветите, как происходит сортировка в таблице значений.
Кратко - на форме ТЗ. Заполняется номенклатурой с некими параметрами из документа. Есть возможность сортировки (поле со списком на той же форме). Как можно осуществить "Без сортировки" - начальное состояние ТЗ сразу после заполнения?

Спасибо.
 
 
   КонецЦикла
 
1 - 16.01.13 - 16:02
Нетривиально...
1. Не сортировать
2. Убрать упорядочивание из запроса или как она там формируется
   Масянька
 
2 - 16.01.13 - 16:05
(1) Ничё не поняла.
Выборка/заполнение ТЗ: перебор ТЧ документа, если номенклатура удовлетворяет заданным параметрам - в ТЗ.
Заполнили ТЗ - ничего не сортируется.
Выбрали "Сортировка по коду": ТЗ отсортировалась по коду.
А вот если выбрать "Без сортировки" - как вернуть начальное состояние ТЗ?
   Ёпрст
 
3 - 16.01.13 - 16:06
(0) завести служебную колонку, заполнить по возврастанию в момент заполнения - сортировать по ней.
   Масянька
 
4 - 16.01.13 - 16:07
(3) А по-другому - никак? До этого я и сама додумалась.
То есть получается, что ТЗ не имеет никаких индексов изначально?
   Ёпрст
 
5 - 16.01.13 - 16:08
(4)угадала.
ЗЫ: пользуй индексированнуюТЗ и табличное поле для показа - там можно.
   Масянька
 
6 - 16.01.13 - 16:09
(5) А это чего?
   КонецЦикла
 
7 - 16.01.13 - 16:09
(2) Елы-палы, теперь понятно :)
Если выгружать ТЧ документа, то есть колоночка с номером строки документа
(4) Изначально вообще данные обычно не упорядочиваются
   Ёпрст
 
8 - 16.01.13 - 16:11
   Mikeware
 
9 - 16.01.13 - 16:15
+(8) Или класс ПоставщикДанных
   Масянька
 
10 - 16.01.13 - 16:21
Ну вас в баню! Я сейчас опять выпаду из жизни на пару дней - пока разберусь с (7). :)))))))
Лучше я добавлю эту долбанную колонку.
 
 Рекламное место пустует
   КонецЦикла
 
11 - 16.01.13 - 16:23
(10) Правильно, лучше это время на Хрюнделя потратить
   Mikeware
 
12 - 16.01.13 - 16:25
(11) что ты называешь "хрюнделем"?
Аналог горжетки?
-----------
"Как уберечь горжетку от выпадания волос ?
- Что такое горжетка, мы не знаем, но догадываемся.
Рекомендуем не ездить на лошади верхом, на велосипеде,
а также не мыться жесткой мочалкой."©АР
   Дык ё
 
13 - 16.01.13 - 17:34
(12) это бойфренд Масяни в оригинальном мульте

Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует