Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Восстановление поврежденной файловой базы. Возможно?

v7: Восстановление поврежденной файловой базы. Возможно?
Я
   Denis_Spb
 
16.01.13 - 11:58
Столкнулся с такой проблемой, в файловой базе 1С Бухгалтерии, пропали документы. Стирание индексов и индексирование - не помогло. На копии базы провел ТИИ. Вылезли ошибки:
Файл 1SJOURN.dbf. Запись 19. После CLOSED. Неверное содержимое поля Numeric - ""
И дальше многочисленные записи с текстом:
Неверный признак удаленности записи.

Что с этим можно сделать?
 
 
   Стрелок
 
1 - 16.01.13 - 11:59
руками отменить все признаки удаления в редакторе dbf. после лопатить базу на предмет удаления того что должно быть удалено
   Стрелок
 
2 - 16.01.13 - 11:59
или руками пометить на удаление эту запись с пустым номером
   vde69
 
3 - 16.01.13 - 12:02
сделать копию базы !!!!!!!!!!!!!!

на копии базы !!!!!!!!!!!!!!

1. удалить файл 1SJOURN.dbf
2. зайти в конфигуратор, что-то изменить (например синоним конфигурации). нажать сохранить
3. выполнить ТИИ в режиме создания обьектов
   DimGan
 
4 - 16.01.13 - 12:04
(3)Может не стоит совсем журнал удалять? Взять с последнего бэкапа, а потом ТиИ с созданием... И то не факт, что оживет.
   Стрелок
 
5 - 16.01.13 - 12:05
(3) проведение (признак) навернётся. документы будут полупыстыми.. фигня всё это - имхо только руками или полностью базу из бекапа
   BlackSeaCat
 
6 - 16.01.13 - 12:06
Нанять специалиста еще не предлагали?
   Vladal
 
Модератор
7 - 16.01.13 - 12:14
BlackSeaCat, флуд в тематике не допускается.

Если хочешь предложить, пиши прямо: "Наймите специалиста" и подскажи, где его найти.
   Ёпрст
 
8 - 16.01.13 - 12:22
(3) самый нелепый совет на счет удаления 1sjourn
   Ёпрст
 
9 - 16.01.13 - 12:23
(0) открыть 1sjourn любым дбф редактором и исправит запись.
Либо update таблички через прямой запрос
   Ёпрст
 
10 - 16.01.13 - 12:25
+9 можно еще маркер удаленных записей прибить, ДО ТиИ.
 
 Рекламное место пустует
   Denis_Spb
 
11 - 16.01.13 - 12:31
Как исправить? Что именно править? Прошу прощения, за тупые вопросы, просто никогда dbf файлы руками не правил.
   Ёпрст
 
12 - 16.01.13 - 12:33
(11) Копия базы есть до ТиИ хоть ?
   Denis_Spb
 
13 - 16.01.13 - 12:36
Есть. ТиИ делал только с копией.
   Ёпрст
 
14 - 16.01.13 - 12:38
(13) выкладывай в архиве на файлопомойку на поглядеть
   Denis_Spb
 
15 - 16.01.13 - 12:38
1SJOURN.dbf? или что-то еще?
   Ёпрст
 
16 - 16.01.13 - 12:40
(15) всю базу целиком.
Интересуют только файлы *.dbf,*.md и *.dd
вот их в архив запакуй и кидай на файлопомойку.
   Ёпрст
 
17 - 16.01.13 - 12:40
и базы, только ДО твоих всех действий.
   Denis_Spb
 
18 - 16.01.13 - 12:54
Ссылку сюда кидать?
   Ёпрст
 
19 - 16.01.13 - 12:57
ну да, если не хочешь светить базу всем учасникам форума, кидай на eprst@mail.ru
   Denis_Spb
 
20 - 16.01.13 - 12:58
Отправил
   Ёпрст
 
21 - 16.01.13 - 13:05
Ну.. 1sjourn явно из какой-то копии (или из восстановления удаленных файлов) был слеплен - в нём только начало есть и всё.

Т.е целые доки только за чуть-чуть 10 год, в остальных строках мусор.

Восстановить можно, но не всё.

Архивов, нема ?
файл *.mlg есть в \syslog ?
   Ёпрст
 
22 - 16.01.13 - 13:07
Хотя бы проводки целы.
ЗЫ: mlg нужон для нумеров документов.
   КонецЦикла
 
23 - 16.01.13 - 13:14
(3) Это что за неудачная шутка?
Откуда 1С возьмет сведения для восстановления полей журнала?

(22) А позиции документов, общие реквизиты?
Я бы без бэкапа и не дергался
   Ёпрст
 
24 - 16.01.13 - 13:16
(23) это все ёсть
Общий реквизиты, там только один - комментарий, он неогр.длины , так что есть

Нужны только нумера доков..
всё собственно.
   Ёпрст
 
25 - 16.01.13 - 13:17
(23) ну, 1с-ина восстановит при ТиИ.. только вот это будут доки все не проведенные. и т.д
   vde69
 
26 - 16.01.13 - 14:52
(23) (25)

почему шутка... реальный совет при серьезных проблеммах с журналом

после этого можно остальное заполнять,

что-то можно будет прямым запросом из старого журнала вытащить...

остальное -
признак проведен и дату - по наличию движений у документа (или проводок),
общие реквизиты - да могут потерятся...
   КонецЦикла
 
27 - 16.01.13 - 14:56
(24) (26) Может я туплю, но как восстановить позиции документов? С номерами вроде как реально
   НЕА123
 
28 - 16.01.13 - 15:05
мда.
всегда считал что в 7-ке дата, номер дока только в 1SJOURN
   1Сергей
 
29 - 16.01.13 - 15:20
(28) ещё в журнале
   Ёпрст
 
30 - 16.01.13 - 15:23
(27) в файле проводок есть
   Ёпрст
 
31 - 16.01.13 - 15:24
на непроведенные можно и болт забить (доверенности там и прочий мусор)
   Ёпрст
 
32 - 16.01.13 - 15:24
(29) в каком журнале ?!
   1Сергей
 
33 - 16.01.13 - 15:25
(32) млг
 
 
   НЕА123
 
34 - 16.01.13 - 15:46
(29)
дык все в 1SJOURN. нет других таблиц жураналов.
   КонецЦикла
 
35 - 16.01.13 - 15:50
(30) Да... если есть быстрые движения, то, может, повезет и с регистрами :)
   Ёпрст
 
36 - 17.01.13 - 13:58
автору повезло -mlg с начала учета целый.. в общем журнальчик восстановился
   Стрелок
 
37 - 17.01.13 - 16:51
а что и как ты доставал из журнала регистрации?
   Ёпрст
 
38 - 17.01.13 - 16:52
(37) номера доков +  дату и время для не проведенных доков.
   Denis_Spb
 
39 - 17.01.13 - 21:47
Выражаю благодарность за оперативную и полезную помощь!


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует