Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: как подключить показ истории периодических реквизитов

v7: как подключить показ истории периодических реквизитов
Я
   work92
 
16.01.13 - 10:40
1
 
 
   ДенисЧ
 
1 - 16.01.13 - 10:40
программно
   cw014
 
2 - 16.01.13 - 10:41
2... Хорош цифрами сыпать

Кнопка "F5" тебе в помощь...
А если програмно, то пиши собственную форму (как в типовой торговле сделано)
   work92
 
3 - 16.01.13 - 10:44
F5 не работае может у кого небуть есть пример
   work92
 
4 - 16.01.13 - 10:50
если можно киньте форму как в типовой
   ДенисЧ
 
5 - 16.01.13 - 10:51
(4) из типовой взять - не судьба? :-)
   work92
 
6 - 16.01.13 - 10:51
или пример
   work92
 
7 - 16.01.13 - 10:53
у меня есть значек истроия но он закрыт как открыть
   ДенисЧ
 
8 - 16.01.13 - 10:53
(7) чо? Где?
   monsterZE
 
9 - 16.01.13 - 10:54
(3) клаву поменять?.. на с рабочей кнопкой =)
   work92
 
10 - 16.01.13 - 10:55
на понели но он белого цвета типа нерабочий
 
 Рекламное место пустует
   andrewalexk
 
11 - 16.01.13 - 10:57
(0):) я мог бы тебе кинуть код функции которая выводит в таблицу значений на форму всю историю...но судя по твоим вопросам ты не подключишь...
   work92
 
12 - 16.01.13 - 10:58
andrewalexk я подключу кидай
   vah1
 
13 - 16.01.13 - 11:02
(0) отчеты писать не пробовала?
   work92
 
14 - 16.01.13 - 11:07
andrewalexk так киниш код формы
   andrewalexk
 
15 - 16.01.13 - 11:09
:)

Перем Фёст;

Функция История(чПараметр=0)
    Если Фёст=0 Тогда
        форма.фИстория.Видимость(0);
        форма.ТЗИстория.Видимость(0);
       //*****************************//
 
       //*    Отображение истории    *//
 
       //*****************************//
 
        Если тзИстория.КоличествоКолонок()=0 тогда
            тзИстория.НоваяКолонка("Дата",,,,,8);
            тзИстория.НоваяКолонка("НомерДК",,,,,20);
        Иначе     
            тзИстория.УдалитьСтроки();
        КонецЕсли;     
        пПериодический=СоздатьОбъект("Периодический");
        пПериодический.ИспользоватьОбъект("НомерДК",ТекущийЭлемент());
        пПериодический.ВыбратьЗначения();
        Пока пПериодический.ПолучитьЗначение()=1 цикл
            тзИстория.НоваяСтрока(); 
            тзИстория.НомерДК=пПериодический.Значение;
            тзИстория.Дата=пПериодический.ДатаЗнач;
        КонецЦикла;
        Если тзИстория.КоличествоСтрок()>0 тогда
            тзИстория.Сортировать("Дата+");
            тзИстория.ТекущаяСтрока(тзИстория.КоличествоСтрок());    
            форма.фИстория.Видимость(1);
        КонецЕсли;    
        Фёст=1;
    КонецЕсли;
    Возврат "История ДК: "+?(ТЗИстория.ТекущаяСтрока()>0,СокрЛП(ТЗИстория.ПолучитьЗначение(ТЗИстория.ТекущаяСтрока(),"НомерДК").Владелец),"");
КонецФункции                  
 //*******************************************
 
зы
фистория - функция на форме
тзистория - тз на форме
номердк - периодический реквизит
   work92
 
16 - 16.01.13 - 11:11
andrewalexk функцию кинуть в глобальны
   1Сергей
 
17 - 16.01.13 - 11:11
у справочника вообще есть периодические реквизиты?
   work92
 
18 - 16.01.13 - 11:13
1Сергей а как узнать
   andrewalexk
 
19 - 16.01.13 - 11:16
:) локально
   andrewalexk
 
20 - 16.01.13 - 11:17
(18):)) ...потому и (11)
   work92
 
21 - 16.01.13 - 11:20
Можеш глянуть если я перекину базу
   work92
 
22 - 16.01.13 - 11:20
andrewalexk Можеш глянуть если я перекину базу
   Mikeware
 
23 - 16.01.13 - 11:21
Может, забанить поциента для чтения СП?
   ЧеловекДуши
 
24 - 16.01.13 - 11:22
Посмотри, как в ТиС-е сделано :)
   ЧеловекДуши
 
25 - 16.01.13 - 11:23
(23)Тут еще проще... надо лишь послать в нужном направлении :)
   monsterZE
 
26 - 16.01.13 - 11:24
(0) конфигуратор открой, справочники, твой справочник, значек реквизита как гиперпрыжек в звездный войнах! =))
   Svetka
 
27 - 16.01.13 - 11:24
(0) кури функцию в глобальном модуле -  глЗначенияПериодическихРеквизитов()
   monsterZE
 
28 - 16.01.13 - 11:25
если ф5 не работает, значит таких реквизитов нет =)
   Калиостро
 
29 - 16.01.13 - 11:26
(28) Бинго!
   Svetka
 
30 - 16.01.13 - 11:26
+(27) твоя задача - передать функции нужные параметры. Если не знаешь как передать - смотри примеры в типовой.
   Svetka
 
31 - 16.01.13 - 11:27
(26) Ахаха "гиперпрыжек в звездный войнах!" - интересная ассоциация))
   monsterZE
 
32 - 16.01.13 - 11:28
(29) че "бинго", может он не открывая справочник ф5 нажимает.. =))
   andrewalexk
 
33 - 16.01.13 - 11:31
(31) :)...но кривая...там приыжок в гиперпространство...а тут во времени...скорее "Назад в будущее"
 
 
   Калиостро
 
34 - 16.01.13 - 11:51
(32) см. (10)
   monsterZE
 
35 - 16.01.13 - 11:54
(34) каюсь, просмотрел =)


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует