Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: При сохранении изменений конфигуратор выдает ошибку

v7: При сохранении изменений конфигуратор выдает ошибку
Я
   sidalexsandr
 
15.01.13 - 15:10
Установлено 1с 7.7. реализ 27 + MS SQL Server 2008
Делаю:

1) Добавляю реквизит Одобрил (тип число длина 1)
2) Нажимаю сохранить
3) Конфигуратор выдает запрос "Выполнить сохранения метаданных"
4) Нажимаю "Да"

Конфигуратор выдает ошибку: База данных не может быть открыта в однопользовательском режиме.
 
 
   пипец
 
1 - 15.01.13 - 15:12
   Скользящий
 
2 - 15.01.13 - 15:12
если база скульная, то надо кварианалайзер закрыть на сервере наверно .
   varelchik
 
3 - 15.01.13 - 15:15
Либо хтось вылетел и у него висит ожибка соединения с сервером.
В квери надо этот процесс (процессы) прибить.
   sidalexsandr
 
4 - 15.01.13 - 15:19
Другие базы на этом Sql Server работают нормально. Ещё варианты.
   МихаилМ
 
5 - 15.01.13 - 15:21
посмотрите, какие процессы подключены к бд. килл процесс.
   sidalexsandr
 
6 - 15.01.13 - 15:29
Теперь выдает ошибку http://s019.radikal.ru/i617/1301/82/5cca487ee59e.png
   Umka2008
 
7 - 15.01.13 - 15:33
Перегрузите SQL
   sidalexsandr
 
8 - 15.01.13 - 15:35
(7) Проблема в том, что куча пользоавателей работает в другой базе sql - 1c на этом сервере.
   КонецЦикла
 
9 - 15.01.13 - 15:36
   lefthander
 
10 - 15.01.13 - 15:38
Отключите базу и снова подключите. На сервере.
 
 Рекламное место пустует
   sidalexsandr
 
11 - 15.01.13 - 15:39
(9) Сообщение (34) делал.
   sidalexsandr
 
12 - 15.01.13 - 15:39
(9) Не помогло.
   Холст
 
13 - 15.01.13 - 15:43
(2) где в SQL 2005 Standart  найти Query Analyzer ? не находится или как то можно установить его ?
в интернете пишут, что он только у 2000го скуля
вопрос шире - как в SQL 2005 Standart увидеть все подключения с возможность отключить произвольное ?
   lefthander
 
14 - 15.01.13 - 15:43
У нас такое случалось когда начинался бекап каталога базы архиватором и кто то оставался подключенным к базе.
   sidalexsandr
 
15 - 15.01.13 - 15:43
(10) Не помогло.
   Холст
 
16 - 15.01.13 - 15:59
(10) а не приведет ли детач при наличии подключений к падению базы в суспект при подключении потом ?
   sidalexsandr
 
17 - 15.01.13 - 16:07
Хелп ми.
   КонецЦикла
 
18 - 15.01.13 - 16:14
(13) 1. В менеджмент студио
2. В активити мониторе

(17) Что из той ветки пробовал? Там вроде вообще речь за длл-ки шла
   1Сергей
 
19 - 15.01.13 - 16:15
скопируй МД в пустую папку и попытайся изменить там
   sidalexsandr
 
20 - 15.01.13 - 17:12
(18) Повторяю подробно скопировал sqlsrv32.dll
sqlsrv32.rll
odbcbcp.dll

Не помогло
   sidalexsandr
 
21 - 15.01.13 - 17:24
(19) Отдельно изменяется. А когда пытаюсь объеденить с этим md бфзу на SQl, то старая ошибка.
   sidalexsandr
 
22 - 15.01.13 - 17:27
Перед ошибкой генерация ...
соединение с сервером Sql
обработка справочника Договоры 900 

и ошибка : http://s019.radikal.ru/i617/1301/82/5cca487ee59e.png
   Ёпрст
 
23 - 15.01.13 - 17:28
и как хоть дружил с 2008 скулем конфу ?
   sidalexsandr
 
24 - 15.01.13 - 17:29
До меня подружили. Такая ошибка стала появляться недельку назад на копии базы и сначала изредка а сейчас постоянно.
   monsterZE
 
25 - 15.01.13 - 17:30
выгрузить в дбф, исправить, загрузить обратно - работает?
   КонецЦикла
 
26 - 15.01.13 - 17:31
(24) Локальное местечко разработки со своими 1С и SQL есть?
   monsterZE
 
27 - 15.01.13 - 17:31
если в дбф-е поправится - пересоздай базу в скл и загрузи
   Ёпрст
 
28 - 15.01.13 - 17:31
ну дык.. поставь секретный релиз платформы  и на "чистый скуль" без подмены библиотек и понижения совместимости в скуле.
   sidalexsandr
 
29 - 15.01.13 - 17:32
(28) Попробую, завтро к утру загрузиться отпишусь.
   sidalexsandr
 
30 - 16.01.13 - 10:18
(25) При загрузке выдает ошибку: http://s019.radikal.ru/i617/1301/82/5cca487ee59e.png

После чего данные в базе пропали.
   Dolly_EV
 
31 - 16.01.13 - 10:58
(30) зачем тебе загрузка??? написали же в (28), чего надо сделать!
1. поставь "секретный" релиз
2. поставь (верни) "чистый" скуль
3. в базе поставь режим совместимости 90
всё
   Ёпрст
 
32 - 16.01.13 - 11:04
(31) не 90, а 100
   Trotter
 
33 - 16.01.13 - 12:31
(32) что такое режим совместимости ?
 
 
   varelchik
 
34 - 16.01.13 - 12:35
Зайди сюды http://forum.infostart.ru/forum24/topic38442/?PAGEN_1=6
и непарь людям мозги.
   пипец
 
35 - 16.01.13 - 13:12
   Trotter
 
36 - 16.01.13 - 13:15
(35) а для чего он нужен и за что отвечает ?)
   пипец
 
37 - 16.01.13 - 13:19
   пипец
 
38 - 16.01.13 - 13:22
   Dolly_EV
 
39 - 16.01.13 - 15:31
(32) угу, не доглядел, что про 2008 речь
а начать читать стоит отсюда: http://infostart.ru/public/82018/
   antistaks
 
40 - 16.01.13 - 17:16
   sidalexsandr
 
41 - 17.01.13 - 11:26
(34) Секретный реализ с инфостара не решил проблему.
   ЧеловекДуши
 
42 - 17.01.13 - 11:36
(41)Переходи на SQL2005 64бит и сервер 2003 64 бит (хоть терминал)
Или переходи на SQL 2000

Кто работает в выне 7, переведи в терминал, или сноси к такой-то маме и ставь ХП СП3.
...п.с... Админов на кол, за вынь 7 :)
   sidalexsandr
 
43 - 17.01.13 - 13:41
(42) Я программы пишу на компе, где windows 7. А база храниться на SQL server 2008.
В dbf загружается очень долго вплоть до недели.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует