Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Документ "Установка цен номенклатуры"

Документ "Установка цен номенклатуры"
Я
   pashok3108
 
15.01.13 - 11:42
Здравствуйте!
Делаю внешнюю обработку заполнения табличных частей для документа "Установка цен номенклатуры".В табличную часть необходимо добавить номенклатуры.
Подскажите как это сделать?
К чему обращаться?К табличной части товары или к табличному полю Таблица Цен?
Заранее большое спасибо
 
 
   cw014
 
1 - 15.01.13 - 11:44
Ну рискни обратиться к табличному полю, особенно вне контекста формы
   rbcvg
 
2 - 15.01.13 - 11:45
Товары. Кстати, "Загрузка данных из табличного документа" чем не устраивает?
   pashok3108
 
3 - 15.01.13 - 11:46
Строка= Док.Товары.Добавить();
Строка.Номенклатура=...;

Табличное поле остается пустым(
   Undefined vs NULL
 
4 - 15.01.13 - 11:47
(3) это не рабочий кусок кода
   demart-omsk
 
5 - 15.01.13 - 11:47
правильный ответ в (2)
   demart-omsk
 
6 - 15.01.13 - 11:48
Зачем изобретать велосипед?
   х86
 
7 - 15.01.13 - 11:56
баян вобщем-то

    ДокОбъект = Неопределено;
    Выборка = Запрос.Выполнить().Выбрать();
    Сч = 1;
    Всего = Выборка.Количество();
    Пока Выборка.Следующий() Цикл
        
        Если Сч%50 = 0 Тогда
            Состояние("Создание установки цен: [ " + Строка(Сч) + " / " + Строка(Всего) + " ]");
        КонецЕсли;
        
       //Создадим документ
 
        Если ДокОбъект = Неопределено Тогда
        
            ДокОбъект = Документы.УстановкаЦенНоменклатуры.СоздатьДокумент();
            ДокОбъект.Дата = ТекущаяДата();
            ДокОбъект.УстановитьНовыйНомер();
            
            ДокОбъект.НеПроводитьНулевыеЗначения = Истина;
            ДокОбъект.Ответственный = глЗначениеПеременной("глТекущийПользователь");
            ДокОбъект.Комментарий = "Перенос в УТ11";
            
            НаборЦен = Новый Соответствие;
        
        КонецЕсли;
        
       //Заполним табл номенклатурой
 
        СтрокаТавары = ДокОбъект.Товары.Добавить();
        ЗаполнитьЗначенияСвойств(СтрокаТавары, Выборка);
        
        НаборЦен.Вставить(Выборка.ТипЦен, "");
        
       //Запишем док или полный или каждую н-пачку
 
        Если (ДокОбъект.Товары.Количество() = 5000) или (Всего = Сч) Тогда
            
           //Заполним типами цен
 
            Для каждого КлюЗнач Из НаборЦен Цикл
            
                СтрокаТипаЦен = ДокОбъект.ТипыЦен.Добавить();
                СтрокаТипаЦен.ТипЦен = КлюЗнач.Ключ;
            
            КонецЦикла;
        
            Попытка
                ДокОбъект.Записать();
                Сообщить("Записан документ: " + ДокОбъект);
            Исключение
                Сообщить(ОписаниеОшибки());
                Прервать;
            КонецПопытки;
            
            ДокОбъект = Неопределено;
        
        КонецЕсли;
        
        Сч = Сч + 1;
        
    КонецЦикла;

   cw014
 
8 - 15.01.13 - 11:57
(3) А таблицу значений типов цен ты заполняешь? А проставляешь ключи связи таблицы типов цен и таблицы номенклатуры?

Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь во втором сообщении вам дадут решение, а в двадцатом дадут правильное решение. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует