Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Как получить набор записей до проведения документа?

Как получить набор записей до проведения документа?
Я
   AugustBlack
 
15.01.13 - 08:50
привет, бп 2.0 есть документ перемещение товаров. Необходимо добавить доп. субконто в проводки, дело в том что не хочется изменять глобальный модуль, идея в том чтобы дополнить доп. аналитикой сформированные типовыми функциями проводки

Процедура ОбработкаПроведения(Отказ, РежимПроведения)

    ***некий код***

   // Движения по документу
 
    Если Не Отказ Тогда
        ДвиженияПоРегистрам(РежимПроведения, СтруктураШапкиДокумента, ТаблицаПоТоварам, ТаблицаПоКомТоварам, ТаблицаПоТаре, Отказ, Заголовок);
    КонецЕсли;

 //получаю движения которые необходимо модифицировать
 
    
НаборЗаписейРегистра = Движения.Хозрасчетный;//все ок
 
        
НаборЗаписейРегистра.Прочитать();
 //здесь ничего нету:)        
 
Для Каждого Запись из НаборЗаписейРегистра Цикл    
            
   // Чтение и модификация очередного движения.
 
            
КонецЦикла;   

    
КонецПроцедуры// ОбработкаПроведения()
 

т.е после при чтении набора записей регистра проводки пропадают, почему так? или как можно это обойти
 
 
   AugustBlack
 
1 - 15.01.13 - 08:50
(1) при чтении набора записей регистра проводки(записи) пропадают, почему так? или как можно это обойти
   DrShad
 
2 - 15.01.13 - 08:51
делай в подписке
   чувак
 
3 - 15.01.13 - 08:52
После прочитать() передай в переменную. ИМХО
   AugustBlack
 
4 - 15.01.13 - 09:13
(2) спс,как вариант
(3) что вы имели ввиду не совсем понял
   Defender aka LINN
 
5 - 15.01.13 - 09:15
(1) Ну, надо сесть, приложить кулак ко лбу и крепко подумать - что же происходит при вызове метода "Прочитать"
   DrShad
 
6 - 15.01.13 - 09:15
(4) и не как вариант, а методически верный подход
   DrShad
 
7 - 15.01.13 - 09:16
(5) +1
и таки да читать набор не нужно ибо он еще не записан
   cw014
 
8 - 15.01.13 - 09:16
А ты попробуй без "Прочитать" :)
   Starhan
 
9 - 15.01.13 - 09:17
(0) спасибо посмеялся.
(7) зачем интригу испортил
   AugustBlack
 
10 - 15.01.13 - 09:17
(9) чем посмеялся? предложи решение
 
 Рекламное место пустует
   DrShad
 
11 - 15.01.13 - 09:18
(9) вот такая вот я гадина :))
   DrShad
 
12 - 15.01.13 - 09:19
(10) над копрокодом в (0)
   Defender aka LINN
 
13 - 15.01.13 - 09:19
(10) Гм... Автор не читатель?
   DrShad
 
15 - 15.01.13 - 09:23
(14) вот спасибо тебе мил человек
   Defender aka LINN
 
Модератор
16 - 15.01.13 - 09:23
(14) Вьюноша, а вот хамить не надо, ага?
   Starhan
 
17 - 15.01.13 - 09:28
(10) да вариантов куча.

вот эти слова "дело в том что не хочется изменять глобальный модуль,"
вообще не понятны.

В твоем случае. Надо просто убрать "прочитать()" причины уже объясняли в (7)

но правильнее (опять же как уже говорили) перенести код по изменению субкотно в подписки на события как сказали в (2)

Список тем форума
Рекламное место пустует  Рекламное место пустует
Основная теорема систематики: Новые системы плодят новые проблемы.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует