Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Нужна помощь по документу Поступления в кассу

Нужна помощь по документу Поступления в кассу
Я
   serega1977
 
15.01.13 - 08:41
УНФ 8.2.15.318
Проблема такая, при изменении вид операции - не изменяется текущая страница.
Изменение страницы должно проходит по следующей процедуре, где еще смотреть?
Процедура УставитьТекущуюСтраницу()
    
    ИмяСтраницы = "";
    
    Если Объект.ВидОперации = СтруктураВидОперации.ОтПокупателя
     ИЛИ Объект.ВидОперации = СтруктураВидОперации.ОтПоставщика Тогда
        ИмяСтраницы = "РасчетыСКонтрагентом";
    ИначеЕсли Объект.ВидОперации = СтруктураВидОперации.ОтПодотчетника Тогда
        ИмяСтраницы = "РасчетыСПодотчетником";
    ИначеЕсли Объект.ВидОперации = СтруктураВидОперации.РозничнаяВыручка Тогда
        ИмяСтраницы = "РозничнаяВыручка";
    ИначеЕсли Объект.ВидОперации = СтруктураВидОперации.РозничнаяВыручкаСуммовойУчет Тогда
        ИмяСтраницы = "РозничнаяВыручкаСуммовойУчет";
    ИначеЕсли Объект.ВидОперации = СтруктураВидОперации.Прочее Тогда
        ИмяСтраницы = "РасчетыПрочие";
    КонецЕсли;

    Элемент = Элементы.Найти(ИмяСтраницы);
    
    Если Элемент <> Неопределено Тогда
        Элементы.Страницы.ТекущаяСтраница = Элемент;
    КонецЕсли;
    
КонецПроцедуры
 
 
   cw014
 
1 - 15.01.13 - 08:42
А вызывается эта процедура при изменении вида операции??
   serega1977
 
2 - 15.01.13 - 08:53
// Процедура устанавливает текущую страницу в зависимости от вида операции
   Fedot200
 
3 - 15.01.13 - 08:57
Процедура УставитьТекущуюСтраницу()  а что такое Уставить?
   serega1977
 
4 - 15.01.13 - 09:03
(3) - в чем вопрос, так написано в модуле документа
   Prikum
 
5 - 15.01.13 - 09:04
(4) Номер конфигурации?
   serega1977
 
6 - 15.01.13 - 09:06
(5) 1.1.3.4
   Starhan
 
7 - 15.01.13 - 09:08
(0) смотреть где вызывается метод УставитьТекущуюСтраницу()
И вызываются ли те методы в которых вызвается УставитьТекущуюСтраницу()


например в Методе УстановитьВидимость.

п.с.
что за слово такое Уставить в названии метода в сабже?
это украинский или ТС перепечатывал текст в ручную?
   serega1977
 
8 - 15.01.13 - 09:12
(7) - просто скопировал и вставил (как есть)..
   serega1977
 
9 - 15.01.13 - 09:14
(7) как обычно это бывает)) никто ничего не трогал, все работало и сломалось..
   eklmn
 
10 - 15.01.13 - 09:25
сделай сравнение с конф.поставщика и посмотри различия в мдуле
 
 Рекламное место пустует
   serega1977
 
11 - 15.01.13 - 09:32
(10) - так сейчас и сделаю.. спс

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует