Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Средняя себестоимость МПЗ, при переносе из Бух7.7 в УПП

Средняя себестоимость МПЗ, при переносе из Бух7.7 в УПП
Я
   TDI
 
14.01.13 - 15:18
Подсткажите пожалуйста!
В правиле выгрузки остатков по 10сч есть такой код:
--------------------
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ИспользоватьСубконто(ВидыСубконто.Материалы,, 1);
    Ит.ИспользоватьСубконто(ВидыСубконто.МестаХранения,, 1); 
    
    
        Ит.ВыполнитьЗапрос(, ДатаВводаОстатков, "10.2",,,,,5);
    
   //    Ит.ВыполнитьЗапрос(, Параметры.ДатаВводаОстатков, Строка(ТекСчет.Код),,,,,5);
 
    
    Ит.ВыбратьСубконто(1);

    Пока Ит.ПолучитьСубконто(1) = 1 Цикл
        СуммаНаСкладах = ИТ.СКД("С");
        КоличествоНаСкладах = ИТ.СКД("К");
        ОстатокНаСкладах = КоличествоНаСкладах;
        ОстатокСуммыНаСкладах = СуммаНаСкладах;
        
        Если Ит.Субконто(1).Наименование = "РУКАВ ВС 38" Тогда
            df = 4;
        КонецЕсли;
        
        Если КоличествоНаСкладах <= 0 Тогда
            Продолжить;
        КонецЕсли;
        Ит.ВыбратьСубконто(2);
        Пока Ит.ПолучитьСубконто(2) = 1 Цикл
            КоличествоНаСкладе = ИТ.СКД("К");
            Если (КоличествоНаСкладе = 0) или (ПустоеЗначение(Ит.Субконто(2)) = 1) Тогда
               //Корректир. средней ст-ти дает такой результат
 
                Продолжить;
            КонецЕсли;
            Если ОстатокНаСкладах = КоличествоНаСкладе Тогда
                СуммаНаСкладе = ОстатокСуммыНаСкладах;
                ОстатокНаСкладах = 0;
                ОстатокСуммыНаСкладах = 0;
            Иначе
                СуммаНаСкладе = Окр(СуммаНаСкладах / КоличествоНаСкладах * КоличествоНаСкладе,2,1);
                ОстатокНаСкладах = ОстатокНаСкладах - КоличествоНаСкладе;
                ОстатокСуммыНаСкладах = ОстатокСуммыНаСкладах - СуммаНаСкладе;
            КонецЕсли;
---------------------------------

И получается что если один и тот-же материал, есть на разных складах, то его себестоимость усредняется по всем складам.
Это для чего так реализовано? Почему не переносить себестоимость, не усредняя по всем складам?
 
 
   DrShad
 
1 - 14.01.13 - 15:23
(0) т.е. ты спрашиваешь о не типовом коде!? да хз зачем вы это делали
   TDI
 
2 - 14.01.13 - 15:34
это типовой код
   DrShad
 
3 - 14.01.13 - 15:35
да ладно!?

вот это типовое!?
Если Ит.Субконто(1).Наименование = "РУКАВ ВС 38" Тогда
            df = 4;
        КонецЕсли;
   TDI
 
4 - 14.01.13 - 15:36
не, это для проверки просто добавил,
вот это имеется ввиду 
------------------
 Если ОстатокНаСкладах = КоличествоНаСкладе Тогда
                СуммаНаСкладе = ОстатокСуммыНаСкладах;
                ОстатокНаСкладах = 0;
                ОстатокСуммыНаСкладах = 0;
            Иначе
                СуммаНаСкладе = Окр(СуммаНаСкладах / КоличествоНаСкладах * КоличествоНаСкладе,2,1);
                ОстатокНаСкладах = ОстатокНаСкладах - КоличествоНаСкладе;
                ОстатокСуммыНаСкладах = ОстатокСуммыНаСкладах - СуммаНаСкладе;
            КонецЕсли;
--------------------
   DrShad
 
5 - 14.01.13 - 15:37
ну тогда скорее всего из-за этого

Если (КоличествоНаСкладе = 0) или (ПустоеЗначение(Ит.Субконто(2)) = 1) Тогда
               //Корректир. средней ст-ти дает такой результат
 
 
                Продолжить;
            КонецЕсли;
   shuhard
 
6 - 14.01.13 - 15:38
(0) о чем топик - о справедливости правил ?
   TDI
 
7 - 14.01.13 - 15:44
(6)
хочется понять для чего сделано это усреднение себестоимости по всем складам.
   TDI
 
8 - 14.01.13 - 16:05
up
   ДенисЧ
 
9 - 14.01.13 - 16:08
(7) Ну, в уппырище есть настройка, как вести суммовой учет по складам - по каждому, или в общем. Наверное, для этого.
   MrStomak
 
10 - 14.01.13 - 16:16
Потому как в Бух 7.7 нет суммы для конкретного склада, в правилах берется сумма для всех складов, потом распределяется пропорционально количеству на на каждом складе.
 
 Рекламное место пустует
   TDI
 
11 - 14.01.13 - 16:25
(10)
На субконто "Места хранения", есть учет по сумме
   DrShad
 
12 - 14.01.13 - 16:26
(10) а это что?
Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ИспользоватьСубконто(ВидыСубконто.Материалы,, 1);
    Ит.ИспользоватьСубконто(ВидыСубконто.МестаХранения,, 1);
   DrShad
 
13 - 14.01.13 - 16:27
+(12) сорри, в (10) верный ответ
   TDI
 
14 - 14.01.13 - 16:34
(13)
не понял..
Суммы же есть на конкретном складе? В оборотке если смотреть,
то сумма будет показываться итоговая по складу..
   DrShad
 
15 - 14.01.13 - 16:34
(14) а типовая обработка перехода об этом не знает ибо изначально их нет
   mr_K
 
16 - 14.01.13 - 16:37
(14) Насколько я помню, в типовой Бух 7.7 на десятке субконто МестаХранения - оборотное. в (10) - все правильно сказано

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует