Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Проблемы при создании документа

Проблемы при создании документа
Я
   TdAlex
 
12.01.13 - 10:36
Добрый день.
УТ 11, создаю документ

&НаКлиенте
Процедура СоздатьЗаказ(Команда)
    Заказ = СозданиеЗаказа(); 
    ОткрытьЗначение(Заказ);
   //ОткрытьФорму("Документ.ЗаказКлиента.Форма.ФормаДокумента", , Заказ,,); //не катит
 
    объект.Корзина.Очистить();
КонецПроцедуры

&НаСервере
Функция СозданиеЗаказа()
    ДокЗаказ = Документы.ЗаказКлиента.СоздатьДокумент();
    ДокЗаказ.Дата = ТекущаяДата();
    ДокЗаказ.Организация =  Справочники.Организации.НайтиПоНаименованию("ООО ""Легион""");
    ДокЗаказ.Статус = Перечисления.СтатусыЗаказовКлиентов.КОтгрузке;
    ДокЗаказ.Приоритет = Перечисления.Приоритеты.Средний;
    ДокЗаказ.Валюта = Валюта;
    ДокЗаказ.Менеджер = ПараметрыСеанса.ТекущийПользователь;
    ДокЗаказ.НалогообложениеНДС = Перечисления.ТипыНалогообложенияНДС.ПродажаОблагаетсяНДС;
    ДокЗаказ.ЦенаВключаетНДС = Истина;    
    
    СуммаД =0;
    Для каждого запись из Объект.Корзина цикл
        строка = ДокЗаказ.Товары.Добавить();
        строка.Номенклатура = запись.номенклатура;
        строка.ВидЦены = запись.ВидЦены;
        строка.СтавкаНДС = запись.номенклатура.СтавкаНДС;
        строка.ДатаОтгрузки = запись.ДатаОтгрузки;
        строка.Количество = запись.Количество;     
        строка.КоличествоУпаковок = запись.КоличествоУпаковок;
        строка.Цена = запись.Цена;
        строка.Сумма = запись.Сумма;
       //строка.ДатаОтгрузки = ТекущаяДата();
 
      // строка.Склад = запись.Склад;
 
       СуммаД = СуммаД+запись.Сумма; 
   КонецЦикла;
   ДокЗаказ.СуммаДокумента = СуммаД;
   
    ДокЗаказ.Записать();
    
    Возврат ДокЗаказ.ссылка;    
КонецФункции

Нумерация убита, т.к. вводят всякую фигню.
Так вот, открывается форма заказа, юзеры рцуами вводят номер, жмут Провести, и номер исчезает! Вводят его еще раз, проводят, все ок.
Вопрос, почему в первый раз, номер исчезает?
Спасибо.
 
 
   kosts
 
1 - 12.01.13 - 10:51
Номер документа автоматически присваивается только при первой записи.
   TdAlex
 
2 - 12.01.13 - 11:57
он вообще не присваивается при первой записи, т.к. нумерация сбита, а когда руками его вписывают и проводят, он очищается, вводят еще раз, проводят, остается.
Почему при первом вводе он очищается?
   kosts
 
3 - 12.01.13 - 14:03
>он вообще не присваивается при первой записи
он присваивается при первой записи, другое дело, что присваивается пустой номер.

Может автонумерация сбилась, может в какой подписке номер не правильно устанавливается. В пошаговой отладке можно поискать.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует