Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Почему не останавливается на точке остановки в управляемых формах?

Почему не останавливается на точке остановки в управляемых формах?
Я
   Zend
 
11.01.13 - 23:44
Почему иногда не останавливается на точке остановки?
Если использовать управляемые формы и запускать отладку в тонком клиенте.
 
 
   Armando
 
1 - 11.01.13 - 23:53
Потому что сервер
   Zend
 
2 - 11.01.13 - 23:56
И как быть?
   Азат
 
3 - 11.01.13 - 23:56
-debug
   Prikum
 
4 - 12.01.13 - 00:35
(3) А УФ причем?
   mikecool
 
5 - 12.01.13 - 01:10
(4) при сервере
   Zend
 
6 - 12.01.13 - 12:51
Что то не совсем понял. Что имеется ввиду сервер?
База локальная, работаю на своём компьютере.
   nunzio
 
7 - 12.01.13 - 12:56
(0) Значит не должно.
   Fragster
 
8 - 12.01.13 - 12:58
внешние обработки?
   nunzio
 
9 - 12.01.13 - 13:01
(8) Поиграем в вангу) внешние печатные формы, внешние отчеты ?
   Fragster
 
10 - 12.01.13 - 13:02
не, просто для внешних - есть http://infostart.ru/public/89283/ для внутренних - демоническое обновление какое-нибудь - там кэш прочистить надобно...
 
 Рекламное место пустует
   Fragster
 
11 - 12.01.13 - 13:03
ну и вариант-победитель - не происходит выполнения кода со строкой, где точка
   Zend
 
12 - 12.01.13 - 13:18
Нет, не внешние обработки, а всё в конфигурации и не обработки.
Нет, сточка с кодом выполняется.
   Zend
 
13 - 12.01.13 - 13:24
Заметил вот что:
Если поставить точку остановки в процедуре с директивой &НаКлиенте, то не остановиться.
А если в процедуре с директивой &НаСервере то там останавливается.
   Zend
 
15 - 12.01.13 - 14:24
)))
Ну реально, в чём у меня косяк то?
   Luhtas
 
16 - 12.01.13 - 14:33
(15)
Там три кнопки для отладки "Начать отладку", "Толстый клиент(управляемое приложение)начать отладку" и "Тонкий клиент начать отладку".
   Zend
 
17 - 12.01.13 - 14:38
(16) И? Какой мне нужен?
В любом случае нажимал на все три, результат один.
   Luhtas
 
18 - 12.01.13 - 14:42
(17) Посмотри настройки в меню: Сервис-Параметры, закладки "Запуск 1С Предприятия" и "Общие". Что там у тебя? Я запускаю "Начать отладку" - работает везде.
   Нуф-Нуф
 
19 - 12.01.13 - 14:47
ты подключен для отладки только к серверу. смотри - отладка - подключения - предметы откладки
   zak555
 
20 - 12.01.13 - 14:47
срин конфигуратора покажи
   Zend
 
21 - 12.01.13 - 14:55
(19) А что там смотреть нужно? В скрине ниже выложил что у меня там.
(20) http://s47.radikal.ru/i117/1301/22/197cbed2d75d.jpg
   monsterZE
 
22 - 12.01.13 - 15:11
(21) а че, точка останова стоит на коментарии? =)
   Zend
 
23 - 12.01.13 - 15:16
(22) Ну я для скрина открыл первую попавшуюся конфигурацию и в первое попавшиеся место. А так на строчку с кодом, который выполняется.
   sanfoto
 
24 - 12.01.13 - 16:59
Предполагаю вы ставите точку остановки внутри процедуры или функции в которой нет кода, так?

1)тогда это стандартная фича - остановки не будет.
Процедура Зпап()
 // папавпвапрапр - здесь в любом месте небудут остановки
 
КонецПроцедуры

1)не пустая процедура - с кодом
Процедура Зпап()
 // папавпвапрапр 
 
а=1;/// - здесь   БУДУТ остановки
 
КонецПроцедуры
   mikecool
 
25 - 12.01.13 - 18:10
(24) при установке точки бряка на КонецПроцедуры - остановится даже при пустой процедуре
   sanfoto
 
26 - 12.01.13 - 19:47
(25) mikecool
да, действительно если точка останова в "пустой" процедуре стоит на "КонецПроцедуры"... только тогда срабатывает))
   mikecool
 
27 - 12.01.13 - 20:00
(26) а как думаешь еще можно проверить, какой из обработчиков срабатывает - лепишь на все обработчики событий объекта формы пустые процы, находишь и ненужные удаляешь


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует