Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Перед проведением

v7: Перед проведением
Я
   Gera1t
 
11.01.13 - 21:15
Есть ли в 7 обработчик событий передпроведением,
т.е. что бы действие происходило не из модуля документа, а из формы, но только если документ проводится.
 
 
   miki
 
1 - 11.01.13 - 21:42
И для чего же потребовалось намешать в котлеты мух?
   Gera1t
 
2 - 11.01.13 - 21:43
ну есть такая необходимость
   Gera1t
 
3 - 11.01.13 - 21:45
конкретно нужно записать в справочник ссылку на документ, а документ выбирается в форме документа и передать ссылку в виде ссылки в модуль документа не получается
   Ork
 
4 - 11.01.13 - 21:51
(0) В семерке есть метод Провести(). Вызывать его можно в том числе из модуля формы. В вашем случае можно поступать примерно так :

В модуле формы :
Процедура ВыполнитьПроведение()
    Если ВыполнитьВсеПроверки() = 1 Тогда
        Если Провести() = 1 Тогда
            Если Вопрос("Документ проведен. Закрыть форму", "Да+Нет") = "Да" Тогда
                Форма.Закрыть(0);
            Иначе
                ПозакрыватьВсеВПроведенномДокументе();
            КонецЕсли;
    КонецЕсли;
КонецПроцедуры

Но вопроса в (1) это не отменяет.
   Ork
 
5 - 11.01.13 - 21:54
+ (4) В свойствах стандартной кнопки проведения прописать ВыполнитьПроведение().
   miki
 
6 - 11.01.13 - 21:55
(4-5)при групповухе не сработает
   miki
 
7 - 11.01.13 - 21:57
(3)"не получается" и "невозможно" вещи разные. Что значит "выбирается в форме документа"? Это реквизит дока?
   ЧеловекДуши
 
8 - 11.01.13 - 21:59
(0)Используй процедуру "ПриЗаписи()"
А так же свою собственную функцию, которая будет вызывать "Записать()" и затем проверку перед процедурой "Провести(0)".
Но в сущности, команда в форме "Записать()" (если документ проведен) инициирует автоматически команду "Провести(0)".
Но при явном указании "ПриЗаписиПроводить(0)" :)
   ЧеловекДуши
 
9 - 11.01.13 - 22:00
+ "ПриЗаписиПроводить(0)" -> ПриЗаписиПроводить(1) ^)
   miki
 
10 - 11.01.13 - 22:01
и ещё. Что будешь делать при отмене проведения?
 
 Рекламное место пустует
   Ork
 
11 - 11.01.13 - 22:06
(7) Вот тут я засомневался... Насчет "реквизит документа". Иначе таких вопросов не возникало бы.

(10) А тоже самое, что и при групповом проведении - увеличивать рейтинг посещаемости Мисты.
   miki
 
12 - 11.01.13 - 22:11
Имхо, автору надо покурить про периодические реквизиты и и установку оных доками.
(11)А если не реквизит, то какой смысл привязвать его к проведению дока?
   ЧеловекДуши
 
13 - 11.01.13 - 22:31
(3)Во замудрил.... Пятница... многобуковокнеосилил :)
   Gera1t
 
14 - 11.01.13 - 23:18
(7) это не реквизит документа
   Gera1t
 
15 - 11.01.13 - 23:20
смысл в том, что есть документ Оприходывание ТМЦ, есть необходимость привязать к этому документу несколько документов Заявка. я сделал на форме Оприходывание  СЗ в который добавляются заявки и при записи хранятся в справочнике. Так вот у меня не получилось передать данные из СЗ в модуль документа для записи данных именно в момент проведения.
   SerF_2011
 
16 - 12.01.13 - 00:24
Можно добавить в документ реквизит типа строка и писать в него список значений с помощью ЗначениеВСтрокуВнутр в процедуре ПриЗаписи, а в модуле документа использовать ЗначениеИзСтрокиВнутр для получения списка значений обратно, благо перед проведением док записывается.
   КонецЦикла
 
17 - 12.01.13 - 00:24
При проведении реквизиты тоже запсиываются, если чо
   SerF_2011
 
18 - 12.01.13 - 00:26
(17) Истинно так.
   monsterZE
 
19 - 12.01.13 - 14:13
(16) это не первая тема тс по одному и тому-же вопросу.. собсно не понятно, что именно не получается или чего хочет добиться тс. =)
тс, напиши хоть по шагам как формируются твои документы.. и почему не хочешь ограничивать 1заявка=1расходник, например с отбором по реквизиту (клиент поставщик)..
вот тебе еще вариант подчиненности - каждая последующая заявка делается на основании предидущей а в расходнике собираешь всю эту пирамиду. =)
мне не понятно что у тебя за проблема..
   monsterZE
 
20 - 12.01.13 - 14:25
или, если так надо привязаться именно к документу - добавил реквизит с отбором у заявки.
в своем доке, делаешь обработку заявок по "ип пупкин" за выбранный период, собрал тч всех заявок слил в свой док, свернул, пометил в реквизите заявок, что закреплены за твоим документом, провел.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует