Вход | Регистрация

1С:Предприятие ::

Метки: 

Выгрузка весы из УТ 10.3

Я
   OlesyaBelochka
 
11.01.13 - 19:44
Добрый вечер, проблема в следующем. Есть весы с печатью этикеток CAS CL5000J. Пытаемся выгрузить из УТ данные по товару в эти весы, все выгружается прекрасно, кроме цен. Цена должна выгружаться напримерм как 256,2 а выгружается как 256.. без копеек. Смотрела по коду, в обработку данные передаются с копейками вот код:         ПЛУ = Новый ComObject("ScaleCAS.CL5000JPlu");    
        ПЛУ.PluNumber = PLU;
        ПЛУ.ProductCode = КодТовара;
        ПЛУ.ProductName = Наименование;
        ПЛУ.Price = Цена;
        
        Если (КодТовара > 99999) И (ФормаПредупреждения.ПоказыватьПредупреждение()) Тогда
            Если ФормаПредупреждения.ОткрытьМодально() = КодВозвратаДиалога.Отмена Тогда
                Возврат мОшибкаНеизвестно;
            КонецЕсли;
        КонецЕсли;
                            
        Если ОбъектВесов.UploadPlu(ПЛУ) Тогда
            Возврат мНетОшибки;
        Иначе
            Объект.ОписаниеОшибки = "Ошибка при загрузке ПЛУ: " + ОбъектВесов.LastErrorString;
            Результат = мОшибкаЗагрузкиДрайвера;
        КонецЕсли;    
Это код из обработки обслуживания для данного торгового оборудования.
Может быть кто-нить сталкивался с похожей проблемой.
заказчик говорит что во всем виновато обновление и до обновления все работало. (ставилась новая платформа и обновлялась УТ до последнего релиза) распаковала копию базы из Архива, выгружается точно так же как в из базы
 
 
   kotletka
 
1 - 11.01.13 - 19:46
к весам идет книжка, в ней есть коды настройки, в том числе и разрядность
   2S
 
2 - 11.01.13 - 19:50
Что есть Цена в отладчике?
   OlesyaBelochka
 
3 - 11.01.13 - 19:52
Цена в отладчик попадает из табличной части обработки "ТОВыгрузкаВВесыСПечатьюЭтикеток"  Это число формата 15,2
   OlesyaBelochka
 
4 - 11.01.13 - 19:54
(1)В том то и дело что заказчик утверждает что ничего никто в весах не менял.. Сегодня цены в весах были с копейками, потом мы их заново выгрузили из УТ и они загрузились без копеек


Список тем форума
Рекламное место пустует Рекламное место пустует
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует