Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Программа вылетает ошибкой

v7: Программа вылетает ошибкой
Я
   Gal4onok
 
10.01.13 - 12:04
Добрый день!
Возникла проблема: при формировании кассового отчета за один день программа вылетает с ошибкой "Rentime Error" и закрывается. Данных не много,найдены 3 документа, при проведении которых формируется ошибка. Пометили на удаление.Продублировали их- не помогло.
Делали ТИИ, ошибок нет.Выгрузку/загрузку, База 7.7 Тис, скуль
Подскажите, что делать?
 
 
   shamannk
 
1 - 10.01.13 - 12:05
На другом ПК та же ошибка?
   Стрелок
 
2 - 10.01.13 - 12:06
снести винду
   КонецЦикла
 
4 - 10.01.13 - 12:07
Профайлером отловить строку сбоя, запостить сюда
   КонецЦикла
 
5 - 10.01.13 - 12:08
Ошибки никакой нет? Просто слет? Или там что-то про "неуникальное значение ключа и проч."?
   Стрелок
 
6 - 10.01.13 - 12:11
(5) так виндовая же ошибка
   КонецЦикла
 
7 - 10.01.13 - 12:12
(6) Так проблема-то в конкретных документах
   Gal4onok
 
9 - 10.01.13 - 12:23
ошибка на всех пк. нашла три дока только. в конфигуратор не уводит.
   Dolly_EV
 
10 - 10.01.13 - 12:26
Доки пометили Х, скопировали, провели новые? раз ошибка не ушла, имхо, дело не в доках, а в том, что внутри? (номенклатура, партии... )
но все же см. (8)
 
 Рекламное место пустует
   Gal4onok
 
11 - 10.01.13 - 12:28
   Dolly_EV
 
12 - 10.01.13 - 12:30
(11) Аха-хаааа... маладца!))) но не об том фото речь
   Gal4onok
 
13 - 10.01.13 - 12:30
доки пометили, создали новые- заполнили реквизитами, провели. Это кассовые документы( контр, касса, фирма)
   Gal4onok
 
14 - 10.01.13 - 12:30
(12) в личке
   ЧеловекДуши
 
15 - 10.01.13 - 12:36
(14)Ошибка только на конкретном дне?
Или на любом?
Посмотри, в отладчике, когда формируется ошибка, после запроса или до?
Нет ли у вас там умников на "вин 7"?
На каком скуле вы сидите, версия?
7-ка, версия?
Что правили в типовом отчете?
   Gal4onok
 
16 - 10.01.13 - 12:39
скуль 2003, 
7.7, ТИС релиз древний. сильно переписана. отчет не типовой. последние два года не правился, и работал исправно.

про умников на вин7 - не поняла
   Dolly_EV
 
17 - 10.01.13 - 12:39
(14) воот, уже лучше!))
(13) кассовые - ПКО ?
попробуйте удалить совсем сбойные доки
   DGorgoN
 
18 - 10.01.13 - 12:40
Сбойные доки удалить. Сделать выгрузку/загрузку
   Dolly_EV
 
19 - 10.01.13 - 12:42
(16) при проведении и при формировании отчета попробовать локализовать (отладчиком) место где валится...
Вобщем сначала (17,18): удалить наглухо сбойные доки
   Dolly_EV
 
20 - 10.01.13 - 12:42
еще лучше конечно (4)
   Gal4onok
 
21 - 10.01.13 - 12:43
кассовые ПКО и РКО.
В отладчике после выполения запроса. в момент
    Запрос.Выгрузить(ТЗ);
    ТЗ.Свернуть("Касса","НачОст,КонОст");
   Gal4onok
 
22 - 10.01.13 - 12:43
(20) - это как, я не понимаю
   Gal4onok
 
23 - 10.01.13 - 12:51
че то фотка не сильно помогла;)
   Dolly_EV
 
24 - 10.01.13 - 12:54
(17) попробовала?
   Dolly_EV
 
25 - 10.01.13 - 12:57
(22) выгнать всех из базы, зайти монопольно, открыть проблемный док. Открыть SQL Server profiler. Запустить новую трассировку. в 1С нажать "Ок". когда все обвалится - последние несколько строк трассировки из профайлера - в студию
   КонецЦикла
 
26 - 10.01.13 - 12:58
(22) что такое скуль 2003 не понял, но попробую... открыть profiler, начать трассировку, все колонки выделить в т.ч. с ошибками
Начать свои действия в 1С, приводящие к коллапсу
В профайлере побегут строки
Последние строки - сюда

Или дать удаленный доступ, посмотрим сами
   КонецЦикла
 
27 - 10.01.13 - 12:58
+(26) Сразу после ошибки закончить трассировку
   КонецЦикла
 
28 - 10.01.13 - 13:01
(21) странно :)
Так все же на какой строке валится?
Запрос.Выгрузить(); ?
Т.е. запрос выполняется?
Только конкретный документ?
   Dolly_EV
 
29 - 10.01.13 - 13:12
Склоняюсь к (17)... вот инструмент для осуществления (17)
http://rghost.ru/42881506
   Gal4onok
 
30 - 10.01.13 - 13:49
(29) не помогло
   Dolly_EV
 
31 - 10.01.13 - 14:01
тады придется освоить (25),(26)
   Gal4onok
 
32 - 10.01.13 - 14:51
куда выложить файлик по трассировке?
   Gal4onok
 
33 - 10.01.13 - 14:54
 
 
   Gal4onok
 
34 - 10.01.13 - 18:34
ну вот- что с фоткой, что без- один результат,
   dmitn2
 
35 - 10.01.13 - 18:39
решение - перейти на 8-ку
   FN
 
36 - 10.01.13 - 18:53
(0) Посмотри использование памяти процессом 1cv7s.exe во время обработки перед вылетом.
Есть вероятность что просто памяти не хватает - в этом случае нужно отчет переписать.
   КонецЦикла
 
37 - 11.01.13 - 01:52
(33)


tracerlog.txt (193.9 КБ)
Файл удален.

MD5
   46e4cf23d45977a65eb4c7493457da29
SHA1
   52d3ef4bdd64e08b034553e8948c99db0a386250
    Анонимно
    10 января 2013, 14:54
    Скачан 0 раз
   QR

Пипец. Никто не успел скачать же еще
   КонецЦикла
 
38 - 11.01.13 - 01:53
На (28) ответь
А если заменить выгрузку на обход группировок, зайдет туда?
   КонецЦикла
 
39 - 11.01.13 - 01:54
По идее это уже ворочается в кишках 1С, всякие группировки по запросу и обработка его результатов... странно...


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует