Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Клиент - Сервер, непонятна причина ошибки

Клиент - Сервер, непонятна причина ошибки
Я
   vokar911
 
10.01.13 - 11:50
Всем здравствуйте! Уважаемые форумчане подскажите что не так, видел подобную ошибку, но ответа так и не нашел, в чем может быть причина:

ситуация следующая:

В модуле общей формы содержится код:

[code]
&НаСервере
Процедура ЗаполнитьТаблицу(Источник)
    
    
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    
    ЗаполнитьТаблицу(ВладелецФормы.Объект);
    
КонецПроцедуры
[/code]

Процедура "ЗаполнитьТаблицу" завершается с ошибкой:
{ОбщаяФорма.ТекущиеПараметрыАбонемента.Форма(14)}: Ошибка при установке значения атрибута контекста (Объект)
    ЗаполнитьТаблицу(ВладелецФормы.Объект);
по причине:
Нельзя изменять поле, содержащее объект данных формы

Почему выходит ошибка, если ВладелецФормы.Объект это ДанныеФормыСтруктура, которые можно передавать с клиента на сервер, учитывая , что данные формы я менять не собираюсь. Или может я чт-то не допонял?
 
 
   GROOVY
 
1 - 10.01.13 - 11:53
А нафига пытаться передать данные которые и так доступны на серввере?
   vokar911
 
2 - 10.01.13 - 11:55
Данные о владельце формы недоступны на сервере
   GROOVY
 
3 - 10.01.13 - 11:58
и правда...
   vokar911
 
4 - 10.01.13 - 12:20
Нереально, а вот такой вариант работает:

&НаСервере
Процедура ЗаполнитьТаблицу(Источник)
    
    
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    
    темп = ВладелецФормы.Объект;
    ЗаполнитьТаблицу(темп);
    
КонецПроцедуры


1С такой 1С.
   Aprobator
 
5 - 10.01.13 - 12:24
1С это магия )

Список тем форума
Рекламное место пустует  Рекламное место пустует
Компьютеры — это как велосипед. Только для нашего сознания. Стив Джобс
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует