Вход | Регистрация

1С:Предприятие ::

Метки: 

v7: Проведение Док с ДБФ

Я
   work92
 
10.01.13 - 11:36
Не создает новый документ что с кодом не так
 
 
   work92
 
1 - 10.01.13 - 11:36
Док=СоздатьОбъект("Документ.ПоступлениеТоваров");  
 ДБФ = создатьОбъект("XBASE"); 
 ДБФ.ОткрытьФайл("D:\catalog.dbf");
 Док=СоздатьОбъект("Документ.ПоступлениеТоваров");
 ДБФ.Первая(); 
 
 
  Пока ДБФ.ВКонце()=0 Цикл 
      
       
       Ценаа=ДБФ.Sum;

 
    


 Док.Новый();
 // Док.МестоХранения=ДБФ.Cklad;
 
  //Док.Контрагент=ДБФ.Postov;
 
  //Док.Договор=ДБФ.Dogovor; 
 
  //Док.НомерДок=ДБФ.Homerdok;
 
  //Док.ДатаДок=ДБФ.DataDok;
 
   
 Док.НоваяСтрока();
 // Док.Товар=ДБФ.Tovar;
 
 // Док.Количество= ДБФ.kol;
 
   Док.Цена=Ценаа//ДБФ.Sum;
 

    
        ДБФ.Следующая();
        Док.Записать();
         Док.Провести();
 КонецЦикла;
    
    
    
 

    
    
КонецПроцедуры
   Ёпрст
 
2 - 10.01.13 - 11:39
дык в цикл не заходит и привет
   KRV
 
3 - 10.01.13 - 11:41
Док=СоздатьОбъект("Документ.ПоступлениеТоваров");  - для надежности два раза?
   work92
 
4 - 10.01.13 - 11:42
Ёпрст4 что в цикл не фходит
   KRV
 
5 - 10.01.13 - 11:49
ДБФ.Следующая(); - в эту строчку внимательно вкурись в СП
(2) входит в цикл ;)
   Dolly_EV
 
6 - 10.01.13 - 11:53
Ваще четкий код)))

Док.Новый();
Док.НоваяСтрока();
Док.Записать();

Ты точно уверен, что на КАЖДУЮ запись из dbf тебе надо создавать ОТДЕЛЬНЫЙ док. Поступления с ОДНОЙ строкой?))
   KRV
 
7 - 10.01.13 - 11:57
(6) читай код выше - там в ДБФ у него поставщики и склады.. если чо..
   Dolly_EV
 
8 - 10.01.13 - 12:10
Вот так попробуй:
КолЗаписей=ДБФ.КоличествоЗаписей();
Для НомЗаписи=1 По КолЗаписей Цикл
    ДБФ.Перейти(НомЗаписи);
КонецЦикла;
   Dolly_EV
 
9 - 10.01.13 - 12:14
или так:
ДБФ.Первая();
Пока ДБФ.Следующая()=1 Цикл
    Док.....
КонецЦикла;
(7) И? в конкретном примере цикл один, так что насоздается много доков с одной строкой.
Если всё сидит в одной dbf (Поставщики, доки, товар), без индекса тут не обойтись
   KRV
 
10 - 10.01.13 - 12:30
зачем? ну надо ему кучу доков с одной строкой - пусть лепит..
 
 Рекламное место пустует
   KRV
 
11 - 10.01.13 - 12:31
(8) да не там у него ошибка..


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует