Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

ПФ СФ для ПТиУ

ПФ СФ для ПТиУ
Я
   Валидатор
 
10.01.13 - 11:16
сделал СФ внешнюю печатную форму 1137, прикрепил к документу СФ полученный, из документа все вызывается, ПФ формируется, все хорошо, но мне нужно, чтобы у меня тоже самое формировалось не при открытии документа СФ полученный, а в документе ПТиУ, пр нажатии печать, выбираем нашу ПФ и она формируется, но у меня вылетает ошибка. И ничего не происходит, как решить проблему?
 
 
   Валидатор
 
1 - 10.01.13 - 11:17
СсылкаНаОбъект у меня СФ полученный, а в документ я засовываю ПТиУ, поэтому может возникать ошибка, ну а как по другому делать? не понимаю(
   mikecool
 
2 - 10.01.13 - 11:17
исправить ошибку вестимо
   mikecool
 
3 - 10.01.13 - 11:18
(1) это СФ за поставщика? тогда анализируй документссылку и формируй другим способом, делов то
   Валидатор
 
4 - 10.01.13 - 11:19
(3) вот сижу и не понимаю, как сделать(
   Vladimirr
 
5 - 10.01.13 - 11:34
(4) зови спеца
   Валидатор
 
7 - 10.01.13 - 11:50
мне нужно получить ТЧ документа и засунуть ее в ПФ:
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
                   |    ПоступлениеТоваровУслуг.Товары.(
                   |        Ссылка,
                   |        НомерСтроки,
                   |        Номенклатура,
                   |        КоличествоМест,
                   |        Количество,
                   |        ЕдиницаИзмеренияМест,
                   |        Коэффициент,
                   |        ЕдиницаИзмерения,
                   |        Цена,
                   |        Сумма,
                   |        СтавкаНДС,
                   |        СуммаНДС,
                   |        СчетУчетаБУ,
                   |        СерияНоменклатуры,
                   |        ХарактеристикаНоменклатуры,
                   |        Заказ,
                   |        СчетУчетаНДС,
                   |        СчетУчетаНУ,
                   |        ОтражениеВУСН,
                   |        Склад,
                   |        ПриходныйОрдер,
                   |        ЗаказПоставщику,
                   |        КлючСвязи
                   |    )
                   |ИЗ
                   |    Документ.ПоступлениеТоваровУслуг КАК ПоступлениеТоваровУслуг
                   |ГДЕ
                   |    ПоступлениеТоваровУслуг.Ссылка = &Ссылка";
                   
                   Запрос.УстановитьПараметр("Ссылка", СсылкаНаОбъект);

Выборка = Запрос.Выполнить.выбрать();
Пока Выборка.Следующий Цикл
ОбластьМакета.Параметры.Цена = Выборка.Цена
КонецЦикла;

типа того?
   Prikum
 
8 - 10.01.13 - 11:52
(7) А посмотреть как сделано в типовой?
   Валидатор
 
9 - 10.01.13 - 11:53
в типовой из документа ПТиУ не печатается файл, там не много по другому
   Prikum
 
10 - 10.01.13 - 11:54
(9) Но СФ то печатается?
 
 Рекламное место пустует
   Валидатор
 
11 - 10.01.13 - 11:55
СФ у меня печатается, когда я ее печатаю из документа СФ, а когда я ее хочу распечатать из документа ПТиУ тут и встает вопрос
   Валидатор
 
12 - 10.01.13 - 12:07
ЗапросПоТоварам = Новый Запрос();
    ЗапросПоТоварам.УстановитьПараметр("Курс", СсылкаНаОбъект.КурсВзаиморасчетов);
    ЗапросПоТоварам.УстановитьПараметр("Кратность", СсылкаНаОбъект.КратностьВзаиморасчетов);
    ЗапросПоТоварам.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект.Ссылка);
    ЗапросПоТоварам.Текст = "ВЫБРАТЬ
    |    ВложенныйЗапрос.НомерСтроки,
    |    ВложенныйЗапрос.Товар,
    |    ВложенныйЗапрос.Товар.НаименованиеПолное КАК ТоварНаименование,
    |    NULL КАК ОбъектСтроительства,
    |    NULL КАК ОбъектСтроительстваНаименование,
    |    NULL КАК ПредставлениеСтраны,
    |    ВложенныйЗапрос.ЕдиницаИзмерения.Представление КАК ЕдиницаИзмерения,
    |    ВложенныйЗапрос.Количество,
    |    ВложенныйЗапрос.Цена,
    |    ВложенныйЗапрос.Сумма,
    |    ВложенныйЗапрос.СуммаНДС,
    |    ВложенныйЗапрос.СтавкаНДС,
    |    ВложенныйЗапрос.Характеристика,
    |    ВложенныйЗапрос.Серия,
    |    1 КАК ID,
    |    ВложенныйЗапрос.СтранаПроисхождения КАК СтранаПроисхождения,
    |    ВложенныйЗапрос.НомерГТД.Представление КАК НомерГТД,
    |    ВложенныйЗапрос.СтранаПроисхожденияКод КАК СтранаПроисхожденияКод
    |ИЗ
    |    (ВЫБРАТЬ
    |        ТаблицаПоТоварам.НомерСтроки КАК НомерСтроки,
    |        ТаблицаПоТоварам.Номенклатура КАК Товар,
    |        ТаблицаПоТоварам.ЕдиницаИзмерения КАК ЕдиницаИзмерения,
    |        СУММА(ТаблицаПоТоварам.Количество) КАК Количество,
    |        ТаблицаПоТоварам.Цена КАК Цена,
    |        ТаблицаПоТоварам.Сумма КАК Сумма,
    |        ТаблицаПоТоварам.СуммаНДС КАК СуммаНДС,
    |        ТаблицаПоТоварам.СтавкаНДС КАК СтавкаНДС,
    |        ТаблицаПоТоварам.ХарактеристикаНоменклатуры КАК Характеристика,
    |        ТаблицаПоТоварам.СерияНоменклатуры КАК Серия,
    |        ТаблицаПоТоварам.Номенклатура.НомерГТД КАК НомерГТД,
    |        ТаблицаПоТоварам.Номенклатура.СтранаПроисхождения КАК СтранаПроисхождения,
    |        ТаблицаПоТоварам.Номенклатура.СтранаПроисхождения.Код КАК СтранаПроисхожденияКод
    |    ИЗ
    |        Документ.ПоступлениеТоваровУслуг.Товары КАК ТаблицаПоТоварам
    |    ГДЕ
    |        ТаблицаПоТоварам.Ссылка = &ТекущийДокумент
    |    
    |    СГРУППИРОВАТЬ ПО
    |        ТаблицаПоТоварам.НомерСтроки,
    |        ТаблицаПоТоварам.Номенклатура,
    |        ТаблицаПоТоварам.ЕдиницаИзмерения,
    |        ТаблицаПоТоварам.СтавкаНДС,
    |        ТаблицаПоТоварам.Цена,
    |        ТаблицаПоТоварам.ХарактеристикаНоменклатуры,
    |        ТаблицаПоТоварам.СерияНоменклатуры,
    |        ТаблицаПоТоварам.Сумма,
    |        ТаблицаПоТоварам.СуммаНДС,
    |        ТаблицаПоТоварам.Номенклатура.НомерГТД,
    |        ТаблицаПоТоварам.Номенклатура.СтранаПроисхождения,
    |        ТаблицаПоТоварам.Номенклатура.СтранаПроисхождения.Код) КАК ВложенныйЗапрос
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ
    |    ТаблицаПоУслугам.НомерСтроки,
    |    ТаблицаПоУслугам.Номенклатура,
    |    ТаблицаПоУслугам.Содержание,
    |    NULL,
    |    NULL,
    |    ""Россия"",
    |    ТаблицаПоУслугам.Номенклатура.ЕдиницаХраненияОстатков.Представление,
    |    ТаблицаПоУслугам.Количество,
    |    ТаблицаПоУслугам.Цена,
    |    ТаблицаПоУслугам.Сумма,
    |    ТаблицаПоУслугам.СуммаНДС,
    |    ТаблицаПоУслугам.СтавкаНДС,
    |    NULL,
    |    NULL,
    |    2,
    |    NULL,
    |    NULL,
    |    NULL
    |ИЗ
    |    Документ.ПоступлениеТоваровУслуг.Услуги КАК ТаблицаПоУслугам
    |ГДЕ
    |    ТаблицаПоУслугам.Ссылка = &ТекущийДокумент";
    
    
    ВыборкаСтрокТовары = ЗапросПоТоварам.Выполнить().Выбрать();
    Товары = ИнициализацияТаблицыСтрок();

    Пока ВыборкаСтрокТовары.Следующий()  Цикл
                
        Строчка = Товары.Добавить();
        Если ЗначениеЗаполнено(ВыборкаСтрокТовары.Товар) Тогда
            Строчка.Товар               = ВыборкаСтрокТовары.Товар;
            Строчка.ТоварНаименование   = ВыборкаСтрокТовары.ТоварНаименование  + ФормированиеПечатныхФорм.ПредставлениеСерий(ВыборкаСтрокТовары);
        ИначеЕсли ЗначениеЗаполнено(ВыборкаСтрокТовары.ОбъектСтроительства) Тогда
            Строчка.Товар               = ВыборкаСтрокТовары.ОбъектСтроительства;
            Строчка.ТоварНаименование   = ВыборкаСтрокТовары.ОбъектСтроительстваНаименование;
        КонецЕсли;
        Строчка.ПредставлениеСтраны = ВыборкаСтрокТовары.СтранаПроисхождения;
        Строчка.СтранаПроисхожденияКод = ВыборкаСтрокТовары.СтранаПроисхожденияКод;
        Строчка.ПредставлениеГТД    = ВыборкаСтрокТовары.НомерГТД;
        Строчка.Количество          = ВыборкаСтрокТовары.Количество;
        Строчка.ЕдиницаИзмерения    = ВыборкаСтрокТовары.ЕдиницаИзмерения;
        Строчка.Цена      = ВыборкаСтрокТовары.Цена;
        Строчка.СтавкаНДС = ВыборкаСтрокТовары.СтавкаНДС;
        Строчка.СуммаНДС  = ВыборкаСтрокТовары.СуммаНДС;
        Строчка.Сумма     = ВыборкаСтрокТовары.Сумма;
        КонецЦикла;

Вот как в типовом, данные из запроса по ТЧ я получаю, но потом не могу загрузить их в ПФ(
   Prikum
 
13 - 10.01.13 - 12:09
Можно же через параметр узнать откуда  печатаем, из СФ или ПТиУ? И тогда приводить соответствующей код.
   Валидатор
 
14 - 10.01.13 - 13:18
почти разобрался, остался вопрос с кодом единиц измерения. При формировании СФ полученный ЕИ берутся из справочника ЕдиницыИзмерения или из справочника Классификатор единиц измерения?
   Prikum
 
15 - 10.01.13 - 13:30
(14) Конфигурация какая? Или тоже думаешь, что у 1С она одна?
   Валидатор
 
16 - 10.01.13 - 13:57
(15) думал в начале ветки указал конфу( КА, разобрался уже что от куда
   Prikum
 
17 - 10.01.13 - 14:00
(16) Где в (0) упоминается КА?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует