Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Открыть список справочника и спозиционироваться на нужном элементе

v7: Открыть список справочника и спозиционироваться на нужном элементе
Я
   Масянька
 
10.01.13 - 09:06
Доброе утро!
Опять мозги ломаю....

Процедура ПриВыбореОбъекта(ТекТаблица) 
    
    Если ТекТаблица = 2 Тогда       // дубли банков
 
        СпрБанки = СоздатьОбъект("Справочник.Банки");
        СпрБанки.НайтиПоКоду(ТаблицаДублей.Реквизит);
        ТекБанк = СпрБанки.ТекущийЭлемент();
Сообщить("Банк - " + ТекБанк + " - " + ТипЗначенияСтр(ТекБанк));        

       //ОткрытьФорму(СпрБанки.ТекущийЭлемент());
 
        ОткрытьФорму("Справочник.Банки.ФормаСписка", СпрБанки.ТекущийЭлемент());

    КонецЕсли;
    
КонецПроцедуры   // ПриВыбореОбъекта
 

Открывает форму списка справочника, но на нужный элемент не встает.
Чего я упустила?

Спасибо.
 
 
   фобка
 
1 - 10.01.13 - 09:07
Активировать(), или как-то так
   ДенисЧ
 
2 - 10.01.13 - 09:08
АктивизироватьОбъект();

Через контекст
   фобка
 
3 - 10.01.13 - 09:08
+(1) вру
   Масянька
 
4 - 10.01.13 - 09:08
Если изменить:
ОткрытьФорму(СпрБанки.ТекущийЭлемент()); - открывает форму заданного элемента.
   Ёпрст
 
5 - 10.01.13 - 09:09
(0)
Конт="";
ОткрытьФорму("Справочник.Банки.ФормаСписка",Конт);
Конт.АктивизироватьОбъект(СпрБанки.ТекущийЭлемент());
   Масянька
 
6 - 10.01.13 - 09:12
(5) Спасибо - получилось. А почему в стандартных (по конфигурации смотрела) Активизировать нет?
   ДенисЧ
 
7 - 10.01.13 - 09:17
(6) а им этого не надо
   Масянька
 
8 - 10.01.13 - 09:20
(7) Док-т "Заявка покупателя": есть реквизит шапки - Контрагент. В заполненном счете, мышей щелкаешь по полю "Контрагент" - открывается форма списка справочника "Контрагенты" на нужном контрагенте.
   1Сергей
 
9 - 10.01.13 - 09:21
(8) потому, что там стандартная обработка выбора
   Ёпрст
 
10 - 10.01.13 - 09:22
(8) дык смотри, что написано в ПриНачалеВыбораЗначения в доке.
 
 Рекламное место пустует
   Ёпрст
 
11 - 10.01.13 - 09:22
(9) не угадал.
   Масянька
 
12 - 10.01.13 - 09:24
(10) Процедура ПриНачалеВыбораЗначения(ЭлементДиалога, ФлагСтандОбр)
    
    Если ЭлементДиалога="БанковскийСчет" Тогда
        ЮрФизЛицо = Фирма.ЮрЛицо;
        ОткрытьФорму("Справочник.БанковскиеСчета.ФормаСписка", ЮрФизЛицо);
        ФлагСтандОбр = 0;
        
    КонецЕсли;
    
КонецПроцедуры// ПриНачалеВыбораЗначения()
   Ёпрст
 
13 - 10.01.13 - 09:27
Хотя, мот (9) и прав, но это работает, только если выключена иерархия папок.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует