Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Отладчик

Отладчик
Я
   tolok_d
 
09.01.13 - 14:53
Здравствуйте, подскажите как дальше
Процедура КнопкаВыполнитьНажатие(Кнопка)
    Обработка = ВнешниеОбработки.Создать(ИмяФайлаОбработки);
    Обработка.СсылкаНаОбъект = ЭтотОбъект.Документ;
   //что здесь писать
 
КонецПроцедуры

Вот не пойму как дальше написать чтобы открылась уже отлаживаемая обработка.
 
 
   tolok_d
 
1 - 09.01.13 - 14:55
До этого все работает, вообще проблем не вижу, а вот здесь застрял((
   le_
 
2 - 09.01.13 - 14:56
.ПолучитьФорму().Открыть();

   tolok_d
 
3 - 09.01.13 - 14:58
(2) там формы нету.
   Alexaha
 
4 - 09.01.13 - 15:00
(3) а что ты тогда хочешь чтобы у тебя открылось?
   tolok_d
 
5 - 09.01.13 - 15:01
Чтобы выполнилась обработка.
   tolok_d
 
6 - 09.01.13 - 15:02
и я смог по ней отладчиком пробежать, а то без него неудобно(
   le_
 
7 - 09.01.13 - 15:02
(5) Ну, вызывай тогда процедуру выполнения.
Обработка.ВыполнитьБлаБлаБла();

   pessok
 
8 - 09.01.13 - 15:04
экспортную процедуру Выполнить() а там уже точку останова
   tolok_d
 
9 - 09.01.13 - 15:07
(7) не, чтото не работает, ладно, сделаю по другому. Спасибо
   tolok_d
 
10 - 09.01.13 - 15:08
(8) тоесть экспортную?
 
 Рекламное место пустует
   tolok_d
 
11 - 09.01.13 - 15:09
{Форма.Форма.Форма(8)}: Метод объекта не обнаружен (Выполнить)
    Обработка.Выполнить();
   tolok_d
 
12 - 09.01.13 - 15:09
что за Форма.Форма.Форма(8) откуда это берется?
   pessok
 
13 - 09.01.13 - 15:10
Выполнить() Экспорт 
в модуле объекта
   pessok
 
14 - 09.01.13 - 15:11
форма.форма.форма - это то место, откуда ты ее вызываешь, как бы ни двусмысленно это не звучало :)
   Starhan
 
15 - 09.01.13 - 15:12
Название темы не соответствует теме.
   tolok_d
 
16 - 09.01.13 - 15:13
(15) прошу прощения
   tolok_d
 
17 - 09.01.13 - 15:20
не, что-то не то(
   Alexaha
 
18 - 09.01.13 - 15:21
(17) а что не то? что ты делаешь?
то что в (13) советовали сделал?
   pessok
 
19 - 09.01.13 - 15:25
(0) братюнь, давай код обработки, щас быстро тебе ткнем пальцем что куда перенести и где поставить экспортный вызов
   tolok_d
 
20 - 09.01.13 - 15:28
да, все, сделал по другому(в самой тестируемой обработке добавил форму и вызываю ее)
   tolok_d
 
21 - 09.01.13 - 15:29
хотя всетаки интересно что же там не так, даю код
   tolok_d
 
22 - 09.01.13 - 15:31
в модуле формы:
Перем ИмяФайлаОбработки Экспорт;  

Процедура КнопкаВыполнитьНажатие(Кнопка)
    Обработка = ВнешниеОбработки.Создать(ИмяФайлаОбработки);
   //Обработка.пОбъект = ЭтотОбъект.Документ;
 
    Обработка.СсылкаНаОбъект = ЭтотОбъект.Документ;
   //Обработка.Инициализировать(Обработка);
 
    Обработка.Инициализировать(ЭтотОбъект);
КонецПроцедуры

Процедура ПутьКОбработкеНачалоВыбора(Элемент, СтандартнаяОбработка)
    ВыборФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    ВыборФайла.Расширение = "epf";
    ВыборФайла.Фильтр = "Внешние обработки (*.epf)|*.epf";
    Если Не ВыборФайла.Выбрать() Тогда
        Возврат;        
    КонецЕсли;
    ЭтотОбъект.ПутьКОбработке = ВыборФайла.ПолноеИмяФайла;
    ИмяФайлаОбработки = ВыборФайла.ПолноеИмяФайла;
КонецПроцедуры

в модуле обработки

 //Перем пОбъект Экспорт;
 
//Перем пИмяТабличнойЧасти Экспорт;
 //Перем пТабличноеПолеОбъекта Экспорт;
 

Процедура Инициализировать(Объект) Экспорт
    Объект = ... не придумал    
КонецПроцедуры
   tolok_d
 
23 - 09.01.13 - 15:31
или лучьше саму обработку скинуть?
   tolok_d
 
24 - 09.01.13 - 15:31
*лучше
   pessok
 
25 - 09.01.13 - 15:34
чтобы понять рекурсию, надо понять рекурсию...
что ты хотел на выходе заиметь? передавать в обработку объект, из которой она вызывается, а потом выполнять с ним какие-то действия посредствам обработки?
   tolok_d
 
26 - 09.01.13 - 15:34
На коментраии не обращайте внимание, то я с примера делал, не поудалял
   tolok_d
 
27 - 09.01.13 - 15:36
(25) у меня есть обработка, которая в фоновом режиме заполняет екселевский файл. Вот ее то и надо протестировать. Я хотел сделать такую обработку, в форме кторой можно ввести документ, с какого это все формируется и путь к самой обработке, нажать ок, и отладчиком смотреть уже.
   Alexaha
 
28 - 09.01.13 - 15:40
(27) а почему нельзя было сделать эту обработку, открыть ее интерактивно, выбрать в ней документ, запустить на выполнение и смотреть отладчиком?
к чему все эти извраты?
   tolok_d
 
29 - 09.01.13 - 15:43
(28) ну хотелось сделать такую обработку, чтоб на ней еще и другие потестировать
   tolok_d
 
30 - 09.01.13 - 15:43
(28) или я не так понял вопрос?
   Alexaha
 
31 - 09.01.13 - 15:59
(30) ты правильно понял, только, имхо, нет смысла в такой униыверсальной обработке
   tolok_d
 
32 - 09.01.13 - 16:00
(31) понял) спасибо)


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует