Вход | Регистрация

1С:Предприятие ::

Метки: 

v7: нумерация в документе

Я
   defre315
 
08.01.13 - 17:01
Всем привет, ребят подскажите плиз, есть документ в котором проставляетяся номер.
начался новый год а нумерация продолжается с прошлого года, нужно что бы нумерация началась с 1-цы
это должно указываться где то в настройках? либо в прописывается в самом документе?
http://s006.radikal.ru/i215/1301/5d/dd7e2e2cc4c5.png
 
 
   ДенисЧ
 
1 - 08.01.13 - 17:02
в документе периодичность номера год
   BlackSeaCat
 
2 - 08.01.13 - 17:04
(1) У автора это явно реквизит документа, а не его номер.
   defre315
 
3 - 08.01.13 - 17:05
в переодичности стоит В пределах года
   KUBIK
 
4 - 08.01.13 - 17:07
(3) Ваяй процедуру/функцию (см (2))
   ДенисЧ
 
5 - 08.01.13 - 17:07
(3) значит, это не номер документа, а самодельный реквизит. Его сам нумеруй.
   defre315
 
6 - 08.01.13 - 17:09
Процедура НомерДоверенности()
    Док=СоздатьОбъект("Документ.Доверенность");
    Док.ОбратныйПорядок(1);
    Док.ВыбратьДокументы(НачГода(ДатаДок),КонГода(ДатаДок));
    Если Док.ПолучитьДокумент()>0 Тогда
        ПредыдущийНомер = Док.Номер;
        ДлинаПредыдущийНомер = СтрДлина(СокрЛП(ПредыдущийНомер));
        Попытка
            НовыйНомер = Строка(Число(ПредыдущийНомер)+1);
        Исключение
            НовыйНомер = 1;
        КонецПопытки;
        ДлинаНовыйНомер = СтрДлина(Строка(НовыйНомер));
        Если ДлинаНовыйНомер < ДлинаПредыдущийНомер Тогда
            Длина = ДлинаПредыдущийНомер;
        Иначе
            Длина = ДлинаНовыйНомер;
        КонецЕсли;
        ФорматнаяСтрока = "Ч(0)"+Строка(Длина)+".0";
        Номер = Формат(НовыйНомер, ФорматнаяСтрока);
    Иначе
        Номер = "1";
    КонецЕсли;    
КонецПроцедуры
   KUBIK
 
8 - 08.01.13 - 17:15
+(7) реквизит текстовый? Там можно такое написать...:))))
Сделал бы числовым
   Lionee
 
9 - 08.01.13 - 17:16
в (0) ослеп у него номер документа НФ-000002 !
а это резквезит


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует