Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Ошибка при изменении наименования элемента подчиненного справочника

Ошибка при изменении наименования элемента подчиненного справочника
Я
   gash85
 
08.01.13 - 15:52
глV7 = Новый COMОбъект ("V77.Application");

Если ИзмПолнНаим = 1 Тогда                                _адреса=глV7.CreateObject("Справочник.Адрес");                                _адреса.ИспользоватьВладельца(Клиент77);                                                                _адреса.ВыбратьЭлементы();

Пока _адреса.ПолучитьЭлемент()=1 Цикл                                                                    Если СокрЛП(_адреса.наименование) <> СокрЛП(ЗаменаПолнНаим) Тогда                                    _адреса.наименование = ЗаменаПолнНаим;                                        _адреса.записать();                                    КонецЕсли;
                                КонецЦикла;                                        
КонецЕсли;

Клиент77 - Элемент справочника Клиенты (владельца справочника Адреса).

При попытке изменить наименование в справочнике Адреса получаю ошибку - Произошла исключительная ситуация (1С: Предприятие): Изменено Наименование! Может быть нарушена последовательность выборки!
 
 
   Wobland
 
1 - 08.01.13 - 15:55
спасибо за информацию, приму к сведению
   gash85
 
2 - 08.01.13 - 15:56
(1) да вопрос вроде как очевиден - как изменить наименование не вылетая с ошибкой. К чему юмор?
   Wobland
 
3 - 08.01.13 - 15:57
(2) очевиден? не стесняйся, задавай
   Wobland
 
4 - 08.01.13 - 15:58
найтиэлемент тут не надо?
   Patrio_O_Muerte
 
5 - 08.01.13 - 15:59
хм, имхо олеаутомейшн коряво работает с использовать владельца...
   gash85
 
6 - 08.01.13 - 16:00
(4) не надо. используется конструкция:
_адреса.ИспользоватьВладельца(Клиент77);
_адреса.ВыбратьЭлементы();
Пока _адреса.ПолучитьЭлемент()=1 Цикл
 // вот тут мы и получили элемент подчиненного справочника. 
 
КонецЦикла;
   palpetrovich
 
7 - 08.01.13 - 16:20
порядоккодов не спасут отца...?
   gash85
 
8 - 08.01.13 - 16:28
(7) да, именно 
_адреса.ПорядокКодов(); 
помогло
   Jaffar
 
9 - 08.01.13 - 16:43
казалось бы - при чем тут v8...

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует