Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

группировка строк ТЧ табличного документа 1с 8.2

группировка строк ТЧ табличного документа 1с 8.2
Я
   abbas
 
08.01.13 - 12:47
Доброе время суток.
Есть в документ, самописанный...
В табличной части документа есть строки много строк и где в колонке "Вид актива" всего 3 вида:
1. НМА
2. ОС 
3. ТМЗ
Теперь вывожу в табличный документ, но сгруппировать не получается, чтоб было 3 уровня, где нажимая на плюс выходит строки именно с данным видом активов...
Подскажите плс...
 
 
   Галахад
 
1 - 08.01.13 - 12:51
Ну, код наверное стоит показать.
   abbas
 
2 - 08.01.13 - 12:52
ТабДок.НачатьАвтоГруппировкуСтрок();
    Для каждого Строчка Из Инвентаризация Цикл
        ОбластьСтроки.Параметры.Заполнить(Строчка);
        ТабДок.Вывести(ОбластьСтроки,1,Строчка.ВидАктива,Истина);
    КонецЦикла; 
    ТабДок.ЗакончитьАвтоГруппировкуСтрок();
   abbas
 
3 - 08.01.13 - 12:52
Где Строчка - это строчка табличного документа
   Галахад
 
4 - 08.01.13 - 13:04
Хм. Выведи сначала группу на первом уровне, а строки на втором.
   abbas
 
5 - 08.01.13 - 13:08
ТабДок.НачатьАвтоГруппировкуСтрок();
    ОбластьГруппы.Параметры.ВидАктива = "ОС";
    ТабДок.Вывести(ОбластьГруппы,1,"ОС",Истина);    
    Для каждого Строчка Из Инвентаризация Цикл
        Если Строчка.ВидАктива = "ОС" Тогда  
            ОбластьСтроки.Параметры.Заполнить(Строчка);
            ТабДок.Вывести(ОбластьСтроки,2,Строчка.ВидАктива,Истина);
        КонецЕсли;
    КонецЦикла; 
    ТабДок.ЗакончитьАвтоГруппировкуСтрок();
   abbas
 
6 - 08.01.13 - 13:09
Таким способом нужно будет тогда 3 цикла строить...(((
Но одна табличная часть, один цикл или не реально сделать в одном цикле?
   Галахад
 
7 - 08.01.13 - 13:10
(6) Запросом же. С группировкой.
   abbas
 
8 - 08.01.13 - 13:14
Нет не запросом, это из табличной части документа
   Галахад
 
9 - 08.01.13 - 13:16
(8) Документ не записан, что-ли?
Ну тогда выгрузи табличную часть в таблицу значений.
И ее в запрос.
   abbas
 
10 - 08.01.13 - 13:20
выгрузить таблицу значений в запрос? каким образом?
Запрос.Выполнить().Выбрать(ТЗ) ?
 
 Рекламное место пустует
   Галахад
 
11 - 08.01.13 - 13:22
   abbas
 
12 - 08.01.13 - 13:26
А если сделать три цикла по 3 видам, как будет более эффективно ???
   abbas
 
13 - 08.01.13 - 13:26
как будто работал специалист =)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует