Вход | Регистрация

  1  2   
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: 1С++ запрос

v7: 1С++ запрос
Я
   bananan
 
08.01.13 - 12:47
Добрый день! Нужна помощь в переделке запроса.
Запрос Такой:
    ТекстЗапроса = "
    |SELECT
    | Клиент [Клиент $Справочник.Клиенты] 
    |,Агент [Агент $Справочник.Агент]
    |,Заказ [Заказ $Документ]  
    |,НачОст
    |,Приход
    |,Расход
    |,КонОст
    |,ПрошлоДней
    |,Долг
    |,Переплата
    |,Отсрочка
    |,CASE WHEN ПрошлоДней > Отсрочка THEN ROUND((ПрошлоДней-Отсрочка) * (:процент) * Долг / 100,2) ELSE 0 END as Пеня
    |
    |FROM
    |(
    |SELECT
 
   |
    | *    
    |,CASE WHEN КонОст<0 THEN КонОст ELSE 0 END Долг
    |,CASE WHEN КонОст>0 THEN КонОст ELSE 0 END Переплата
    |,CASE WHEN $ПоследнееЗначение.Клиенты.СрокКредита(Клиент, :ТекДата) = 0 
    | THEN :Дней
    |    ELSE $ПоследнееЗначение.Клиенты.СрокКредита(Клиент, :ТекДата) END Отсрочка
    
    | FROM
    |(
    |SELECT 
    |  Журнал.IDDOCDEF 
    |, (DATEDIFF(day,LEFT(Журнал.DATE_TIME_IDDOC, 8),:Дата2)) AS ПрошлоДней
    |, CASE WHEN Журнал.IDDOCDEF = $ВидДокумента.РасходнаяНакладная"+?(ф2=1,"Н","")+" THEN $РН.Агент ELSE $Ост.Агент END Агент
    |, ВЗОст.Клиент Клиент
    |, ВЗОст.Заказ Заказ
    |, ВЗОст.СуммаОснНачальныйОстаток НачОст
    |, ВЗОст.СуммаОснПриход Приход
    |, ВЗОст.СуммаОснРасход Расход
    |, ВЗОст.СуммаОснКонечныйОстаток as КонОст
    |  FROM $РегистрОстаткиОбороты.Взаиморасчеты"+?(ф2=1,"Нал","")+"(:Дата1,:Дата2~,,Движения,,,(Клиент, Заказ),СуммаОсн) AS ВЗОст
    |  LEFT JOIN _1SJOURN AS Журнал ON Журнал.IDDOC = RIGHT(ВЗОст.Заказ,9)
    |  LEFT JOIN $Документ.РасходнаяНакладная"+?(ф2=1,"Н","")+" AS РН ON Журнал.IDDOC = РН.IDDOC
    |  LEFT JOIN $Документ.Остатки"+?(ф2=1,"Нал","Взаиморасчетов")+" AS Ост ON Ост.IDDOC = Журнал.IDDOC
    |  WHERE Журнал.IDDOCDEF IN  ($ВидДокумента.РасходнаяНакладная"+?(ф2=1,"Н","")+",$ВидДокумента.Остатки"+?(ф2=1,"Нал","Взаиморасчетов")+")
    |) T1
    |) T2
    |  LEFT JOIN $Справочник.Клиенты  AS Клиенты ON RIGHT(Клиент,9) = Клиенты.ID
 
   |
Так вот в переработаном запросе надо добавить поле В том числе и в это поле скидать данные по таких документах:
1. ПерезачетБартер
2. ВозвратнаяНакладная
3. ПерезачетБартерНал
4. ВозвратнаяНакладнаяН
Насколько я понимаю - тут ничего сложного вроде и нет, но, уже с час смотрю на эту задачу, как баран на новые ворота.
Где и как вставить условие по данным документа?
Честно, говоря, - ничего не понимаю. :(
 
 
   Азат
 
1 - 08.01.13 - 12:52
CASE WHEN Журнал.IDDOCDEF = $ВидДокумента.ТВОЙВИДДОКУМЕНТА"+?(ф2=1,"Н","")+" THEN $РН.ТВОЕПОЛЕ ELSE $Ост.ДРУГОЕПОЛЕ END Агент

добавляй такие строки и будет тебе щастье
   Mikeware
 
2 - 08.01.13 - 12:53
:-)
   bananan
 
3 - 08.01.13 - 12:58
(1) Добвлять, насколько я понимаю, во второй SELECT?
   Азат
 
4 - 08.01.13 - 12:59
(3) а потом ссылку еще и в первый... ты чо, симен сименыч
   bananan
 
5 - 08.01.13 - 13:01
(4) Ссылк. А ссылку - это как?
Рябата, я с 1С++ третий день работаю. Да и в SQL познания - желают лучшего :(
   Mikeware
 
6 - 08.01.13 - 13:01
(4) это называется "это же несложно - сделайте за меня"©
   bananan
 
7 - 08.01.13 - 13:03
(6) Не правда!
   Mikeware
 
8 - 08.01.13 - 13:03
(5) ссылку на документацию тебе дали 24 декабря - 2 недели назад.
   bananan
 
9 - 08.01.13 - 13:14
Да докуметацию я читаю..
(4) Я понрял что надо ссылку вставлять в первй оператор SELECT
   Азат
 
10 - 08.01.13 - 13:16
(9) идешь к любому терминалу киви, кидаешь 500 рублей на кошелек 9875811760 и я за тебя это поле добавлю
 
 Рекламное место пустует
   bananan
 
11 - 08.01.13 - 13:27
(10) В Украине - гривни, да и терминалов киви нет
   Азат
 
12 - 08.01.13 - 13:33
(11) ну и мучайся
   bananan
 
13 - 08.01.13 - 13:35
(12) Спасбо за понимание и поддержку :)
   КонецЦикла
 
14 - 08.01.13 - 13:47
Добавлять во все селекты по аналогии
Что такое "скидать данные таких документах" не совсем понятно, скорее всего во внутреннем запросе нужно к вирт. таблице добавить соединение с документами (по типу тех которые уже есть)
   bananan
 
15 - 08.01.13 - 13:53
(14) Какае имеено данные нужны я и сам тоолком не понял - уточню после обеда.
А пробывал так:
|SELECT
    | Клиент [Клиент $Справочник.Клиенты] 
    |,Агент [Агент $Справочник.Агент]
    |,Заказ [Заказ $Документ]  
    |,НачОст
    |,Приход
    |,Расход
    |,КонОст
    |,ПрошлоДней
    |,Долг
    |,Переплата
    |,Отсрочка
    |,CASE WHEN ПрошлоДней > Отсрочка THEN ROUND((ПрошлоДней-Отсрочка) * (:процент) * Долг / 100,2) ELSE 0 END as Пеня
    |
    |FROM
    |(
    |SELECT
 
   |
    | *    
    |,CASE WHEN КонОст<0 THEN КонОст ELSE 0 END Долг
    |,CASE WHEN КонОст>0 THEN КонОст ELSE 0 END Переплата
    |,CASE WHEN $ПоследнееЗначение.Клиенты.СрокКредита(Клиент, :ТекДата) = 0 
    | THEN :Дней
    |    ELSE $ПоследнееЗначение.Клиенты.СрокКредита(Клиент, :ТекДата) END Отсрочка
    
    | FROM
    |(
    |SELECT 
    |  Журнал.IDDOCDEF 
    |, (DATEDIFF(day,LEFT(Журнал.DATE_TIME_IDDOC, 8),:Дата2)) AS ПрошлоДней
    |, CASE WHEN Журнал.IDDOCDEF = $ВидДокумента.РасходнаяНакладная"+?(ф2=1,"Н","")+" THEN $РН.Агент ELSE $Ост.Агент END Агент
    |, CASE WHEN Журнал.IDDOCDEF = $ВидДокумента.ПерезачетБартер"+?(ф2=1,"Н","")+" THEN $РН.Агент ELSE $Ост.Агент END Агент
    |, ВЗОст.Клиент Клиент
    |, ВЗОст.Заказ Заказ
    |, ВЗОст.СуммаОснНачальныйОстаток НачОст
    |, ВЗОст.СуммаОснПриход Приход
    |, ВЗОст.СуммаОснРасход Расход
    |, ВЗОст.СуммаОснКонечныйОстаток as КонОст
    |  FROM $РегистрОстаткиОбороты.Взаиморасчеты"+?(ф2=1,"Нал","")+"(:Дата1,:Дата2~,,Движения,,,(Клиент, Заказ),СуммаОсн) AS ВЗОст
    |  LEFT JOIN _1SJOURN AS Журнал ON Журнал.IDDOC = RIGHT(ВЗОст.Заказ,9)
    |  LEFT JOIN $Документ.РасходнаяНакладная"+?(ф2=1,"Н","")+" AS РН ON Журнал.IDDOC = РН.IDDOC
    |  LEFT JOIN $Документ.Остатки"+?(ф2=1,"Нал","Взаиморасчетов")+" AS Ост ON Ост.IDDOC = Журнал.IDDOC
    |  WHERE Журнал.IDDOCDEF IN  ($ВидДокумента.РасходнаяНакладная"+?(ф2=1,"Н","")+",$ВидДокумента.Остатки"+?(ф2=1,"Нал","Взаиморасчетов")+")
    |) T1
    |) T2      
    | T3
    |  LEFT JOIN $Справочник.Клиенты  AS Клиенты ON RIGHT(Клиент,9) = Клиенты.ID
 
   |
   
   
Так ругается:
Line 101: Incorrect syntax near 'T3'.
   КонецЦикла
 
16 - 08.01.13 - 13:54
(15) Пилять, ну так не берись за работу пока не знаешь что делать
И зачем создавать ветку? чтобы мистяне были на низком старте до обеда?
   bananan
 
17 - 08.01.13 - 13:55
+(15) Еще, честно говоря, я слабо понимаю как работает исходный запрос. Может кто поможет и расскажет: как он работает?
   bananan
 
18 - 08.01.13 - 13:55
(16) Так вот и прошу подсказки...
   Mikeware
 
19 - 08.01.13 - 13:56
(15) как бы логично
   Mikeware
 
20 - 08.01.13 - 13:57
(17) ну и спроси у того, кто его писал....
   КонецЦикла
 
21 - 08.01.13 - 13:57
Откуда взялось T3?
Делай соединения по типу
LEFT JOIN _1SJOURN AS Журнал ON Журнал.IDDOC = RIGHT(ВЗОст.Заказ,9)

И добавляй поля в селект по аналогии с 

|,CASE WHEN КонОст<0 THEN КонОст ELSE 0 END Долг
   КонецЦикла
 
22 - 08.01.13 - 13:58
Проще, наверное, позвать кого-то или тут оформить как заявку на удаленку
   bananan
 
23 - 08.01.13 - 14:05
(20) Нет того, кто писал... Теперь он далеко от сюда.
(21) Сделать соединение по типу и добавлять поля по аналогии.. А можно подробнее и конкретно к данному запросу?
   bananan
 
24 - 08.01.13 - 14:10
Если я во второй селект вставляю:
|, CASE WHEN Журнал.IDDOCDEF = $ВидДокумента.ПерезачетБартер"+?(ф2=1,"Н","")+" THEN $РН.Агент ELSE $Ост.Агент END Агент
 
То ругается:
The column 'Агент' was specified multiple times for 'T1'.
   Mikeware
 
25 - 08.01.13 - 14:15
(24) она не ругается, а сообщает об ошибке. вполне нормально сообщает. остается две вещи:
1. прочитать
2. понять прочитанное
   bananan
 
26 - 08.01.13 - 14:21
(25) Колонка"Агент" была указана несколько раз....
А что мне делать, чтобы не было несколько раз? Мне надо эту колонку (поле) просмтреть в 5 разных видах документов!
   Mikeware
 
27 - 08.01.13 - 14:22
(26) я не возражаю...
а для начала советую почитать таки документацию.
   КонецЦикла
 
28 - 08.01.13 - 14:25
Можно тупо сделать соединения с шапками документов во вложенном запросе
В том запросе который повыше сделать через case обработку полей (типа вытащить в самый верхний запрос одно поле вместо четырех)
   bananan
 
29 - 08.01.13 - 14:48
(27) Документацию читаю по 1С, 1С++, SQL
(28) соединение с шапками документов - сделать через JOIN?
case обработку полей (типа вытащить в самый верхний запрос одно поле вместо четырех) - а это совсем не понял как
   Mikeware
 
30 - 08.01.13 - 15:00
(29) выбор когда Журнал.иддокдеф=$ВидДокумента.ПервыйДокумент Тогда $ПервыйДокумент.Агент Когда Журнал.иддокдеф=$ВидДокумента.Второйокумент Тогда $ВторойДокумент.Агент
когда Журнал.иддокдеф=$ВидДокумента.ТретийДокумент Тогда $ТретийДокумент.Агент иначе $ЧетвертыйДокумент.агент конец
   bananan
 
31 - 08.01.13 - 15:02
(30) Это case?
   Азат
 
32 - 08.01.13 - 15:06
(31) lingvo.yandex.ru, translate.google.com
   bananan
 
33 - 08.01.13 - 15:08
(32) Еще раз ОГРОМНОЕ спасибо за полезные подсказки
 
 
   bananan
 
34 - 08.01.13 - 15:25
Хорошо. с предыдущим запросом вроде как разобрался. Но, теперь, нужда созхдать запрос с нуля... Тут я уж точно без помощи не справлюсь.
Задача такая - по документах ВыплатаЗП и Справочнику.Сотрудники - "вынуть" всю инфу о сотруднике (из справочника) и его зарплате за какой-то месяц
1. В форме для этого нужно задать - выбор месяца. - как конкретную дату выбрать знаю; месяц - не знаю
2. В запросе пробывал так:
|SELECT
            |   Жур.iddoc as [Док $Документ]
            |   ,Жур.iddocdef as [Док_вид $ВидДокумента]
            | Сотр [Сотрудник $Справочник.Сотрудники]
            | FROM  $ДокументСтроки.ВыплатаЗП as ДокЗП (nolock)";
Выдает:
: Incorrect syntax near 'Сотр'.
Пожалйста, подскажите!!
   Mikeware
 
35 - 08.01.13 - 15:41
(34) неправильный синаксис возле "Сотр"
а когда исправишь синтаксис - выйдет ошибка "Неизвестное имя "Сотр"
   bananan
 
36 - 08.01.13 - 15:54
(35) Неправильный синтаксис - нестрашно - разберусь
А вот с "Неизвестное имя "Сотр" - что делать?
   Mikeware
 
37 - 08.01.13 - 16:05
(36) сделать известным.
   viktor_vv
 
38 - 08.01.13 - 16:07
(36) Ну как бы нету такого поля в твоих таблицах.
В приведенном примере оно и на Жур должно ругаться, если это весь текст запроса.
Из какой таблицы ты это поле выдернуть хочешь?
Наверное надо 

$ДокЗП.Сотр
   Mikeware
 
39 - 08.01.13 - 16:10
(38) "Стоит негр на улице и пьет молоко. Мимо проходит белый, останавливается перед ним, смотрит так пристально и говорит:
- Не-е-е, не поможет..."
©
   bananan
 
40 - 08.01.13 - 16:12
(38) Поле Сотр - это Элемент справочника Сотрудники ну и строка из Документа ВыплатаЗП
Сделал $ДокЗП.Сотр - ошибка:
Incorrect syntax near '?????'.
   viktor_vv
 
41 - 08.01.13 - 16:13
(39) :)).
   viktor_vv
 
42 - 08.01.13 - 16:14
(40) Поле Сотр в какой таблице ???
   viktor_vv
 
43 - 08.01.13 - 16:15
(42)+ В табличной части какого-то документа, в шапке какого-то документа, реквизит какого-то справочника ?
   bananan
 
44 - 08.01.13 - 16:16
(43) В табличной части доумента ВыплатаЗП, реквизит - справочника Сотрудники
   viktor_vv
 
45 - 08.01.13 - 16:18
Если прваильно помню, ты укрбухию мучаешь. В табчасти "Выплата ЗП" там реквизит "Сотрудник". Тогда

|SELECT
            | $ДокЗП.Сотрудник [Сотрудник $Справочник.Сотрудники]
            | FROM  $ДокументСтроки.ВыплатаЗП as ДокЗП (nolock)";
   bananan
 
46 - 08.01.13 - 16:22
(45) Да, 1С Бухгалтерия для Украины
Попробывал код, что ты написал - ошибка:
eta name parser error: поле таблицы не найдено "$ДокЗП.Сотрудник"
   bananan
 
47 - 08.01.13 - 16:23
+(46) А где можно узнать какие имена парсер дает документам?
   viktor_vv
 
48 - 08.01.13 - 16:26
(47) Открыть конфигуратор, там русским по черному написаны идентификаторы реквизитов, а парсер уже подставляет реальные имена таблиц в базе.
(46) Какая-то у тебя неправильная бухия, в моей есть такой реквизит.
   Patrio_O_Muerte
 
49 - 08.01.13 - 16:29
(8)Совсем с ума сошел, тут ведь праздники были! Когда б он занимался делом?
 
 Рекламное место пустует
   viktor_vv
 
50 - 08.01.13 - 16:29
(48)* подставляет реальные имена таблиц и полей.
   bananan
 
51 - 08.01.13 - 16:29
(48) Документ называется ВыплатаЗП
Идентификатор: ВыплатаЗП
Синоним: ВыплатаЗП
Комментарий: Выплата заработной платы
   viktor_vv
 
52 - 08.01.13 - 16:30
(48)* праздники сказываются :), русским по белому.
   viktor_vv
 
53 - 08.01.13 - 16:30
(51) Теперь раскрываем ветку ТабличнаяЧасть и что там ?
   bananan
 
54 - 08.01.13 - 16:31
(53) Сотр
   viktor_vv
 
55 - 08.01.13 - 16:33
(54) Это у тебя что-то очень древнее.

|SELECT
            | $ДокЗП.Сотр [Сотрудник $Справочник.Сотрудники]
            | FROM  $ДокументСтроки.ВыплатаЗП as ДокЗП (nolock)";
   bananan
 
56 - 08.01.13 - 16:33
Ясно, теперь понял в чем фигоня. А по поводу парсера... Откуда мили как ... ну не знаю как точно сформулировать..
Откуда ты взял $ДокЗП?
   viktor_vv
 
57 - 08.01.13 - 16:35
(56) Строчка
FROM  $ДокументСтроки.ВыплатаЗП as ДокЗП (nolock)";

ничего не навевает ?
   bananan
 
58 - 08.01.13 - 16:35
(57) Пардон; туплю
   viktor_vv
 
59 - 08.01.13 - 16:36
И таки лучше, хотя бы по диагонали, документацию почитать.
   bananan
 
60 - 08.01.13 - 16:37
А теперь нужно делать подзапрос - чтобы выбрать данные о Сотр из таблицной части документа - из справочника Сотрудники?
   bananan
 
61 - 08.01.13 - 16:38
Через inner join?
   viktor_vv
 
62 - 08.01.13 - 16:39
(60) Левое соединение со справочником Сотрудники по реквизиту Сотр и ID справочника.
   viktor_vv
 
63 - 08.01.13 - 16:39
(62)+ Реквизиту Сотр табличной части дока.
   bananan
 
64 - 08.01.13 - 16:39
(62) Спасибо, попробую
   Mikeware
 
65 - 08.01.13 - 16:57
(62) Зачем левое, если у него сотрудник точно есть?
   bananan
 
66 - 08.01.13 - 17:05
Я пока еще не очень в SQL-е, короче написла таой текст запроса:
ТекстЗапроса = "
            |SELECT
            | $ДокЗП.Сотр [Сотрудник $Справочник.Сотрудники]
            | JOIN (                                    
            | SELECT                                        
            | $ДокЗП.Сотр [Сотрудник $Справочник.Сотрудники]
            | FROM $Справочник.Сотрудники
            |
            | FROM  $ДокументСтроки.ВыплатаЗП as ДокЗП (nolock)";
            
Выдает ошибку:Server]Incorrect syntax near the keyword 'JOIN'
   Mikeware
 
67 - 08.01.13 - 17:07
(66) абсолютно верно выдает.
   Mikeware
 
68 - 08.01.13 - 17:08
+(67) я б за такое еще б и в морду дал на его месте...
   viktor_vv
 
69 - 08.01.13 - 17:10
(65) Ну это да.
Привык inner как фильтр использовать в основном.
   bananan
 
70 - 08.01.13 - 17:10
(67-69) А как написать?
   Mikeware
 
71 - 08.01.13 - 17:14
(70) как написано в учебниках по языку
   viktor_vv
 
72 - 08.01.13 - 17:16
ТекстЗапроса = "
            |SELECT
            |$ДокЗП.Сотр [Сотрудник $Справочник.Сотрудники],
            |СпрСотр.ИдентификаторНеПереодическогоРеквизитаСправочника [Алиас $Типизация]
            |FROM
            | 
            |$ДокументСтроки.ВыплатаЗП as ДокЗП (nolock)
            | inner JOIN $Справочник.Сотрудники as СпрСотр (nolock)
            |   on $ДокЗП.Сотр = СпрСотр.ID
            |";

Извини, но больше я пас.
Ты ж не читаешь нихрена.
   viktor_vv
 
73 - 08.01.13 - 17:17
(72)*

           |$СпрСотр.ИдентификаторНеПереодическогоРеквизитаСправочника [Алиас $Типизация]
   bananan
 
74 - 08.01.13 - 17:17
(72) Да читаю... Спасибо и за то
   viktor_vv
 
75 - 08.01.13 - 17:17
* Периодического.
   bananan
 
76 - 08.01.13 - 17:18
(73) А какого именно реквизита?
   КонецЦикла
 
77 - 08.01.13 - 17:19
(66) Скачай конструктор запросов by Berezdetsky
   bananan
 
78 - 08.01.13 - 17:20
В справочнике Сотрудники - 14 Периодических реквизитов
   Mikeware
 
79 - 08.01.13 - 17:23
(77) ну, конструктор тоже иногда ляпы дает. Плюс с виртуальными таблицами у него косячок - параметры не ставит, да и лишние соединения пихает.
Лучше руками научиться...
   bananan
 
80 - 08.01.13 - 17:25
(77)(79) Так какой именно периодический реквизит справочника надо указать?
   viktor_vv
 
81 - 08.01.13 - 17:26
(76) То есть ты у МЕНЯ спрашиваешь, какие данные ТЫ хочешь получить из справочника сотрудники ?
Пожалуй у меня не настолько развита telepat.dll .
   bananan
 
82 - 08.01.13 - 17:26
(81) Понял
   Mikeware
 
83 - 08.01.13 - 17:27
(81) не обновлял давно? :-)))
   КонецЦикла
 
84 - 08.01.13 - 17:28
(79) 90% забот автора уберет
   viktor_vv
 
85 - 08.01.13 - 17:29
(83) Да че-то закрутился, пропустил пару релизов :)).
   bananan
 
86 - 08.01.13 - 17:31
Мне нужны многие поля из справочника вот, например текст запроса:
|SELECT
            |$ДокЗП.Сотр [Сотрудник $Справочник.Сотрудники],
            |СпрСотр.ИНН [Алиас $Типизация]
            |FROM
            | 
            |$ДокументСтроки.ВыплатаЗП as ДокЗП (nolock)
            | inner JOIN $Справочник.Сотрудники as СпрСотр (nolock)
            |   on $ДокЗП.Сотр = СпрСотр.ID
            |";
Выдает ошибку:
Invalid column name 'ИНН'.
А в Справочнике Сотрудники эсть реквизит ИНН!
Что здесь не так?
   bananan
 
87 - 08.01.13 - 17:32
* И ято значит [Алиас $Типизация]?
   КонецЦикла
 
88 - 08.01.13 - 17:32
$СпрСотр.ИНН

[Алиас $Типизация] - убрать нах
   КонецЦикла
 
89 - 08.01.13 - 17:33
До чего ты туп блин... извини конечно
   bananan
 
90 - 08.01.13 - 17:34
(89) извинятся не надо - бывает и туплю
   viktor_vv
 
91 - 08.01.13 - 17:35
(86) Я ж в (73) специально исправил.
   bananan
 
92 - 08.01.13 - 17:35
(880 Написал такой текст запроса:
|SELECT
            |$ДокЗП.Сотр [Сотрудник $Справочник.Сотрудники],
            |СпрСотр.ИНН
            |FROM
            | 
            |$ДокументСтроки.ВыплатаЗП as ДокЗП (nolock)
            | inner JOIN $Справочник.Сотрудники as СпрСотр (nolock)
            |   on $ДокЗП.Сотр = СпрСотр.ID
            |";
Выдает ошибку:
nvalid column name 'ИНН'.
Реквищзит ИНН ТОЧНО есть в справочнике сотрудники!!
   viktor_vv
 
93 - 08.01.13 - 17:36
Для примитивных типов не надо типизировать.
   Mikeware
 
94 - 08.01.13 - 17:37
(90) не "бывает", а "постоянно"
   Mikeware
 
95 - 08.01.13 - 17:38
(93) почему бы и нет? правила приличия....
   bananan
 
96 - 08.01.13 - 17:38
*(92) И откуда парсер или там SQL знает что такое СпрСотр?
   Mikeware
 
97 - 08.01.13 - 17:39
финиш
   viktor_vv
 
98 - 08.01.13 - 17:40
(95) Ну может быть, только придется писать, что такое типизация :)). Боюсь не осилю доступно.
   bananan
 
99 - 08.01.13 - 17:40
(97)    Mikeware - ты даешь самые "полезные" подсказки и советы
   bananan
 
100 - 08.01.13 - 17:42
Сменил СпрСотр.ИНН на СпрСотр.Налоговая - так он и такого поля не видит: Invalid column name 'Налоговая'
  1  2   

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует