Вход | Регистрация

1С:Предприятие ::

Метки: 

Операции введенные вручную.

Я
   анастасия137
 
07.01.13 - 21:08
Создана проводка Операции введенные вручную. Данные считываются из dbf файла. Но сумма операции не считается. Как программно посчитать сумму операции?

Процедура КнопкаВыполнитьНажатие(Кнопка)    
БД = Новый XBase;            
БД.ОткрытьФайл(ПолноеИмяФайла);
ВыбраннаяОрганизация = Организация;    
ДатаЗаписи = ТекущаяДата(); 
Документ = Документы.ОперацияБух.СоздатьДокумент();
Документ.Дата = ДатаЗаписи; 
Документ.Организация = ВыбраннаяОрганизация; 
Документ.Комментарий = сокрлп(БД.new);
Документ.Содержание = сокрлп(БД.new); 
Документ.Записать();
НаборЗаписей = РегистрыБухгалтерии.Хозрасчетный.СоздатьНаборЗаписей();
НаборЗаписей.Отбор.Регистратор.Установить(Документ.Ссылка); 
 //???????
 
СуммаОперации=0;
 //???????
 
БД.Первая(); 
Пока БД.Вконце() = Ложь Цикл
    Движение = НаборЗаписей.Добавить(); 
    Движение.Регистратор = Документ.Ссылка; 
    Движение.Период = ДатаЗаписи;
    Движение.СчетДт = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.01.1");
    Движение.СубконтоДт.НоменклатурныеГруппы = Справочники.НоменклатурныеГруппы.НайтиПоНаименованию(сокрлп(БД.house));
    Движение.СчетКт = ПланыСчетов.Хозрасчетный.НайтиПоКоду("20.01"); 
        Если Движение.СчетКт.УчетПоПодразделениям Тогда
        Движение.ПодразделениеКт = подразделение;
        КонецЕсли; 
    Движение.СубконтоКт.НоменклатурныеГруппы = Справочники.НоменклатурныеГруппы.НайтиПоНаименованию(сокрлп(БД.house));
    Движение.СубконтоКт.СтатьиЗатрат=статьиЗатрат;
    Движение.Организация = ВыбраннаяОрганизация; 
    Движение.Сумма = БД.sum;
    НаборЗаписей.Записать();
 //???????
 
        Документ.СуммаОперации=СуммаОперации+Бд.sum;
 //???????
 
    БД.Следующая(); 
КонецЦикла;
Сообщить("Документ /-Операции, введенные вручную-/ создан");
БД.ЗакрытьФайл();
КонецЕсли;
КонецПроцедуры

Процедура КаталогНачалоВыбора(Элемент, СтандартнаяОбработка)
 
 
   ИначеЕсли
 
2 - 07.01.13 - 21:11
Движение.Сумма = БД.sum;

БД.sum - тип значения какой?
   анастасия137
 
3 - 07.01.13 - 21:12
число
   aka AMIGO
 
4 - 07.01.13 - 21:14
Документ.СуммаОперации=Документ.СуммаОперации+Бд.sum;
так, хотя-бы..
   анастасия137
 
5 - 07.01.13 - 21:15
так я и написала не считает
   rphosts
 
6 - 07.01.13 - 21:15
(5) вы не так написали, вниматеьно смотрите на свой код
   aka AMIGO
 
7 - 07.01.13 - 21:16
+4
или в цикле
СуммаОперации=СуммаОперации+Бд.sum; 
а после цикла
Документ.СуммаОперации=СуммаОперации+Бд.sum;
   aka AMIGO
 
9 - 07.01.13 - 21:17
(8) я поспешил? :)
   rphosts
 
10 - 07.01.13 - 21:18
(9) не, намана, те кому нужно в будуще отследят.... вопрос-то совсем простой.
 
 Рекламное место пустует
   анастасия137
 
11 - 07.01.13 - 21:19
в какой цикл записать
    СуммаОперации = 0;
    Для каждого Движение Из 
        
   //ЗДЕСЬ НЕ ЗНАЮ!
 
    Документы.ОперацияБух.ПолучитьФормуДокумента().ЭлементыФормы.ТабличноеПолеДвиженияБУ.Значение
   //ЗДЕСЬ НЕ ЗНАЮ!
 

    Цикл
    СуммаОперации = СуммаОперации + БД.sum;
    КонецЦикла;
   aka AMIGO
 
12 - 07.01.13 - 21:22
(11) в твой цикл.. не плоди циклы вновь.. всё в твоем коде есть
   rphosts
 
13 - 07.01.13 - 21:25
Документы.ОперацияБух.ПолучитьФормуДокумента().ЭлементыФормы.ТабличноеПолеДвиженияБУ.Значение;


этот-тут зачем нам? это-то какое отношение к вопросу имеет?

смотрите (7) - там всё что нужно написано!

достаточно взять (0) и применить (7).

ветка должна соответствовать нулевому посту! Там вопрос "КАК" а не "СДЕЛАЙТЕ ЗА МЕНЯ".
   ИначеЕсли
 
14 - 07.01.13 - 21:30
Документ.Записать() не хватает ещё.
   анастасия137
 
15 - 07.01.13 - 21:39
Всем спасибо за помощь)


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует