Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Непойму почему нет ключа в структуре..

Непойму почему нет ключа в структуре..
Я
   live in sky dreams
 
07.01.13 - 01:32
Вот кусок кода из формы выбора справочника "КлассификаторБанковРФ".


&НаКлиенте
Процедура ОбработатьВыбор(ВыбранныеСтроки, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    
    Ссылки = Новый Массив;
    Для каждого Ссылка Из ВыбранныеСтроки Цикл
        Если Элементы.Список.ДанныеСтроки(Ссылка).ЭтоГруппа Тогда
            Продолжить;
        КонецЕсли;
        
        Ссылки.Добавить(Ссылка);
    КонецЦикла;
    
    Если Ссылки.Количество() > 0 Тогда
        ПодобратьБанкИзКлассификатора(Ссылки);
        Оповестить("ОбновитьПослеДобавления");
    КонецЕсли;
    
КонецПроцедуры


Тут в переменную "ВыбранныеСтроки" передается собственно сама выбранная строка списка справочника.
Не могу понять почему в структуре "Элементы.Список.ДанныеСтроки(Ссылка)" нет ключа "ЭтоГруппа". Справочник то иерархический...
 
 
   Zypse
 
1 - 07.01.13 - 01:43
Потому что на клиенте...
   live in sky dreams
 
2 - 07.01.13 - 01:45
(1) нет.
Сейчас залез в типовую бухию 3.0 отладчиком посмотрел - там тоже на клиенте и там есть
   Займись делом
 
3 - 07.01.13 - 02:01
Динамический список?

Если да, то у "ЭтоГруппа" в списке не стоит галочка "Использовать всегда" - на клиент она и не приезжает с сервера поэтому. (Может ещё приехать если "ЭтоГруппа" вынесен в список на форму, но так лучше не делать, а явно указывать "ИспользоватьВсегда", если в коде обращаешься)
   live in sky dreams
 
4 - 07.01.13 - 02:03
(3)эээ.. а где именно эта галочка находится?
   live in sky dreams
 
5 - 07.01.13 - 02:04
Список динамический, указана основная таблица.. Где там эта галочка? Не найду чего то
   live in sky dreams
 
6 - 07.01.13 - 02:05
все, нашел
   live in sky dreams
 
7 - 07.01.13 - 02:06
(3) спасибо тебе добрый человек!
   Займись делом
 
8 - 07.01.13 - 02:07
Немного не успел) Но вдруг кому ещё пригодится - картинка
http://s53.radikal.ru/i139/1301/c4/88184bdb8491.png
   live in sky dreams
 
9 - 07.01.13 - 02:08
эту фишку надо запомнить...
sky_закладка

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует