Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Прописать одинаковый список баз 1С

v7: Прописать одинаковый список баз 1С
Я
   MikaelW
 
05.01.13 - 18:25
Терминальный сервер
Нужно всем пользователям прописать список баз одинаковый.
Пользователей 30 и пароли всех не знаю.

У всех новых создающихся базы прописываются сами, т.к. в ветке реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Terminal Server\Install\Software\1C\1Cv7\7.7\Titles прописаны. Но как прописать имеющимся.

1С была деинсталирована на сервере(перестанавливали) в итоге уу всех пользователей исчез список баз..

Заранее спасибо!
 
 
   Delorn
 
1 - 05.01.13 - 18:40
http://www.odines.ru/thread503.html
если это терминал, то можно один раз сделать так:

REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Terminal Server\Install\Software\1C\1Cv7\7.7\Titles]
"D:\\Base1\\"="Имя базы один"
"D:\\Base2\\"="Имя базы 2"
   Delorn
 
2 - 05.01.13 - 18:40
Яндекс и гугль клевые чуваки.
   MikaelW
 
3 - 05.01.13 - 18:45
(1) пост до конца прочитать можно?
(2) чуваки действительно клевые. Нашел бы не спрашивал!

Может кто стартер какой посоветует? ;))
   КонецЦикла
 
4 - 05.01.13 - 18:51
(3) От romix поищи
Он может прописывать базы по умолчанию
Выгонять пользователей 
И еще важнее: не пускать их :)
Пока не поставил на одной конторе - мучался шопипец, каждый лезет, пробует запустить, блокирует файлы, в итогу пятиминутное обновление вырастало в получасовое
   Злопчинский
 
5 - 05.01.13 - 19:22
(4) а ее как прикрутить при запуске приложения 1С в терминале сразу при входе...? она только локально поможет или если в терминале доступен рабочий стол...
?
   MikaelW
 
6 - 05.01.13 - 19:25
(5) а зачем рабочий стол?
Вроде прикрутил ее и все в ней прописал.
Теперь проблем нет...

Посмотрю как завтра день отработает!
   PALESIA
 
7 - 05.01.13 - 19:26
(0) если прикрутить Starter1C.exe - он автоматом подхватывает все базы ... только у него вроде бы проблемы с терминальным режимом ... но попробовать стоит
   MikaelW
 
8 - 05.01.13 - 19:29
(7) от ромикса прикрутил, только он криво окно запускает во весь экран, батник придется писать наверное....
   PALESIA
 
9 - 05.01.13 - 19:33
(9) папку "MD_Free" и "stop.ini" в ней не забыл? )
   MikaelW
 
10 - 05.01.13 - 19:34
(9)Ну она мне не особо требуется!
И уведомления вылезают в ТРЕЕ.
В терминале нужно дописывать окно сообщений в 1С.
Мне лень да и не требуется особо...
 
 Рекламное место пустует
   MikaelW
 
11 - 05.01.13 - 19:36
   PALESIA
 
12 - 05.01.13 - 19:37
(10) ну на любителя - выгонялка клевая - особенно для любителей по нескольку раз на входе окно открыть - рубить через диспетчер - не ахти как, когда юзверей масса
   КонецЦикла
 
13 - 05.01.13 - 19:39
(7), (8) Использовался как раз в основном в терминальном режиме
Просил Ромикса еще что-то доработать, не помню уже что
Несколько лет работал, проблем не замечал. О чем вы, товарищи?
   MikaelW
 
14 - 05.01.13 - 19:43
   КонецЦикла
 
15 - 05.01.13 - 19:48
(14) А... мои заходили через RDP, т.е. видели рабочий стол сервера
   MikaelW
 
16 - 05.01.13 - 19:56
(15) у меня тоже RDP только прописана сразу среда, нефиг пользователям шастать по серверу.....
1С и хватит!
   PALESIA
 
17 - 05.01.13 - 20:06
(15) мои тоже так сначала заходили ... пока кнопки "Выход из системы" и "Завершение работы" пару раз не перепутали ...
   monsterZE
 
18 - 05.01.13 - 20:15
(17) а нечего разрешать юзверям завершать работу сервера =)
   monsterZE
 
19 - 05.01.13 - 20:17
собсно можно запретить рабочий стол как у тс или пользовать альтернативу типа 2х клиент-сервер
по теме - выгрузить ветку реестра текущих пользователей, добавить нужные базы, загрузить обратно
..если я правильно понял, что нужно =)
   MikaelW
 
20 - 05.01.13 - 20:34
(19) да я что-то с реестром не дружу....
   monsterZE
 
21 - 05.01.13 - 20:36
точно ветку не помню (на работе валяется файлик, после празников посмотрю, если будет еще актуально).. но все пользователи перечисляются что-то типа 001-002...
   monsterZE
 
22 - 05.01.13 - 20:42
нашел дома..
Windows Registry Editor Version 5.00

[HKEY_USERS\S-1-5-21-1933269394-2581739951-2957872566-1114\Software\1C\1Cv7\7.7\Titles]
"D:\\base\\2011alt\\xxx\\"="2011 xxx"
"D:\\base\\2011alt\\ccc\\"="2011 ccc"
"D:\\base\\2011alt\\vvv\\"="2011 vvv"

[HKEY_USERS\S-1-5-21-1933269394-2581739951-2957872566-1117\Software\1C\1Cv7\7.7\Titles]
"D:\\base\\2011alt\\xxx\\"="2011 xxx"
"D:\\base\\2011alt\\ccc\\"="2011 ccc"
"D:\\base\\2011alt\\vvv\\"="2011 vvv"

[HKEY_USERS\S-1-5-21-1933269394-2581739951-2957872566-1120\Software\1C\1Cv7\7.7\Titles]
"D:\\base\\2011alt\\xxx\\"="2011 xxx"
"D:\\base\\2011alt\\ccc\\"="2011 ccc"
"D:\\base\\2011alt\\vvv\\"="2011 vvv"
   Torquader
 
23 - 05.01.13 - 21:58
Самое простое - список баз положить в REG-файл и прописать в автозапуск, чтобы при входе пользователя в его веточку реестра выкладывались нужные базы (желательно перед этим её почистить от лишнего).
   КонецЦикла
 
24 - 05.01.13 - 22:02
(16) Ну так права на то есть
(17) Ну так права на то есть
   PALESIA
 
25 - 05.01.13 - 22:06
(24) а кто тебе сказал, что юзвери не с правами админовскими его вырубили, когда технарь-лошара после настройки терминал не отключил? )
   КонецЦикла
 
26 - 05.01.13 - 22:12
(25) ну так... админ в курилке может всем пароль свой рассказать, всего не предусмотришь


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует