Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Запутался с регистром остатков товаров в 1с77

v7: Запутался с регистром остатков товаров в 1с77
Я
   VBMADD
 
02.01.13 - 23:45
Привет братьям по разуму.
Подскажите плиз че в коде не так?
Че та зациклился я, выдает по всем товарам кол-во 1 шт.

Процедура Остатки()
 //================
 
Рег=СоздатьОбъект("Регистр.ОстаткиТоваров");
СпрТоваров = СоздатьОбъект("Справочник.Товары");
СпрТоваров.ВыбратьЭлементы();

Пока СпрТоваров.ПолучитьЭлемент() = 1
Цикл
   Товар = СпрТоваров.ТекущийЭлемент();
   Рег.Товар = Товар; 
   Рег.ВременныйРасчет();
   РассчитатьрегистрыНа("31.12.10",);
   Рег.ОстаткиПолучить();
   Ост=Рег.Остаток(Товар,"Количество");
   Сообщить("Товар " + Товар + " кол-во = " + Ост);
КонецЦикла;
КонецПроцедуры
 
 
   aka AMIGO
 
1 - 02.01.13 - 23:48
РассчитатьрегистрыНа("31.12.10",); - уже не так..
   kiruha
 
2 - 02.01.13 - 23:48
похоже на развод
   aka AMIGO
 
3 - 02.01.13 - 23:48
+1 - в цикле, имею в виду
   trad
 
4 - 02.01.13 - 23:49
даты записываются в апострофах: '31.12.10'
   aka AMIGO
 
5 - 02.01.13 - 23:50
посмотри запросы в стандартной конфигурации, только потом размещай тут свой
   VBMADD
 
6 - 02.01.13 - 23:53
Выдает ошибку
РассчитатьрегистрыНа("31.12.2010",);
{D:\1CV77\КОМИССИОННЫЙ\EXTFORMS\НОВЫЙ_УДАЛЕНИЕ_ДОКУМЕНТОВ_ЗА_ПЕРИОД.ERT(13)}: Неверно задана граница расчета!
   aka AMIGO
 
7 - 02.01.13 - 23:55
http://help1c.com/faq.html

ищи тут, есть твой проимер
   VBMADD
 
8 - 02.01.13 - 23:56
(4) и (7) Спасибо!
   FN
 
9 - 02.01.13 - 23:57
ТЗ=СоздатьОбъект("ТаблицаЗначений");
Рег=СоздатьОбъект("Регистр.ОстаткиТоваров");
Рег.ВременныйРасчет();
РассчитатьрегистрыПо(ДатаВыбраннаяНаФормеОбработки_ТакПроще);
Рег.ВыгрузитьИтоги(ТЗ);

а уже дальше цикл по ТЗ
   aka AMIGO
 
10 - 03.01.13 - 00:01
(8) да не стоит..
поконкретней:
http://help1c.com/search.html?searchid=1984094&text=v7%20остатки&web=0
 
 Рекламное место пустует
   aka AMIGO
 
11 - 03.01.13 - 00:02
+10 нет, ссылка не получается. Если есть желание - найди там вверху лупу, нажми и введи текст v7 остатки
   VBMADD
 
12 - 03.01.13 - 00:08
(9) Тоже Спасибо!
   КонецЦикла
 
13 - 03.01.13 - 00:08
Это сильно, расчет в цикле
   aka AMIGO
 
14 - 03.01.13 - 00:23
(6) хотя-бы так:
РассчитатьрегистрыНа(Дата("31.12.2010"));
   Злопчинский
 
15 - 03.01.13 - 00:52
(13) ну и фигли - как умеют так и пишут.. я вот сейчас поправлял товарищу код - так у него запрос в переборе каждой строки по докуменрту.. и ничего.. нужные цифры получил, претензий к быстродействию нету..
   VBMADD
 
16 - 03.01.13 - 01:00
(13) и тебе спасибо!
Тему закрыли.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует