Вход | Регистрация

1С:Предприятие ::

Метки: 

Универсальный обмен данными. заполнение программно отбора.

Я
   zladenuw
 
02.01.13 - 19:36
немного изменил процедуру НастроитьПостроитель

Делаю так

    Если ЗначениеЗаполнено(СтруктураОтбора) Тогда
                Построитель.Отбор.Сбросить();
                ПОтбор = Построитель.Отбор;
                Для каждого ЭлементОтбора Из СтруктураОтбора Цикл
                    ПредставлениеОтбора = "Документ_"+ТипДокумента+"."+ЭлементОтбора.Ключ;
                    Если ПОтбор.Найти(ПредставлениеОтбора) = Неопределено Тогда
                        ПОтбор.Добавить(ПредставлениеОтбора,ПредставлениеОтбора,ПредставлениеОтбора);
                    КонецЕсли;                        
                    ПОтбор[ПредставлениеОтбора].Использование = Истина;
                    ПОтбор[ПредставлениеОтбора].Значение      = ЭлементОтбора.Значение;
                    ПОтбор[ПредставлениеОтбора].ВидСравнения  = ВидСравнения.Равно;
                    
                КонецЦикла; 
            КонецЕсли;
В построителе отбор заполнен.
Но выгружает не тот документ.
Где именно можно увидеть когда идет обращение к построителю ?
 
 
   Miss1C
 
1 - 02.01.13 - 19:37
(0) ЭлементОтбора.Значение посмотрите отладчиком
   zladenuw
 
2 - 02.01.13 - 19:38
(0) целый час брожу в отладчике. но не нахожу.
может кто делал ?
   zladenuw
 
3 - 02.01.13 - 19:41
(1) в построителе значение есть.
Но не фига не фильтрует нужное при СОМ экспорте в приемник
   zladenuw
 
4 - 02.01.13 - 20:11
(0) победил.

Но теперь при СОМ ошибка. если выгружаю вручную ошибки нету.
Пишет что 1 ручная, 2 СОМ
Окончание выгрузки: 02.01.2013 18:10:38

Выгружено объектов: 7


СОМ
Начало выгрузки:   02.01.2013 18:10:55

ЗАГРУЗКА В ПРИЕМНИКЕ: Ошибка при загрузке данных: {Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(1541)}: Ошибка в обработчике события ПослеЗагрузкиОбъекта
    ИмяПКО                 =  РеализацияТоваровУслугАвто
    ТипОбъекта             =  Реализация товаров и услуг
    Объект                 =  Реализация товаров и услуг ОП-00000002 от 28.12.2012 14:57:55
    Обработчик             =  ПослеЗагрузкиОбъекта
    ОписаниеОшибки         =  Поле объекта не обнаружено (Контрагент)
    ПозицияМодуля          =  (18)
    КодСообщения           =  21
   zladenuw
 
5 - 02.01.13 - 20:20
(4) в КД вот это поле.  Параметры.Контрагент = Объект.Контрагент;


Список тем форума
Рекламное место пустует Рекламное место пустует
Основная теорема систематики: Новые системы плодят новые проблемы.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует