Вход | Регистрация


О жизни... :: Математика и алгоритмы

OFF: Задачка по теории вероятностей (ТВ)

OFF: Задачка по теории вероятностей (ТВ)
Я
   nikast
 
30.12.12 - 16:51
Друзья привет. Помогите с задачей по тв.
В шкафу находятся 10 пар ботинок разных фасонов. Случайно выбирают 4 ботинка. Найти вероятность того, что среди выбранных 4 ботинок, по крайней мере, одна пара.
Решение:
Всего способов выбрать 4 ботинка из 20:
С(4;20)= 20!/(4!*16!)= 4845
ПП (предположим противное,что в 4-х ботинках нет пар)
Выбираем только левые:
C(4;10)= 10!/(4!*6!) = 210
Т.к мы можем выбрать и правые 2 * С(4;10)
P= (2*210/4845) = 0,087
Откуда искомая вероятность равна:
P(искомая) = 1 - 0,087 = 0,913

А теперь вопрос ? Правильно ли я решил задачу? Потому что на одном из форумов наткнулся на подобную задачу и ответ получили другой.
Спасибо.
 
 
   nikast
 
1 - 30.12.12 - 16:54
ой ой ..
   nikast
 
2 - 30.12.12 - 16:54
Фасон у всех одинаковый
   Злопчинский
 
3 - 30.12.12 - 17:07
мое мнение - чисто интуитивное - неправильно!
   Fragster
 
4 - 30.12.12 - 17:09
не, ну носки я понимаю попутать правый-левый, но ботинки?
   Злопчинский
 
5 - 30.12.12 - 17:26
вероятность = 0.2972
   Злопчинский
 
6 - 30.12.12 - 17:28
Доказательство неверного решения в (0) простое:
вероятность достоверного события = 1
достоверным событием у нас есть веротяность обноружить 0 пар +1 пару+2 пары - если посчитать по (0) - получится сильно много больше 1
   ILM
 
7 - 30.12.12 - 17:37
Бери 4 из 11 - вероятность что пара будет? Умножай на вероятность 1 из 5 (кол-во пар). Перемножай вероятности и получай вероятность обоих событий одновременно. Считать лениво))
   NS
 
8 - 30.12.12 - 17:42
»
   NS
 
9 - 30.12.12 - 17:44
Вру.
(18/19)*(16/18)*(14/17)
и
1-(18/19)*(16/18)*(14/17)
   NS
 
10 - 30.12.12 - 17:45
0.307
 
 Рекламное место пустует
   NS
 
11 - 30.12.12 - 17:51
И решение в текстовом виде.
Вынимаем первый ботинок, нам неважно что это за ботинок, вероятность его вынуть равна единице.
Из оставшихся 19-ти парный только один, вероятность вынуть непарный  18/19
//-// парных два из 18-ти. Непарных 16 из 18.
//-// парных три из 117-ти. Непарных 14 из 17.

Итого вероятность что среди выбранных не будет ни одной пары - (9)
   nikast
 
12 - 30.12.12 - 17:55
Нет, парный не один .. парных 10
   nikast
 
13 - 30.12.12 - 17:56
Ботинки делятся только на правые и левые
   NS
 
14 - 30.12.12 - 17:57
(12) Серьезно?
Вот ты взял один ботинок из шкафа, сколько в шкафу осталось парных ЕМУ ботинок?
   nikast
 
15 - 30.12.12 - 17:58
Будем считать, что все ботинки одного размера. То есть если среди выбраных 4х ботинок будет левый и правый, то это уже пара
   NS
 
16 - 30.12.12 - 17:58
(15) Ответь на (14)
   NS
 
17 - 30.12.12 - 17:59
(15) Для кого в условие написано что 10 пар РАЗНЫХ ФАСОНОВ?
   nikast
 
18 - 30.12.12 - 18:00
ДА-да но я потом написал (2) и (3)
   nikast
 
19 - 30.12.12 - 18:00
Вероятность 0.307 правильная если считать что у них разный фасон я согласен.. а если они все одинаковые
   NS
 
20 - 30.12.12 - 18:01
Если бы было 10 пар одинаковых фасонов, то решение тоже эементарно
(9/19)*(8/18)*(7/17) то что все на одну ногу, и ответ
1-(9/19)*(8/18)*(7/17)
   Злопчинский
 
21 - 30.12.12 - 18:51
ой, в (5) посчитана вероятность именно 1ой пары.
   Злопчинский
 
22 - 30.12.12 - 18:51
эт я неправильно киндеру задание странслировал..
   Злопчинский
 
23 - 30.12.12 - 19:00
а как в текстовом виде типа (11) будет решение именно для 1 пары?
   sda553
 
24 - 30.12.12 - 19:08
Решим другим способом.
Первый ботинок вытаскиваем любой.
Второй ботинок, той же ноги, что и первый Вероятность 9/20
Третий ботинок, той же ноги что первые два 8/20
Четвертый ботинок той же ноги что первые три 7/20

Итого, вероятность такого события 9*8*7/8000 = 63/1000

Нам же нужно найти вероятность обратного события, а значит
1-63/1000 = 937/1000

С твоим ответом не сошлось, ищи ошибку
   Злопчинский
 
25 - 30.12.12 - 19:09
(24) то есть по твоему - вытощить хотя бы одну пару вероятность = 0.937? - категорически не согласен!!!
   sda553
 
26 - 30.12.12 - 19:10
(24) бЛИН стыдно то как
1 - 9*8*7/(19*18*17) = 0.913
С твоим сошлось
   Злопчинский
 
27 - 30.12.12 - 19:11
(26) программирование говорит, что ваш результат - неверный.
   sda553
 
28 - 30.12.12 - 19:12
(27) Давай свою программу, найдем в ней баги, так и быть
   Злопчинский
 
29 - 30.12.12 - 19:13
(28) я как-то склонен больше доверять NS и своему киндеру.. ;-)
   sda553
 
30 - 30.12.12 - 19:14
(29) Твое дело
   Злопчинский
 
31 - 30.12.12 - 19:15
ща опубликую программку..
.
пояснения к программе:
.
обозначим 1-ю пару ботинок как 100 и 101, вторую - 110 и 111 и т.д.
.
отобранные из чулана боты отсортируем по возрастанию, тогда если есть парные быот - разность между текущим и предыдущим = 1
   Злопчинский
 
32 - 30.12.12 - 19:17
»
   ШтушаКутуша
 
33 - 30.12.12 - 19:18
(0) Если выбранные ботинки не возвращаются обратно в шкаф,
то это гипергеометрическое распределение вероятностей,
которое при росте выборки к бесконечности можно апроксимировать нормальным распр., но n=4 из 20(10 пар)
явно маловато для приближения норм.распределением, поэтому,
только гипергеометрич. распределение
 
 
   Злопчинский
 
34 - 30.12.12 - 19:20
(30) запрограммируй и убедись...
   Злопчинский
 
35 - 30.12.12 - 19:21
(30) если из 10 пар - вытяниваем 4 бота и получаем 0.9, то при вытягивании 19 бот - веротяность явно зашкалит за 1....
   Злопчинский
 
36 - 30.12.12 - 19:34
(24) посчитай по свойе формуле вероятность хотя бы одной пары, если вытаскиваем 4 бота из 2 пар.
   sda553
 
37 - 30.12.12 - 19:38
(34) В твоей программе решена задача для случая разных фасонов
   Злопчинский
 
38 - 30.12.12 - 19:39
(37) в соответсвии с (0)...
   Злопчинский
 
39 - 30.12.12 - 19:41
у тебя в (24) - специально не оговорено. значит - решал в соответсвии с (0) - 10 пар ботинок разнызх фасонов - результат выдал неверный.
   Злопчинский
 
40 - 30.12.12 - 20:18
Итого: слив для sda553 - защитан!
   ШтушаКутуша
 
41 - 30.12.12 - 20:20
друзья, извините за занудство но при описанной схеме испытаний
здесь катит только гипергеометрическое распределение.
Остальное просто ээээ несостоятельно.
   Злопчинский
 
42 - 30.12.12 - 20:28
(41) "ты мне цифры назови!" ;-)
   sda553
 
43 - 30.12.12 - 22:39
(40) Ну ладно, порадуйся, в честь НГ. Слил меня..
   ШтушаКутуша
 
44 - 30.12.12 - 23:09
(42) http://www.aup.ru/books/m155/4_19.htm
вот, а довести "до цифры" тут ничего сложного
   Злопчинский
 
45 - 30.12.12 - 23:19
Вот тут малый формулу написал
n - колов пар ботинок, m - колво доставаемых
вероятность что не попадется ни однойпары
С(0,n) * C(m,n) * 2^m / C(m,2n)
   Torquader
 
46 - 31.12.12 - 01:22
Если ботинки одинаковые, то задачу можно свести к чёрным и белым шарам - в этом случае - вероятность вытащить шары разного цвета.
То есть нам нужно оценить вероятность вытягивания шаров одного цвета.
Первый шар в любом случае мы тянем с вероятностью 1.
Потом с вероятностью 9/19 мы можем вытащить шар того же цвета.
Далее тянем ещё один шар 8/18, ну и последний 7/17.
В итоге их нужно перемножить.
Ответ 1-((9/19)*(8/18)*(7/17))=1-(504/5814)=0.9133... и дофига цифр.
   dclxvi
 
47 - 31.12.12 - 01:42
Первый ботинок это просто ботинок

Второй ботинок вероятность угадать 1/19

Третий ботинок вероятность угадать 2/18

Четвертый ботинок вероятность угадать 3/17

Итого: 0,34
   Злопчинский
 
48 - 31.12.12 - 01:55
(46) все пары разные, разного цвета
   Злопчинский
 
49 - 31.12.12 - 01:55
(47) неверно, правильный результат 0.307
 
 Рекламное место пустует
   dclxvi
 
50 - 31.12.12 - 02:20
(49) Да ты прав практическая проверка дает результат: Найдено пар:30 707

Процедура КнопкаСформироватьНажатие(Кнопка)
   // Вставить содержимое обработчика.
   ГСЧ = Новый ГенераторСлучайныхЧисел(255);
   
   НайденыхПар=0;
   Для н=1 по 100000 цикл
       СпБотинков=Новый СписокЗначений;
       СпБотинков.Очистить();
       
       Пока СпБотинков.Количество()<4 Цикл
           ТекБотинок=ГСЧ.СлучайноеЧисло(1, 20);
           Если СпБотинков.НайтиПоЗначению(ТекБотинок)=Неопределено Тогда
               СпБотинков.Добавить(ТекБотинок);
           КонецЕСли;
       КонецЦикла;
       
//        СпБотинков.ВыбратьЭлемент("хххх");
       ТЗПроверки=Новый ТаблицаЗначений;
       ТЗПроверки.Очистить();
       ТЗПроверки.Колонки.Добавить("ПарыБотинок");
       ТЗПроверки.Добавить();
       ТЗПроверки.Добавить();
       ТЗПроверки.Добавить();
       ТЗПроверки.Добавить();
       
       ТЗПроверки.ЗагрузитьКолонку(СпБотинков.ВыгрузитьЗначения(),"ПарыБотинок");
       
//        ТЗПроверки.ВыбратьСтроку();
       Для Каждого СтрТЗ из ТЗПроверки Цикл
           СтрТЗ.ПарыБотинок=Окр(СтрТЗ.ПарыБотинок/2,0,1);
       КонецЦикла;
//        ТЗПроверки.ВыбратьСтроку();
       ТЗПроверки.Свернуть("ПарыБотинок");
       
       Если ТЗПроверки.Количество()<4 Тогда
           НайденыхПар=НайденыхПар+1;
       КонецЕсли;
       
       состояние("обработано:" +н );
   КонецЦикла;
   
   Сообщить("Найдено пар:"+НайденыхПар);
КонецПроцедуры
   Злопчинский
 
51 - 31.12.12 - 02:31
(50) формула в 45
   dclxvi
 
52 - 31.12.12 - 02:41
(51) я вот так пересчитал

1/19 + 2/18*(1-1/19)+ 3/17*(1-(1/19)-2/18*(1-1/19))
   Злопчинский
 
53 - 31.12.12 - 04:33
(52) возможно, выше приведено для общего случая.
   dclxvi
 
54 - 31.12.12 - 08:12
(53) Что за функция C?
   sda553
 
55 - 31.12.12 - 12:27
(54) Это самая основная функция в теории вероятностей wiki:Сочетание
   dclxvi
 
56 - 31.12.12 - 13:16
(55) (45)

Написал прогу:

Функция факториал(к)
   Факториал=1;
   Если К>1 Тогда
       Для л=1 по К цикл
           Факториал=Факториал*л;
       КонецЦикла
   Конецесли;
   
   Возврат  Факториал;
Конецфункции    

Функция Сочетание(н,м)
   Если н>м Тогда
       Возврат факториал(н)/(факториал(м)*факториал(н-м))
   Иначе
       возврат 1;
   Конецесли;
КонецФункции

Функция СтепеньДвойки(й)
   Рез=1;
   Если й>0 Тогда
       Для п=1 по й Цикл
           Рез=Рез*2;
       КонецЦикла;
   Конецесли;
   
   Возврат Рез;
КонецФункции

Процедура КнопкаВыполнитьНажатие(Кнопка)
   // Вставить содержимое обработчика.
   н=20;
   м=4;
   
   Результат= (Сочетание(0,н) * Сочетание(м,н) * СтепеньДвойки(м)) / Сочетание(м,2*н);
   
   Сообщить(Результат);
КонецПроцедуры


Результат выводит: 16

Где ошибка?
   Злопчинский
 
57 - 31.12.12 - 14:05
н=10;
 м=4;
   Злопчинский
 
58 - 31.12.12 - 14:08
у меня в формуле - первый индекс - верхний.
у тебя функция Сочетание(н,м)
а вызывается Сочетание(м,н)
   dclxvi
 
59 - 31.12.12 - 14:24
(58) Как рассчитать вероятность для 11 ботинок?
   Злопчинский
 
60 - 31.12.12 - 14:36
(59) ну.. по формуле...
11 ботинок имеется в виду - доставаемых..?
   dclxvi
 
61 - 31.12.12 - 14:36
(60) да
   Злопчинский
 
62 - 31.12.12 - 14:40
(61) ну.. по формуле...
   dclxvi
 
63 - 31.12.12 - 14:44
(62) должна быть 1 но не получается.
   Злопчинский
 
64 - 31.12.12 - 15:00
(63) если m > n - тогда P=1
   dclxvi
 
65 - 31.12.12 - 19:25
(64) Это понятно. Вопрос про формулу.
   NS
 
66 - 31.12.12 - 20:05
(63) по простейшей методике рассаисанной выше - вероятность что они все разные равна нулю. Значит вероятность что есть хотя бы одна пара равна единице.
   dclxvi
 
67 - 31.12.12 - 20:27
(66) По какой методике?
1. (18/19)*(16/18)*(14/17)
2. С(0,n) * C(m,n) * 2^m / C(m,2n)
   NS
 
68 - 31.12.12 - 21:02
(67)
1*(18/19)*(16/17)*(14/16)*(12/15)*(10/14)*(8/13)*(6/12)*(4/11)*(2/10)*(0/9)
Прямой расчет вероятности
   NS
 
69 - 31.12.12 - 21:03
Ошибочка, знаменатель случайно с третьего множителя завысил наиединицу.
   Злопчинский
 
70 - 31.12.12 - 21:27
(68) а в общем виде записать формулу?
   Злопчинский
 
71 - 31.12.12 - 21:41
(69) то есть третьий множитель и далее должен выглядеть
1*(18/19)*(16/16)*(14/15)...?
   sda553
 
72 - 02.01.13 - 00:06
(45) Да, у меня такой же результат. Ну с учетом того что С(0,n)=1, то этот первый член можно не писать
c(m,n)*2^m/c(m,2n)
для m<n
При m=n вероятность равна 2^n/c(n,2n) что понятно, например, если у нас всего две пары, и мы вытягиваем два ботинка, то есть только 4 способа не взять ни одной пары, и 2 способа взять пары.
   Гений 1С
 
73 - 02.01.13 - 00:11
Я сегодня другую задачу прочитал.
Типо три двери - за одной автомобиль, за двумя другим - коза.
Человек должен выбрать одну дверь.
Потом ведущий открывает одну из дверей с козой (не ту что выбрал) и человек может выбрать - оставить свой выбор или выбрать другую дверь.
Каковы вероятности выигрыша в обоих случаях? гыгыгы. Т.е. имеет ли смысл менять выбор?
   Torquader
 
74 - 02.01.13 - 00:18
(73) Эта задача давно обсуждалась в том числе и здесь.
К сожалению, решение зависит от многих факторов - в частности - всегда ли ведущий просит сделать выбор.
Если, например, мы играем с машиной, и в неё заложено, что она нам откроет неправильную дверь всегда то получается:
1) Сначала мы выбираем дверь, то есть вероятность 1/3, что мы угадали (и 2/3, что не угадали).
2) Компьютер открывает пустую дверь (он всегда это может сделать), то получается, что с вероятностью 2/3 машина за оставшейся дверью.

Однако, если ведущий заинтересован, то есть делает такой "жест" только в том случае, если мы выбрали дверь, за которой машина, то тут получается по-другому:
1) Если мы не угадали, то там сразу показывают козу, то есть с вероятностью 2/3 мы просто идём домой.
2) Если мы угадали, то есть с вероятностью 1/3 нас просят поменять выбор - тогда его менять нельзя, так как в любом случае, мы остаёмся с козой.
   NS
 
75 - 02.01.13 - 00:22
(70) в общем виде?  Если вероятность ситуации p1, а вероятность события p2, то общая вероятность p1*p2
   Злопчинский
 
76 - 02.01.13 - 00:23
(74) резюме по задаче (пусть гений1с википиднет "парадок Монти-Холла") было такое - смена жвери ведет к повышению вероятности выигрыша.
   Злопчинский
 
77 - 02.01.13 - 00:25
(75) ненен.. хтитро как попытался вывернуться... - представим что пар около миллиона, и выбрать надо пордяка 10 тысяч бот... - я сомневаюсь, что формулу ты будешь записывать как выше.. ;-)
   NS
 
78 - 02.01.13 - 00:33
(77) через сочетания напишу.
   Злопчинский
 
79 - 02.01.13 - 01:17
угу, ждемс!
   sda553
 
80 - 02.01.13 - 01:18
(73) Это ты что то как то совсем баянишь. Читай хрестоматийную ролевую игру sda553 и ReaLg в этой теме. Наглядно и на опыте продемонстрировали парадокс.
Теор. вер. и три наперстка.
   NS
 
81 - 02.01.13 - 01:34
(79) чего ждем?!
В данном случае произведение по всем целым i от единицы до n-1
Max(20-i*2,0)/(20-i) для задачи (0)
   чупа
 
82 - 02.01.13 - 04:51
Ну это каким идиотом надо быть чтобы предлагать вероятность 0.307 ?
То есть вероятность вытащить 4 только правых или только левых ботинка = 0.7 ?

1Снеки...
   чупа
 
83 - 02.01.13 - 04:55
Решение же простое - давали выше:
Первый ботинок вытаскиваем любой.
Второй ботинок, той же ноги, что и первый Вероятность 9/19
Третий ботинок, той же ноги что первые два 8/18
Четвертый ботинок той же ноги что первые три 7/17

1-(9/19)*(8/18)*(7/17)


Вот этого тупого 1Снека над озабанить за тупость:
(35) >> (30) если из 10 пар - вытяниваем 4 бота и получаем 0.9, то при вытягивании 19 бот - веротяность явно зашкалит за 1....


Список тем форума
Рекламное место пустует  Рекламное место пустует
Программист всегда исправляет последнюю ошибку.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует