Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

РИБ ошибка

РИБ ошибка
Я
   mirror1982
 
30.12.12 - 11:59
Вылазиет ошибка:

Ошибка при вызове метода контекста (Подключиться): Аутентификация не прошла (SMTP error code 535, Incorrect authentication data: authentication failed for <utaxechangef@mail.ru>)

Вот код:

  //Сначала создаем объект Почта, который в зависимости от настроек будет типа ИнтернетПочта,
  //если используется прямое обращение к серверам, либо Почта если используется MAPI.
  ПочтовыйПрофиль=Новый ИнтернетПочтовыйПрофиль;
  ПочтовыйПрофиль.АдресСервераSMTP=СокрЛП(Константы.АдресСервераSMTPОбмена.Получить());
  ПочтовыйПрофиль.ПортSMTP=Константы.ПортСервераSMTPОбмена.Получить();
  ПочтовыйПрофиль.ПользовательSMTP=СокрЛП(Константы.ПользовательСервераSMTPОбмена.Получить());
  ПочтовыйПрофиль.ПарольSMTP=СокрЛП(Константы.ПарольПользователяSMTPОбмена.Получить());
  ПочтовыйПрофиль.ВремяОжидания=Константы.ВремяОжиданияСервера.Получить();
  ПочтовыйПрофиль.АутентификацияSMTP=СпособSMTPАутентификации.Login;
  ПочтовыйПрофиль.Пользователь=Константы.ПользовательСервераSMTPОбмена.Получить();
  ПочтовыйПрофиль.Пароль=Константы.ПарольПользователяSMTPОбмена.Получить();
  Почта=Новый ИнтернетПочта();
  Попытка
          Почта.Подключиться(ПочтовыйПрофиль);
  Исключение
             Сообщить("ОБМЕН: Ошибка при подключении к почтовому профилю! Обмен не выполнен! "+ОписаниеОшибки(),СтатусСообщения.ОченьВажное);
             Возврат;
  КонецПопытки;
  //Далее выбираем все узлы из плана обмена, за исключением текущего,
  //у которых установлен реквизит ВыполнятьОбмен.
  ВыборкаУзлов=ПланыОбмена.РаспределеннаяБаза.Выбрать();
  Пока ВыборкаУзлов.Следующий() Цикл
       Если (Не ВыборкаУзлов.ВыполнятьОбмен)ИЛИ(ВыборкаУзлов.Ссылка=ПланыОбмена.РаспределеннаяБаза.ЭтотУзел()) Тогда Продолжить; КонецЕсли;
       ЭлектронныйАдрес=СокрЛП(ВыборкаУзлов.ЭлектронныйАдрес);
       Если ЭлектронныйАдрес="" Тогда Продолжить; КонецЕсли;
       //С помощью объектов ЗаписьXML и ЗаписьСообщения выполняем запись изменений
       //для выбранного узла в xml-файл.
       Узел=ВыборкаУзлов.Ссылка;
       ЗаписьXML=Новый ЗаписьXML();
       ИмяФайлаСообщения=КаталогВременныхФайлов()+"Message_"+СокрЛП(ПланыОбмена.РаспределеннаяБаза.ЭтотУзел().Код)+"_"+СокрЛП(Узел.Код)+".xml";
       ЗаписьXML.ОткрытьФайл(ИмяФайлаСообщения);
       ЗаписьСообщения=ПланыОбмена.СоздатьЗаписьСообщения();
       ЗаписьСообщения.НачатьЗапись(ЗаписьXML,Узел);
       ПланыОбмена.ЗаписатьИзменения(ЗаписьСообщения);
       ЗаписьСообщения.ЗакончитьЗапись();
       ЗаписьXML.Закрыть();
       //Затем создаем новое письмо, прикрепляем к нему полученный xml-файл и
       //отправляем по адресу, указанному в реквизите ЭлектронныйАдрес узла.    
       Файл=Новый Файл(ИмяФайлаСообщения);
       ТемаСообщения="1С:Обмен "+СокрЛП(ПланыОбмена.РаспределеннаяБаза.ЭтотУзел().Код)+"_"+СокрЛП(Узел.Код);
       ПочтовоеСообщение = Новый ИнтернетПочтовоеСообщение;
       ПочтовоеСообщение.Тема = ТемаСообщения;
       ПочтовоеСообщение.Вложения.Добавить(ИмяФайлаСообщения, Файл.Имя);
       ПочтовоеСообщение.Получатели.Добавить(ЭлектронныйАдрес);
       Почта.Послать(ПочтовоеСообщение);
       Если Константы.ВыводитьСообщенияОбмена.Получить() Тогда
            Сообщить("ОБМЕН: Сообщение обмена для узла "+Узел.Наименование+" отправлено!",СтатусСообщения.Информация);
       КонецЕсли;
       УдалитьФайлы(ИмяФайлаСообщения);
  КонецЦикла;
  Почта.Отключиться();
 
 
   Fragster
 
1 - 30.12.12 - 12:02
(0) прочитай еще раз сообщение об ошибке
   mirror1982
 
2 - 30.12.12 - 12:03
(1) я прочитал и знаю, что написано, что логин и пароль некорректные. но я ввел их корректно
   Fragster
 
3 - 30.12.12 - 12:14
(2) ну, значит не повезло
   mirror1982
 
4 - 30.12.12 - 12:15
а если серьезно
   Fragster
 
5 - 30.12.12 - 12:16
(4) серьезно - неправильное имя пользователя и/или пароль

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует