Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

создание проводок

создание проводок
Я
   lamme
 
29.12.12 - 05:51
собственно ..
идет заполнение ТЧ документа из обработки по заполнению тч.
потом в док ставится признак - 
Объект.РучнаяКорректировка = истина;
    Объект.записать(режимзаписидокумента.Проведение);

 // проводки делаем
 

 Проводки = Объект.Движения.Хозрасчетный;


    
    для каждого Стр из ТабличнаяЧасть цикл
        Проводка = Проводки.Добавить();

        Проводка.СчетДт    = Стр.Счет;
        
   //    //БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетДт,Проводка.СубконтоДт,"Статьи затрат", Стр.СтатьяЗатрат ,Истина, );
 
       //БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетДт,Проводка.СубконтоДт,"Склады",       СтруктураШапкиДокумента.Склад);
 

        
        Проводка.СчетКт   = стр.СчетЗатрат;
        Проводка.КоличествоКт = Стр.Количество;
        
        
        Проводка.Содержание   = "Списание материалов в производство";
        Проводка.Сумма        = Стр.Себестоимость;


        
    конеццикла;



молча отрабатывает. проводок нет.
что не так делаю
 
 
   Ursus maritimus
 
1 - 29.12.12 - 05:59
Не записываешь
   lamme
 
2 - 29.12.12 - 06:01
чую что  Проводка.записать();
не взлетит
   lamme
 
3 - 29.12.12 - 06:05
ну да ... особенно если смотреть типовые проводки - которые создаются
там про запись вообще ни слова
   lamme
 
4 - 29.12.12 - 06:08
вот типовой пример из кода.
Проводки = Движения.Хозрасчетный;
    
   // Проводки по таре
 
    Для Каждого СтрокаТаблицы Из ТаблицаПоТаре Цикл
        
       // Бухгалтерский учет
 
        Проводка = Проводки.Добавить();
        Проводка.Период       = Дата;
        Проводка.Организация  = СтруктураШапкиДокумента.Организация;
        Проводка.Содержание   = "Передача тары";
        Проводка.Сумма        = СтрокаТаблицы.Сумма;
        
        Проводка.СчетДт       = СтрокаТаблицы.СчетУчета;
        БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетДт,Проводка.СубконтоДт,"Номенклатура", СтрокаТаблицы.Номенклатура,Истина, Заголовок);
        БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетДт,Проводка.СубконтоДт,"Склады",       СтруктураШапкиДокумента.Склад);
        
       // Для товаров, принятых на комиссию партия прописывается всегда 
 
        Если (ПартионныйУчет) Тогда 
            БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетДт,Проводка.СубконтоДт,"Партии", Ссылка, Истина, Заголовок);
        КонецЕсли;
        
        Проводка.КоличествоДт = СтрокаТаблицы.Количество;
        
       // Проверка - вид Операции - комиссия
 
        Если СтрокаТаблицы.СчетУчета.Забалансовый Тогда
            
            Если НЕ (СтрокаТаблицы.СчетУчета.ВидыСубконто.Найти(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Контрагенты ,"ВидСубконто") = Неопределено) Тогда
                Проводка.СубконтоДт.Контрагенты = СтруктураШапкиДокумента.Контрагент;
            КонецЕсли;
            
        Иначе
            
            Проводка.СчетКт   = СтруктураШапкиДокумента.СчетУчетаРасчетовПоТаре;
            БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетКт,Проводка.СубконтоКт,"Контрагенты",        СтруктураШапкиДокумента.Контрагент, Истина, Заголовок);
            БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетКт,Проводка.СубконтоКт,"Договоры",           СтруктураШапкиДокумента.ДоговорКонтрагента);
            
            Если СтруктураШапкиДокумента.СчетУчетаРасчетовПоТаре.Валютный Тогда
                Проводка.ВалютаКт        = СтруктураШапкиДокумента.ВалютаДокумента;
                Проводка.ВалютнаяСуммаКт = СтрокаТаблицы.СуммаВал;
            КонецЕсли;
            
        КонецЕсли;
        
        БухгалтерскийУчет.УстановитьПодразделенияПроводки(
            Проводка, СтруктураШапкиДокумента.ПодразделениеОрганизации, СтруктураШапкиДокумента.ПодразделениеОрганизации);
        
    КонецЦикла;// Проводки по таре
 


Документ = Помступление из переработки.
по аналогии - делаю и я.
Однако - результата нет
что не так?
   Kavar
 
5 - 29.12.12 - 06:10
Пример он внутри документа.
А ты обработкой делаешь.
   lamme
 
6 - 29.12.12 - 06:12
мм ... тогда ткните если не сложно пальцем - куда смотреть
   Kavar
 
7 - 29.12.12 - 06:12
ДокументОбъект.<Имя документа> (DocumentObject.<Имя документа>)
Записать (Write)
Синтаксис:

Записать(<РежимЗаписи>, <РежимПроведения>)
Параметры:

<РежимЗаписи> (необязательный)

Тип: РежимЗаписиДокумента.
Позволяет выбрать один из возможных режимов записи.
Значение по умолчанию: Запись 
<РежимПроведения> (необязательный)

Тип: РежимПроведенияДокумента. 
Позволяет выбрать один из возможных режимов проведения.
Значение по умолчанию: Неоперативный
Описание:

Записывает документ в базу данных.

Доступность:

Сервер, толстый клиент, внешнее соединение.
Примечание:

Для документов с поддержкой уникальности номеров в процессе записи, если нужно, проверяется уникальность номера.
Пример:

Попытка
   НовДокумент.Записать(РежимЗаписиДокумента.Проведение);
Исключение
    Текст = "ru = ""Невозможно провести документ."";"
     + " en = ""Document needs reposting.""";
    Предупреждение(НСтр(Текст));
КонецПопытки;
   lamme
 
8 - 29.12.12 - 06:15
7
не уловил.

я сначала в делаю
Объект.РучнаяКорректировка = истина;
Объект.записать(режимзаписидокумента.Проведение);


потом уже делаю проводки у документа.
   Kavar
 
9 - 29.12.12 - 06:17
Записать  - после проводок. )
   lamme
 
10 - 29.12.12 - 06:19
(9)
Проводка.записать();  -внутри цикла не рабоет.
ругается - метод Записать не обнаружен

как то так ... не дослвно
 
 Рекламное место пустует
   Ursus maritimus
 
11 - 29.12.12 - 06:19
(2) Слущай, ты столько лет занимаешься 1С. Пора бы уметь проводки-то записывать.
   Ursus maritimus
 
12 - 29.12.12 - 06:20
(10) Небор записей надо записывать, а не проводку
   Ursus maritimus
 
13 - 29.12.12 - 06:20
Набор.
   lamme
 
14 - 29.12.12 - 06:20
13
да. это уже понял.
   lamme
 
15 - 29.12.12 - 06:21
все. есть контакт!
спасибо

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует