Вход | Регистрация

1С:Предприятие ::

Метки: 

Обмен РИБ по OLE/COM

Я
   Necytij
 
28.12.12 - 20:32
Хочу осуществить. Видел как-то пару раз темы в виде статьи/обсуждения и продаваемую обработку на инфостарте. Сейчас не могу найти ни одной зацепки как это организовать. Ткните меня носом, пожалуйста, куда следует...
 
 
   Necytij
 
1 - 28.12.12 - 20:40
А вообще какая разница РИБ/ не РИБ, план обмена есть. Тот же метод должен быть что и по http://infostart.ru/public/82865/ , так?
   Рэйв
 
2 - 28.12.12 - 20:44
(1)РИБ - это базы связанные в единую структуру с жесткой зависимостью и отслеживанием коллизий на уровне системы.

Не РИБ - это просто левые базы свзанные по какому то левому алгоритму обмена, написанном Васей Пупкиным( может даже через тот же СОМ, хотя на кой он в РИБ не пойму)
   Necytij
 
3 - 28.12.12 - 21:35
РИБ / не РИБ я имел ввиду, все равно из одного и того же места тянуть зарегистрированные изменения данных.
Вроде как быстрее такой метод + кое-какие камни есть в пересылке файлов, хоть фтп, хоть почтой, особенно если, например, конфа обновилась. А тут я камней и грабель еще не знаю, а вдруг их нет? xD
   Fragster
 
4 - 28.12.12 - 21:37
дарю:


    ЗаписьXML = Новый ЗаписьXML;
    ЗаписьXML.УстановитьСтроку();
    ИмяКорня = "array";
    ЗаписьXML.ЗаписатьНачалоЭлемента(ИмяКорня);
    Для каждого Элемент Из МассивОбъектов Цикл
        СериализаторXDTO.ЗаписатьXML(ЗаписьXML, Элемент, НазначениеТипаXML.Явное);
    КонецЦикла;
    ЗаписьXML.ЗаписатьКонецЭлемента();
    XML = ЗаписьXML.Закрыть();
    
    Для каждого Стр Из Получатели Цикл
        Состояние("Обработано: " + Получатели.Индекс(Стр) + " / " + Получатели.Количество());
        Попытка
            Соединитель = Новый COMObject(КомОбъект);
            КОМ = Соединитель.Connect(Стр.СтрокаСоединения);
            
            КОМЧтениеXML = КОМ.NewObject("ЧтениеXML");
            КОМЧтениеXML.УстановитьСтроку(XML);
            КОМЧтениеXML.Прочитать();// начало корневого элемента
 
            КОМЧтениеXML.Прочитать();// начало данных
 
            Пока КОМЧтениеXML.Имя <> ИмяКорня Цикл
                КОМЗначение = КОМ.СериализаторXDTO.ПрочитатьXML(КОМЧтениеXML);
                КОМЗначение.Записать();
            КонецЦикла;
            
        Исключение
            КОМ = Неопределено;
            Сообщить(Стр.СтрокаСоединения);
            СообщитьОписаниеОшибки(ИнформацияОбОшибке());
        КонецПопытки
    КонецЦикла;
   Fragster
 
5 - 28.12.12 - 21:38
это у меня кусок обработки, которая во много одинаковых баз кидает по кому объекты ИБ
   Necytij
 
6 - 28.12.12 - 21:38
Спасибо, попробую применить.
   Necytij
 
7 - 28.12.12 - 21:39
Так это опять обмен через файл? "ЗаписьXML.Закрыть()"
   Рэйв
 
8 - 28.12.12 - 21:42
(5)Вот только ты забыл сказать одну важную вещь:-)
Что такое и где определяется СериализаторXDTO :-)
Я думаю у падавана точно возникнут вопросы:-)
   Necytij
 
9 - 28.12.12 - 21:42
Я думал что-то вроде алгоритма:
Соединение
Запуск экспортной функции/обработки возвращающей партию объектов рег. как измененные. Вернул не пустой набор, тогда
применение изменений.
Передача партии изменений собственных в функцию два. Вернула истина, значит пометили, как принято...
Извращенно? У меня часто такие фантазии - люди говорят.
   Necytij
 
10 - 28.12.12 - 21:43
Я обычно домом пользуюсь, не аналоги по функционалу разве?
 
 Рекламное место пустует
   Fragster
 
11 - 28.12.12 - 21:46
(7) хоть бы СП почитал...
   Рэйв
 
12 - 28.12.12 - 21:47
(11)СП резко подскочили в цене на Сотби. Их у всех крадут.
   Necytij
 
13 - 28.12.12 - 21:54
СП (газета) — молдавский региональный еженедельник, издаётся в Бельцах с 1994 года.
Я не в Бельцах живу.

Что такое СП? RTFM? Радченко?
   Necytij
 
14 - 28.12.12 - 22:02
Видимо все-таки справка, прочитал, осознал. Каюсь. ))


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует