Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Закрытие кассовой смены - модифицировать

Закрытие кассовой смены - модифицировать
Я
   RasuLL
 
28.12.12 - 12:54
Как можно модифицировать отчет так чтобы, закрывал кассовую смену не за один день, а за несколько, от даты до даты? Я добавила к форме две даты, ДатаНач и ДатаКон и заменила в обработке везде Дата на них. Интервал беру 3 дня, при закрытии очищает Чеки и добавляет в один документ Отчет о розничных продажах. Как сделать так чтобы каждый день добавлял отдельно по какой дате чек по той же отчет о розничных?
 
 
   RasuLL
 
1 - 28.12.12 - 13:14
не отчет а обработка
   NcSteel
 
2 - 28.12.12 - 13:46
(0)

1. На форму добавляешь две даты
2. В цикле по каждому дню вызываешь процедуру которая собирает чеки в ОоРП.
   RasuLL
 
3 - 28.12.12 - 14:06
(2)
Для каждого ДатаНач по ДатаКон Цикл
        
    КоманднаяПанельДействийЗакрытьСмену(Кнопка)
КонецЦикла

NcSteel, а что писать в цикл?
   cw014
 
4 - 28.12.12 - 14:10
(3) Конфа какая, платформа какая, бюджет какой? :)
   RasuLL
 
5 - 28.12.12 - 14:19
(4) хочу сама + помощь) УПП 8.2 редакция 1,2

Для ДатаНач = Дата по ДатаКон Цикл
    ДатаНач = Дата + Дата(КонецДня + 1)    
    КоманднаяПанельДействийЗакрытьСмену(Кнопка)
КонецЦикла;
   Базис
 
6 - 28.12.12 - 14:22
Закон о ККТ поправь ещё, в статье про длительность кассовой смены.
   RasuLL
 
7 - 28.12.12 - 14:23
Как к концу дня прибавить 1 секунду?
   drcrasher
 
8 - 28.12.12 - 14:24
(0) z-отчет с кассы каждый день снимаете?
вот ОоРП зетку сам делает.
а вообще логика проста цикл от начДата до конДата и на каждую дату ОоРП создать - заполнить - провести
   RasuLL
 
9 - 28.12.12 - 14:29
(8) понимаю что просто но не дня меня
Для ДатаНач = Дата по ДатаКон Цикл
    ДатаНач = Дата + (КонецДня(Дата) + 1);    
    КоманднаяПанельДействийЗакрытьСмену(Кнопка);
КонецЦикла
   RasuLL
 
10 - 01.01.13 - 22:39
К обработке скопировала реквизит Дата на КонечнаяДата, добавила ее к форме и создала кнопку ОК с действием
Для Сч = Дата По КонечнаяДата Цикл
    ОбработкаЧековККМ();    
КонецЦикла;

выдает ошибку
{Форма.Форма(821)}: Преобразование значения к типу Число не может быть выполнено
    КонецЦикла;
 
 Рекламное место пустует
   kotletka
 
11 - 01.01.13 - 22:42
(10)даты в цикле нельзя использовать, засунь их в массив и обходи в цикле, насчет последней секунды используй Границу
   RasuLL
 
12 - 01.01.13 - 23:04
(11) а что тут не так?
МассивДат = Новый Массив;
    ТекДата = Дата;
    Пока ТекДата < КонечнаяДата Цикл
    МассивДат.Добавить(ТекДата);
    ТекДата = КонецДня(ТекДата) + 1;
    ОбработкаЧековККМ();
КонецЦикла;
   RasuLL
 
14 - 02.01.13 - 10:42
так сработало

        МассивДат = Новый Массив;
      Пока Дата < КонечнаяДата Цикл
    МассивДат.Добавить(Дата);
    Дата = КонецДня(Дата) + 1;
    ОбработкаЧековККМ();
      КонецЦикла;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует