Вход | Регистрация


1С:Предприятие ::

Метки: 

КД

Я
   Aleksei_Pro
 
28.12.12 - 11:39
После загрузки написал у организации:
Запрос = Новый Запрос;
Запрос.текст = "
|ВЫБРАТЬ
|КонтактнаяИнформация.Объект,
|КонтактнаяИнформация.Тип,
|КонтактнаяИнформация.Вид,
|КонтактнаяИнформация.Представление,
|КонтактнаяИнформация.Поле1,
|КонтактнаяИнформация.Поле2,
|КонтактнаяИнформация.Поле3,
|КонтактнаяИнформация.Поле4,
|КонтактнаяИнформация.Поле5,
|КонтактнаяИнформация.Поле6,
|КонтактнаяИнформация.Поле7,
|КонтактнаяИнформация.Поле8,
|КонтактнаяИнформация.ТипДома,
|КонтактнаяИнформация.ТипКвартиры,
|КонтактнаяИнформация.ТипКорпуса,
|КонтактнаяИнформация.Поле9,
|КонтактнаяИнформация.Поле10,
|КонтактнаяИнформация.Комментарий,
|КонтактнаяИнформация.ЗначениеПоУмолчанию
|ИЗ
|РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
|ГДЕ
|КонтактнаяИнформация.Объект = &Объект";
Запрос.УстановитьПараметр("Объект",Источник);
Выборка = Запрос.выполнить().Выбрать();
Пока выборка.следующий() Цикл
    ВыгрузитьПоПравилу(Выборка,,,,"КонтактнаяИнформация");
КонецЦикла;


Ругается , "Неверные параметры в операции сравнения. Нельзя сравнивать поля неограниченной длины и поля несовместимых типов."

Хотя такой код работает в контрагентах , в чем траблы?
 
 
   ДенисЧ
 
1 - 28.12.12 - 11:40
"поля несовместимых типов"
   Жан Пердежон
 
2 - 28.12.12 - 11:42
после загрузки ВыгрузитьПоПравилу? 
нет слов
   cw014
 
3 - 28.12.12 - 11:48
ПослеЗАГРУЗКИ????
   Aleksei_Pro
 
4 - 28.12.12 - 11:48
после выгрузки опписался
   cw014
 
5 - 28.12.12 - 11:48
Да ты пятниццо, как я посмотрю
   cw014
 
6 - 28.12.12 - 11:49
А как ты определяешь что он у оргов не работает?
   Aleksei_Pro
 
7 - 28.12.12 - 11:54
он на ошибке вываливается я же говорю,(контактные лица тоже) :
ПКО                    =  КонтактныеЛица  (Справочник: Контактные лица)
    Объект                 =  Петров а  (Справочник объект: Контактные лица)
    Обработчик             =  ПослеВыгрузкиОбъекта
    ОписаниеОшибки         =  Ошибка при вызове метода контекста (Выполнить): {(25, 29)}: Неверные параметры в операции сравнения. Нельзя сравнивать поля
 неограниченной длины и поля несовместимых типов.
КонтактнаяИнформация.Объект <<?>>= &Объект
   Aleksei_Pro
 
8 - 28.12.12 - 11:59
обмен через РИБ
   cw014
 
9 - 28.12.12 - 12:00
Источник.Ссылка попробуй
   cw014
 
10 - 28.12.12 - 12:00
Хотя не факт
 
 Рекламное место пустует
   Aleksei_Pro
 
11 - 28.12.12 - 12:01
не пробавал сразу же , тоже самое
   vicof
 
12 - 28.12.12 - 12:05
ВЫРАЗИТЬ(КонтактнаяИнформация.Комментарий КАК Строка(100)) попробуй
   Aleksei_Pro
 
13 - 28.12.12 - 12:07
попробую , но типы совпадают у комментария
   Aleksei_Pro
 
14 - 28.12.12 - 12:13
именно так , странно ,как так , типы и размер проставлен одинаково в регистре сведений ( Строка(НЕОГ))...спасибо
   vicof
 
15 - 28.12.12 - 12:15
Запрос не поддерживает строки неограниченной длины
   Aleksei_Pro
 
16 - 28.12.12 - 12:49
Организация взлетела , но контактные лица нет.:
Если (НЕ Источник.ЭтоГруппа) И (НЕ Источник.ПометкаУдаления) Тогда
    Запрос = Новый Запрос;
    Запрос.текст = "
    |ВЫБРАТЬ
    |КонтактнаяИнформация.Объект,
    |КонтактнаяИнформация.Тип,
    |КонтактнаяИнформация.Вид,
    |ВЫРАЗИТЬ(КонтактнаяИнформация.Представление КАК Строка(300)) КАК Представление,
    |КонтактнаяИнформация.Поле1,
    |КонтактнаяИнформация.Поле2,
    |КонтактнаяИнформация.Поле3,
    |КонтактнаяИнформация.Поле4,
    |КонтактнаяИнформация.Поле5,
    |КонтактнаяИнформация.Поле6,
    |КонтактнаяИнформация.Поле7,
    |КонтактнаяИнформация.Поле8,
    |КонтактнаяИнформация.ТипДома,
    |КонтактнаяИнформация.ТипКвартиры,
    |КонтактнаяИнформация.ТипКорпуса,
    |КонтактнаяИнформация.Поле9,
    |КонтактнаяИнформация.Поле10,
    |ВЫРАЗИТЬ(КонтактнаяИнформация.Комментарий КАК Строка(100)) КАК Комментарий,
    |КонтактнаяИнформация.ЗначениеПоУмолчанию
    |ИЗ
    |РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
    |ГДЕ
    |КонтактнаяИнформация.Объект = &Объект";
    Запрос.УстановитьПараметр("Объект",Источник);
    Выборка = Запрос.выполнить().Выбрать();
    Пока выборка.следующий() Цикл
        ВыгрузитьПоПравилу(Выборка,,,,"КонтактнаяИнформация");
    КонецЦикла;
КонецЕсли;
   hhhh
 
17 - 28.12.12 - 13:06
(14) там зависит от настроек sql-сервера. Значит, элементарно, с контрагентами это у вас на другом компе было.
   Aleksei_Pro
 
18 - 28.12.12 - 13:11
(17) вот щас запускаю с компа , орг и контрг грузит а контактная информация по контактным лицам все равно на ошибке вываливается
   Aleksei_Pro
 
19 - 28.12.12 - 13:21
Ни чего не понимаю , только что работал и теперь опять даже контрагенты ругаются на данный код.
   Aleksei_Pro
 
20 - 28.12.12 - 13:27
Не контрагенты взлетели ( без представления выразить - хотя представление тоже (СТРОКА (НЕОГР)) - а вот организация нет...может это быть связано с SQL если да то что именно?
   Naumov
 
21 - 28.12.12 - 13:42
у тебя в контактной информации запись с пустым объектом, либо с объектом-строкой встретилась скорее всего. Попробой перед сравнением объекта сравнение на ссылку на нужный тип вставить.
   Naumov
 
22 - 28.12.12 - 13:43
а Источник не строка случаем?



Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует