Вход | Регистрация

1С:Предприятие ::

Метки: 

как записать в справочник

Я
   sr_deadman
 
28.12.12 - 10:36
Профессиональное программирование в 1С:Предприятии 8.х
www.Spec8.ru
Базовый курс
Домашнее задание №5. Блок 1.
Необходимо хранить время начала и окончания рабочего дня предприятия в константах.
Создайте справочник «Варианты обедов». Занесите в него предопределенные элементы
• Рыба;
• Мясо;
• Курица.
Создайте роль, которая будет содержать права на все объекты. Для роли отметьте
признак установки полных прав на новые объекты.
В списке пользователей создайте двух пользователей с полными правами: Администратор
и Менеджер.
Создайте справочник «Пользователи», в нем определите реквизит «Администратор»
булевского типа.
Создайте справочник «ОбедыПользователей», подчиненный «Пользователям».
Определите реквизиты:
• Дата;
• Вариант обеда (ссылка на соответствующий справочник).
Справочник «Пользователи» должен автоматически синхронизироваться со списком
пользователей. Для этого при старте приложения проверяйте есть ли текущий пользователь в
справочнике. Если нет, его нужно программно добавить.
Опираясь на эти данные, модифицируйте алгоритмы домашнего задания №4:
• Проверка при входе и выходе и диалог о запросе обеда не должны осуществляться
для пользователей с флагом «Администратор»;
• Время работы предприятия берется из констант;
• Варианты обеда выбираются из одноименного справочника, но выбирать нужно
элементы, не помеченные на удаление;
• Результат выбора пользователя записывайте в справочник
«ОбедыПользователей». При выборе нескольких вариантов выполняйте запись
нескольких элементов справочника;
• Вопрос о выборе обеда должен задаваться только в том случае, если ранее
пользователь не выбирал обед. Например, при первом входе в систему
пользователь указал вариант обеда, тогда при втором запуске в эту же дату вопрос
задавать не следует.
----------------------------------------------------------------------
надо выполнить это задание
• Результат выбора пользователя записывайте в справочник
«ОбедыПользователей». При выборе нескольких вариантов выполняйте запись
как записать в справочник
 
 
   tdm
 
1 - 28.12.12 - 10:38
и ? ...вы у нас каждое задание на форум постить будете, а как же самостоятельно подумать
   Maxus43
 
2 - 28.12.12 - 10:39
где вопрос?
   Ursus maritimus
 
3 - 28.12.12 - 10:39
А там перед домашним заданием ничего не было? Может там почитать?
   sr_deadman
 
4 - 28.12.12 - 10:40
мне надо ее выполнить
вопрос:
• Результат выбора пользователя записывайте в справочник
«ОбедыПользователей». При выборе нескольких вариантов выполняйте запись 
как записать в справочник
   sr_deadman
 
5 - 28.12.12 - 10:40
я сделал так
 Функция Записать()Экспорт
     Спр = Справочники.ОбедыПользователей.СоздатьЭлемент();
     Спр.Наименование = ОбщийМодульСервер.Проверка();                                      
     Спр.Записать();
     Возврат Спр;
 КонецФункции
   Ursus maritimus
 
6 - 28.12.12 - 10:41
ОбщийМодульСервер.Проверка();  
Это что?
   tdm
 
7 - 28.12.12 - 10:41
(2) (3) да это домашнее задание, простейшее!!!
блеать, не могу сдержаться...специально чтобы люди думали и эксперементировали...НА ФОРУМ это выложить...как такие люди работать то будут!)
простите не сдержался...
   sr_deadman
 
8 - 28.12.12 - 10:42
общийМодульПроверка
Функция Проверка()Экспорт
     Выборка = Справочники.ВариантыОбедов.Выбрать();
     СписокЗначений = Новый СписокЗначений;
     Пока Выборка.Следующий() Цикл
         Если Не Выборка.ПометкаУдаления Тогда
             СписокЗначений.Добавить(Выборка.Ссылка);
         КонецЕсли;
     КонецЦикла;
     Возврат СписокЗначений;
 КонецФункции
   Ursus maritimus
 
9 - 28.12.12 - 10:44
(8) И причем тут наименование?
   tdm
 
10 - 28.12.12 - 10:44
(8) у вас преподаватель закрепленный за вами... вам правда лучше на начальном этапе САМОМУ пробовать
 
 Рекламное место пустует
   sr_deadman
 
11 - 28.12.12 - 10:45
я тока учусь 1с мне сказали это задание выполнить
   Maxus43
 
12 - 28.12.12 - 10:46
(11) я бы с курсов у УЦ начал, там живой преподователь объясняет, понятней намного
   salvator
 
13 - 28.12.12 - 10:47
Совсем обнаглели, неучи.
   tdm
 
14 - 28.12.12 - 10:47
(11) я понимаю, сам курсы на заре 8-ки вел... если это кажется сложным вернитесь назад
это учеба, и лучше её самому прорешать, правда-правда если хотите дальше двигаться
тут много спецов которые решат это быстро но вам то это ничего не даст
   sr_deadman
 
15 - 28.12.12 - 10:47
преподавателя пока нет
   tdm
 
16 - 28.12.12 - 10:48
(14) >>вернитесь назад 
в смысле вернитесь на несколько тем назад, прорешайте САМОСТОЯТЕЛЬНО, я вам не из вредности это советую)
с наступающим! и успехов в освоении
   sr_deadman
 
17 - 28.12.12 - 10:49
я запись сделал примерно так

Спр = Справочники.ОбедыПользователей.СоздатьЭлемент(); 
  Спр.Записать();
я сделал так
   Godofsin
 
18 - 28.12.12 - 10:56
(17) Реквизиты заполняй
   Schwonder
 
19 - 28.12.12 - 11:22
Сварщики, говорят, сегодня не плохо зарабатывают.


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует