Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Типы значений

Типы значений
Я
   mirror1982
 
27.12.12 - 19:34
Есть реквизит документа "Лицо", у него 2 типа значения (составной тип данных): справочник контрагент, справочник сотрудники. Как сделать так, чтобы при выборе другого реквизита документа "операция", в зависимости от его значения, тип для выбора значения реквизита "лицо" менялся (становился либо справочник сотрудники, либо справочник контрагенты)?
 
 
   Фокусник
 
1 - 27.12.12 - 19:37
(0) присваивать реквизиту пустую ссылку нужного типа
   Vladal
 
2 - 27.12.12 - 19:55
(0) В свойствах реквизита найди поле Тип, нажми на кнопку с точками и в диалоге вверху включи флажок "Составной тип данных". После этого в дереве метаданных можешь указать несколько типов флажками.

После этого программно определяй тип формы документа. Копипаста из типовой конфигурации, описывающая пример из (1):

        Если клЗначениеНеЗаполнено(ЭлементыФормы.РодительНовыхЮрЛицПлатимМыУТ.Значение) Тогда
            ЭлементыФормы.РодительНовыхЮрЛицПлатимМыУТ.Значение     = Справочники[ПолучитьИмяОбъектаКонфигурации("ТипСправочникаЮрЛицо")].ПустаяСсылка();
        КонецЕсли;    
        Если клЗначениеНеЗаполнено(ЭлементыФормы.РодительНовыхЮрЛицПлатятНамУТ.Значение) Тогда
            ЭлементыФормы.РодительНовыхЮрЛицПлатятНамУТ.Значение     = Справочники[ПолучитьИмяОбъектаКонфигурации("ТипСправочникаЮрЛицо")].ПустаяСсылка();
        КонецЕсли;    
    КонецЕсли;
   mirror1982
 
3 - 27.12.12 - 20:02
всем спасибо!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует