Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Помогите в решение проблемы!!!!!

Помогите в решение проблемы!!!!!
Я
   Wirtox
 
27.12.12 - 17:10
Мне нужно программно удалять строчки с регистра сведений. Написал вот такой код:
&НаСервере
Процедура УдалитьНаСервере()
Таб = РеквизитФормы.ТабЧасть1;
НаборУдаляемыхЗаписей = Новый СписокЗначений;
    Для каждого Стр Из Таб Цикл
        Если Стр.Отметка = Истина Тогда
            НаборУдаляемыхЗаписей.Добавить(Стр);        
            Отбор = Новый Структура;
            Отбор.Вставить("Номенклатура", Стр.Номенклатура);
            Выборка = РегистрыСведений.РегистрСведений1.Выбрать(,,Отбор);
            Выборка.ПолучитьМенеджерЗаписи().Удалить();
        КонецЕсли;
    КонецЦикла;
    
КонецПроцедуры 


И оно выдает вот такую ошибку :
{Обработка.РегистрыСведений.Форма.Форма.Форма(65)}: Ошибка при вызове метода контекста (Выбрать)
            Выборка = РегистрыСведений.РегистрСведений1.Выбрать(,,Отбор);
по причине:
Недопустимое значение параметра (параметр номер '3')
Недопустимое значение параметра (параметр номер '3')


что я делаю не так и как это решить ?
 
 
   le_
 
1 - 27.12.12 - 17:13
(0) Номенклатура в регистре сведений индексируется?
   le_
 
2 - 27.12.12 - 17:14
СП:
<Отбор> (необязательный)
Тип: Структура.
Задает поле и значение отбора открываемой выборки. Ключ структуры описывает имя поля, а значение структуры - значение отбора по этому полю. В качестве полей для отбора могут задаваться измерения или реквизиты, для которых в конфигураторе признак индексирования установлен в значение "Индексировать" или установлен признак "Ведущее".
   le_
 
3 - 27.12.12 - 17:17
   Wirtox
 
4 - 27.12.12 - 17:20
сделал что-бы номенклатура индексировалась теперь выдает вот такую ошибку:
{Обработка.РегистрыСведений.Форма.Форма.Форма(66)}: Ошибка при вызове метода контекста (ПолучитьМенеджерЗаписи)
            Выборка.ПолучитьМенеджерЗаписи().Удалить();
по причине:
Запись не выбрана
   le_
 
5 - 27.12.12 - 17:20
(4) А где Выборка.Следующий() ?
   zak555
 
6 - 27.12.12 - 17:21
что в ТЧ ?
   Wirtox
 
7 - 27.12.12 - 17:22
а про выборка следующий я как-то забыл )) 
сейчас попробую
   Serg_1960
 
8 - 27.12.12 - 17:26
(0) типа как-то так :)
НаборЗаписей = РегистрыСведений.ВашРегистр.СоздатьНаборЗаписей();
НаборЗаписей.Отбор.РегистраторИлиКакоеТоИзмерение.Установить(НужноеЗначение);
НаборЗаписей.Записать();
   Wirtox
 
9 - 27.12.12 - 17:26
Добавил выборка следующий и ничего, не могу понять что я делаю не так...
   le_
 
10 - 27.12.12 - 17:30
Отбор = Новый Структура;
Отбор.Вставить("Тип", Перечисления.ТипыКонтактнойИнформации.Другое);
Выборка = РегистрыСведений.КонтактнаяИнформация.Выбрать(Отбор);
Пока Выборка.Следующий() Цикл
    Выборка.ПолучитьМенеджерЗаписи().Удалить();
КонецЦикла;


Либо через набор записей.
 
 Рекламное место пустует
   Wirtox
 
11 - 27.12.12 - 17:40
Все спасибо разобрался..

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует