Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Розничная цена НЕ корректируется при изменении склада

v7: Розничная цена НЕ корректируется при изменении склада
Я
   twix
 
27.12.12 - 17:06
При изменении склада в документе Реализация(розница) на розничный склад, в табличной части документа при Подборе, цены на товары невозможно изменить, а для оптового склада цены менять можно.
Процедура ПриИзмененииСклада()
    
    Если СтарыйСклад <> Склад Тогда
        
        Если Склад.Выбран()=1 Тогда   
            
            Если (Склад.РозничныйСклад = 1) Тогда
                Если (Склад.ОблагаетсяЕНВД = 1) Тогда
                    НовоеОблагаетсяЕНВД = 1;
                Иначе
                    НовоеОблагаетсяЕНВД = 0;
                КонецЕсли;
                
                Если ПустоеЗначение(ТипЦен) = 0 Тогда
                    ТипЦен = "";
                КонецЕсли;
            Иначе     
                НовоеОблагаетсяЕНВД = 0;
                
                Если ПустоеЗначение(ТипЦен) = 1 Тогда
                    ТипЦен    = глЗначениеПоУмолчанию("ОсновнойТипЦенПродажи");
                КонецЕсли;
            КонецЕсли;                           
            
           // зададим вопрос о пересчете налогов
 
            Если (НовоеОблагаетсяЕНВД <> ОблагаетсяЕНВД) и (КоличествоСтрок()>0) Тогда
                ТекстВопроса = "Для склада """ + Склад.Наименование + " порядок 
                    |налогообложения отличается от установленного в документе."+
                    ?(НовоеОблагаетсяЕНВД=1,"  Не облагается ЕНВД -> облагается ЕНВД."
                    ,"  Облагается ЕНВД -> не облагается ЕНВД.");
                ТекстВопроса = ТекстВопроса + РазделительСтрок+"Пересчитать суммы налогов в документе?";
                Ответ = Вопрос(ТекстВопроса ,"Да+Нет", 60); 
                    
                Если Ответ = "Нет" Тогда
                    НовоеОблагаетсяЕНВД = ОблагаетсяЕНВД;// не изменяем
 
                КонецЕсли;
            КонецЕсли;
 
 
   Fedot200
 
1 - 27.12.12 - 17:12
Продолжайте наблюдения. (с)
   twix
 
2 - 27.12.12 - 17:32
(1) Я уже не знаю что менять там. Я модуль не тот вставила нечаянно. Что надо сделать в модуле?
может здесь надо менять что-то:
Если Склад.РозничныйСклад = 1 Тогда
           // на розн.складе всем разрашаем выбирать цену из списка
 
            Форма.Цена.Доступность(1);
            Форма.Цена.Редактирование(0);
        Иначе
            Форма.Цена.Доступность(глПолучитьПолномочие("РазрешитьРедактированиеЦенВдокументах"));
            Форма.Цена.Редактирование(1);
        КонецЕсл
   Fedot200
 
3 - 27.12.12 - 17:40
(2) Помогло?
   twix
 
4 - 27.12.12 - 17:42
(3) нет, делаю так, тоже не получается:
 Если Склад.РозничныйСклад = 1 Тогда
           // на розн.складе всем разрашаем выбирать цену из списка
 
            Форма.Цена.Доступность(глПолучитьПолномочие("РазрешитьРедактированиеЦенВдокументах"));
            Форма.Цена.Редактирование(1);
        Иначе
            Форма.Цена.Доступность(глПолучитьПолномочие("РазрешитьРедактированиеЦенВдокументах"));
            Форма.Цена.Редактирование(1);
        КонецЕсли;
   Fedot200
 
5 - 27.12.12 - 17:46
(4) А где цену то не дает менять, в документе?
   Fedot200
 
6 - 27.12.12 - 17:48
+ (5) в табличной части документа нет возможности сменить цену?
   twix
 
7 - 27.12.12 - 17:49
(5) В табличной части невозможно изменить цену, да даа
   Fedot200
 
8 - 27.12.12 - 17:56
(7) Доступность()
   koreav
 
9 - 27.12.12 - 18:00
(0) на розничном складе учет в разрезе цен
   twix
 
10 - 27.12.12 - 18:05
(8) Доступность()  сделала, но та же история
 
 Рекламное место пустует
   twix
 
11 - 27.12.12 - 18:06
(9) не поняла, что вы имеете в виду?
   KRV
 
12 - 27.12.12 - 18:06
Права у усера урезаны..
   twix
 
13 - 27.12.12 - 18:08
(12) у меня полные права вроде бы ) но для оптового склада цены ведь корректируются
   twix
 
14 - 27.12.12 - 18:17
при выборе оптового склада, цены на товары уже появляются в табличной части, а при выборе розничного склада все цены равны нулю и их невозможно исправить
   PALESIA
 
15 - 27.12.12 - 18:49
(0) может стоить глянуть в форму, которая вызывается при подборе: чтоит ли там галка ручного изменения периодических реквизитов?
   PALESIA
 
16 - 27.12.12 - 18:51
+(15) в справочнике галку глянуть нужно, и если реквизит - периодика изменять через историю
   AntiBuh
 
17 - 27.12.12 - 19:08
(14) если ТиС можно разово воспользоваться изменением спецификации (на кнопочке действия вроде)
а вообще может остатков просто нет на этом складе?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует