Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Упп зачем при вводе документа ПоступлениеТоваровИУслуг два раза вызывается

Упп зачем при вводе документа ПоступлениеТоваровИУслуг два раза вызывается
Я
   sidalexsandr
 
27.12.12 - 15:51
Упп зачем при вводе документа ПоступлениеТоваровИУслуг два раза вызывается Процедура:
1) В модуле формы документа в Процедуре ПриОткрытии()
ЗаполнениеДокументов.ЗаполнитьШапкуДокумента(ЭтотОбъект, "Покупка", ПараметрОбъектКопирования);
2) В модуле объекта в Процедуре ОбработкаЗаполнения()
ЗаполнениеДокументов.ЗаполнитьШапкуДокумента(ЭтотОбъект, "Покупка");

?
 
 
   shuhard
 
1 - 27.12.12 - 15:55
(0) а тебе не пох ?
   Prince
 
2 - 27.12.12 - 15:55
Убери одну и увидишь ;)
   sidalexsandr
 
3 - 27.12.12 - 16:00
(1) Нет. Надо переносить документы в УПП на подобии 7.7 используя Процедуры из типового Уппца.
   pessok
 
4 - 27.12.12 - 16:04
(0) можно подумать, это мы сидели и ваяли код уппырища...
   mehfk
 
5 - 27.12.12 - 16:06
(0) Встречный вопрос, почему в модуле формы док-та "Комплектация номенклатуры" в ПриОткрытии() есть такой код
Если ЭтоНовый() Тогда 
...
    Если НЕ ЗначениеЗаполнено(НДСвСтоимостиТоваров) Тогда
        НДСвСтоимостиТоваров = Перечисления.ДействиеНДСВСтоимостиТоваров.НеИзменять;
    КонецЕсли;
...
КонецЕсли;

а в модуле док-та в "ОбработкаЗаполнения" нет?
   Serg_1960
 
6 - 27.12.12 - 16:13
(0) Это ты загнул насчет "два раза вызывается". Наверное из-за невнимательности.
   shuhard
 
7 - 27.12.12 - 16:16
(3)[ Надо переносить документы в УПП на подобии 7.7 ]
не взлетит
   Serg_1960
 
8 - 27.12.12 - 16:34
(0) Не "два раза", а - четыре раза шапка документа заполняется. И это только в процедуре обработки заполнения модуля объекта :))

Процедура ОбработкаЗаполнения(Основание)

    ТипОснования = ТипЗнч(Основание);

    Если ТипОснования = Тип("ДокументСсылка.ЗаказПокупателя") Тогда
...
    ИначеЕсли ТипОснования = Тип("ДокументСсылка.ПередачаТоваров") Тогда
        ЗаполнениеДокументов.ЗаполнитьШапкуДокументаПоОснованию(ЭтотОбъект, Основание);
        
        Если Основание.ВидОперации <> Перечисления.ВидыОперацийПередачаТоваров.ВПереработку Тогда
           //договор мог уже заполниться - перезаполним
 
            ЗаполнениеДокументов.ПриИзмененииЗначенияКонтрагента(ЭтотОбъект, мСтруктураПараметровДляПолученияДоговора);

            Возврат;
        КонецЕсли;
        ЗаполнениеДокументов.ЗаполнитьШапкуДокументаПоОснованию(ЭтотОбъект, Основание);
       // Заполнение шапки.
 
        ЗаполнениеДокументов.ЗаполнитьШапкуДокумента(ЭтотОбъект);
...
КонецЕсли;
...
    ЗаполнениеДокументов.ЗаполнитьШапкуДокумента(ЭтотОбъект, "Покупка");
...
КонецПроцедуры
   Maxus43
 
9 - 27.12.12 - 16:37
а если учесть что в 8.2 щас ОбработкаЗаполнения вызывается и при смоздани нового - короче много раз делается фигня
   mehfk
 
10 - 27.12.12 - 17:41
(9) А еще в самой новой УПП древнюччая БСП или предок БСП.
 
 Рекламное место пустует
   ILM
 
11 - 27.12.12 - 18:30
(0) Какой только х...ней люди не страдают. Зачем уже спрашивали?
   ILM
 
12 - 27.12.12 - 18:32
(8) Эй? Люди, что пургу гнать? Там заполнение в зависимости от условий вызывается, после того как вызвалось выходит из процедуры заполнения по Возврату.
   Джинн
 
13 - 27.12.12 - 18:33
(10) Откуда там БСП?
   mehfk
 
14 - 27.12.12 - 19:22
(13) Нет? Значит показалось.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует