Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Подключение весов к 1С

v7: Подключение весов к 1С
Я
   KrutoyDron
 
26.12.12 - 13:28
Здравствуйте. Хочу подключить весы к 1С использую MSCOMM32.OCX. все бы нормально но не все. С помощью одной проги узнал что весы отправляют в середине строки символ #0 и 1С распознает его как конец строки. К примеру "вес # 30 kg", "вес" получаю а "30 kg" нет. как решить проблему помогите.
 
 
   defini
 
1 - 26.12.12 - 13:50
(0) А СтрЗаменить() не?
   KrutoyDron
 
2 - 26.12.12 - 14:12
(1) нет
делаю так Сообщить(СтрЗаменить(Драйвер.Input, Симв(0),"D"));
   defini
 
3 - 26.12.12 - 14:53
А если так:
Стр = СокрЛП(Драйвер.Input);
Сообщить(СтрЗаменить(Стр, Симв(0),"D"));
   KrutoyDron
 
4 - 26.12.12 - 15:23
(3) тоже нет
   KrutoyDron
 
5 - 26.12.12 - 15:34
Процедура ПриОткрытии()

Попытка 
    Драйвер=СоздатьОбъект("MSCOMMLib.MSComm.1"); 
Исключение 
    Предупреждение("Не могу создать объект");    
    Возврат; 
КонецПопытки; 
Драйвер.CommPort = 2;   
Драйвер.Settings = "9600,N,8,1";

Попытка 
    Драйвер.PortOpen=1; 
Исключение 
    Предупреждение("Не могу открыть порт");    
    Возврат; 
КонецПопытки; 
Если Драйвер.PortOpen=0 Тогда 
    Предупреждение("Не открыт порт");    
    Возврат; 
КонецЕсли;  
Сообщить("Создан объект "+Драйвер+" и включен");
КонецПроцедуры

 //*******************************************
 
Процедура ПриЗакрытии()
    Драйвер.PortOpen=0; 
    Драйвер=0; 
КонецПроцедуры
   Lionee
 
6 - 26.12.12 - 16:42
а что за весы ?
   Torquader
 
7 - 26.12.12 - 19:43
Предлагается использовать MSScriptControl, где вставить код на VbScript, передающий, что нужно, и анализирующий, как нужно.
А этот код уже вызывать через команду Run, от MsScriptControl.
Также можно написать OLE-объект через Windows Script Component, который возвращает нужное число или код ошибки, а все танцы с весами будут вообще далеко от 1С.
   KrutoyDron
 
8 - 26.12.12 - 23:12
(6) cas nt-570a
   Ganiev
 
9 - 27.12.12 - 09:15
Стр = СокрЛП(Драйвер.Input);
Код1 = КодСимв("#");
 
Код2 = КодСимв("0"); 
СтрЗаменить(Стр,Симв(Код1),"D");
СтрЗаменить(Стр,Симв(Код2),"D");
Сообщить(Стр);
   KrutoyDron
 
10 - 27.12.12 - 09:27
(9) Код символа я как раз знаю это "0" в 1С или #0 в системах типа дэлфи и т.д или 00 как HEX
 
 Рекламное место пустует
   Ganiev
 
11 - 27.12.12 - 09:39
Если не ошибаюсь то 1с распознает #0 как 2 символа # и 0 !
   timax
 
12 - 27.12.12 - 09:44
Читай руководство к весам. Обычно в самой железке куча настроек в т.ч. по формату сообщения. Работал с весам AND и Vibra.
   KrutoyDron
 
13 - 27.12.12 - 09:53
народ вот руководство но на энглише кто может разобратся
http://www.cas-polska.com.pl/zalacznik.php?id=321&element=335
   KrutoyDron
 
14 - 27.12.12 - 09:58
есть у кого-нибудь хотябы похожее на русском

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует