Вход | Регистрация


1С:Предприятие ::

Метки: 

v7: Редактирование.

Я
   Eeakie
 
26.12.12 - 11:40
Доброе утро.

Обычное редактирование справочника в списке. Редактируется только наименование. Остальные реквизиты даёт редактировать, но не записывает. Никаких ошибок не выскакивает: просто после энтера возвращает прошлое значение реквизита вместо написанного нового. Что может быть?
 
 
   Eeakie
 
1 - 26.12.12 - 11:42
+ В диалоге всё редактируется нормально. Есть кнопка, вызывающая форму элемента.
   andreymongol82
 
2 - 26.12.12 - 11:43
А в форме списка ничего не "накодировано"?
   Азат
 
3 - 26.12.12 - 11:43
а не периодические реквизиты?
   alex74
 
4 - 26.12.12 - 11:43
СтатусВозврата(0) в коде
   alex74
 
5 - 26.12.12 - 11:44
+ (4) в модуле формы списка
   Eeakie
 
6 - 26.12.12 - 11:45
(2) То есть?
(3) Нет.
(4) Есть, но он нужен в ПриСменеВладельца().
   Eeakie
 
7 - 26.12.12 - 11:45
(5) Есть однотипный справочник, где всё нормально работает с таким же кодом.
   Эмбеддер
 
8 - 26.12.12 - 11:46
у меня было что я программно не мог поменять перед записью поля кроме тех, что были в форме списка. добавил на форму эти поля, но сделал невидимыми
   alex74
 
9 - 26.12.12 - 11:46
(6) в данном случае он отрабатывает у тебя в ПриЗаписи()
   Eeakie
 
10 - 26.12.12 - 11:48
(9) Это весьма и весьма печально. Как обойти проблему можно? Часто получается, что при открытии данного справочника меняется владелец и без ПриВыбореВладельца() тут не обойтись...
 
 Рекламное место пустует
   alex74
 
11 - 26.12.12 - 11:50
(10) не вижу никакой проблемы. Программа работает как и положено.
   Эмбеддер
 
12 - 26.12.12 - 11:51
тестирование и исправление?
   Eeakie
 
13 - 26.12.12 - 11:53
(12) Поможет? :)
(11) Ну, хорошо. ПриЗаписи() вообще нет в коде. Работает то как положено, но не так как "нужно" :)
   Ёпрст
 
14 - 26.12.12 - 11:55
ремишь весь  код в форме списка, для начала, проверяешь.
Если всё норм - смотришь, чего ты там натворил в предопределнных процедурах.
   alex74
 
15 - 26.12.12 - 11:55
(13) поставь в отладчике точку останова на СтатусВозврата(0) и посмотри почему он туда попадает
   Ёпрст
 
16 - 26.12.12 - 11:56
и где ты там статусвозврата в 0 заточил.
   Eeakie
 
17 - 26.12.12 - 11:59
Закомментил СтатусВозврата(0) и воткнул туда сообщение. Не доходим туда... Я так понимаю не в нём дело значит. Из предопределенных только ПриВыбореВладельца() и ПриЗакрытии().
   Ёпрст
 
18 - 26.12.12 - 12:02
(17) тогда смотри формулы текстовых реквизитов
   Eeakie
 
19 - 26.12.12 - 12:02
Процедура ПриЗакрытии()
    ОткрытьФорму(Владелец, , 0);
КонецПроцедуры// ПриЗакрытии()
 
//===================================================================================

Процедура ПриВыбореВладельца()
    Сообщить("Печаль!");
    СтатусВозврата(0);
    Возврат;
КонецПроцедуры


Больше ничего толком то и нет в коде.
   Eeakie
 
20 - 26.12.12 - 12:03
(18) Формулы все пустые.

Есть момент один. Висит кнопочка для редактирования в диалоге. На ней висит процедурка:

Процедура ВДиалоге()
    РедактироватьВДиалоге(1); 
    ОткрытьФорму(ТекущийЭлемент(), , 0);
    РедактироватьВДиалоге(0);
КонецПроцедуры


Случайно не здесь косяк?
   alex74
 
21 - 26.12.12 - 12:04
а есть процедура ПриНачалеРедактированияСтроки() ?
   Eeakie
 
22 - 26.12.12 - 12:05
(21) Нету.
   Ёпрст
 
23 - 26.12.12 - 12:08
не все формулы посмотрел, значит
   Eeakie
 
24 - 26.12.12 - 12:09
В форме элемента всё нормально сохраняет. Чёрт.
   Eeakie
 
25 - 26.12.12 - 12:10
(23) Есть еще функция, выводящая информационную строку на форму списка.
   Eeakie
 
26 - 26.12.12 - 12:11
(23) Все формулы посмотрел. Везде пусто.
   Ёпрст
 
27 - 26.12.12 - 12:12
(26) дай мд посмотреть
   alex74
 
28 - 26.12.12 - 12:13
ну значит не получится...
   Eeakie
 
29 - 26.12.12 - 12:15
Уууу... в функции были переменные, которые имеют названия реквизитов. Всё, работает. Спасибо всем.



Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует