Вход | Регистрация


1С:Предприятие ::

Метки: 

v7: Восстановление узла РИБ

Я
   Dem1urg
 
25.12.12 - 19:55
Есть центральная ИБ с уже созданной структурой РИБ. Все хозяйство некоторое время работало. Одна из переферийных баз перестала использоваться. Потом её решили реанимировать, но самой базы уже нет. Как можно заново её создать? Все данные есть в центральной. При выгрузке для периферийной и попытке загрузки этого файла в новую пустую базу выдает ошибку "Файл содержит только изменения".
 
 
   Скользящий
 
1 - 25.12.12 - 20:50
Насколько я помню, можно правкой таблиц сделать так, что периферийная база станет невыгруженной, и сделать опять первичную выгрузку.
   Скользящий
 
2 - 25.12.12 - 20:54
   Скользящий
 
3 - 25.12.12 - 20:55
Хотя я бы новую создал с другим кодом, это намного надежнее и проще.
   Рэйв
 
4 - 25.12.12 - 20:55
(0)Сделай новый образ переферийной базы.
   Рэйв
 
5 - 25.12.12 - 20:56
ну или как там в 77 это называется.я уже не очень помню
   Dolly_EV
 
6 - 26.12.12 - 06:59
в файле 1SDBSET.DBF (или таблице _1SDBSET, если SQL) в поле DBSTATUS на нужной периф. ИБ вместо "C" ставим "N". Всё, можно выгружать периферийку как "вновь созданную", при этом ID (DBUUID) базы останется старый
   1Сергей
 
7 - 26.12.12 - 07:40
РИБ = УРБД?
   DenLaDen
 
8 - 26.12.12 - 08:00
(0) в центральной удаляешь эту периферийную и заново создаешь
   varelchik
 
9 - 26.12.12 - 11:20
(8) Ага как раз.
Вот только данных ужо не будет.
   andreymongol82
 
10 - 26.12.12 - 11:25
(6) +1. Или если выгрузка большая получается - тогда копируем центральную и в _1SDBSET меняем DBSTATUS у главной и подчиненной (кажется M и C)
 
 Рекламное место пустует
   КонецЦикла
 
11 - 26.12.12 - 11:26
(0) Ну так правильно, в пустую базу нужно грузить первичную выгрузку

(9) Если последний обмен прошел и, как автор пишет, "все данные есть в центре", то почему бы и нет?
Если база очень большая (на SQL) можно запустить вот такой скриптец, сделанный на копии ЦБ:

http://pvv911.narod.ru/article/kak_iz_obichnoi_bazi_sdelat_raspredelennuyu_sql/
   andreymongol82
 
12 - 26.12.12 - 11:30
(11) Зачем так много. У меня получалось достаточно проще путем изменения _1SDBSET, так как все таблички, индексы, процедуры уже есть.
   1Сергей
 
13 - 26.12.12 - 11:30
если стоит миграция "всё всем", то вообще проблем не вижу. Всё делается штатно. Удаляем ПБ из списка, создаем новую с теми же кодом и наименованием. Выгружаем. На филиале загружаем. Редактируем список пользователей. Всё
   varelchik
 
14 - 26.12.12 - 11:30
(11) а ты незабыл что есть еще такое понятие как место создания и центр?
так вот первичка выгрузиться только та что миграция все иб.
а место-центр есно не выгрузиться.
   КонецЦикла
 
15 - 26.12.12 - 11:35
(12) Там в принципе для создания, когда вообще таблиц нет (бывает и такое оказывается иногда, портятся)
(14) А ХЗ какие там правила
Погоди, почему не выгрузиться если это ее объекты? Что-то запамятовал
   andreymongol82
 
16 - 26.12.12 - 11:40
(14) Если правильно подставить все гуиды и коды в обоих базах в DBSET,то должно и место-центр выгрузится
   varelchik
 
17 - 26.12.12 - 11:47
(15) если грохнуть и создать заново то не выгрузиться.
если же залезть в 1sdbset и поставить признак первичной выгрузки опять же не выгрузит, только с признавом все иб.
а потом надо перезаписать все объекты это обы у которых признак место создания и центр и сделать обычный обмен.
так что ненадо ляля.
я ужо скоко раз восстанавливал рухнувщие переферийки из центра.
   КонецЦикла
 
18 - 26.12.12 - 11:49
(17) Хорошо, я уже давно не восстанавливал :)
   varelchik
 
19 - 26.12.12 - 11:51
(17) в догонку.
Хуже с теми элементами у которых признак МЕсто создания.
Их к сожалению восстановить не получиться сами понимаете почему.
Бо их в центре никогда не будет.
   varelchik
 
20 - 26.12.12 - 11:52
(16) читай (17)
   andreymongol82
 
21 - 26.12.12 - 12:19
(17) А если без перезаписи 100500 объектов? Тока копирование и тока ковыряние DBSET
   Ёпрст
 
22 - 26.12.12 - 12:20
(0)

создать клон цб, отрезать лишнее,
поправить таблички, наслаждаться.
   varelchik
 
23 - 26.12.12 - 13:24
(22) можно и так.



Список тем форума
Рекламное место пустует Рекламное место пустует
Выдавать глобальные идеи — это удовольствие; искать сволочные маленькие ошибки - вот настоящая работа.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует